What happened to control over Smart Quotes in iOS?

ra
random_pattern
Posts: 111
Joined: Sun Nov 15, 2009 1:25 am

Sat May 02, 2020 8:12 pm Post

I've been working on a project for many years now. My memory is that there used to be a way for Scrivener iOS keyboard settings in iOS Settings to turn OFF Smart Punctuation (just for Scrivener, not for the whole iPad).

I don't want my iPad to correct quotes to make them smart quotes and smart apostrophes in this project, for which I use Courier. The settings for this project on my Mac in Scrivener MacOS are far more extensive; in the past, the project was always set for NO smart quotes, and that still works in Scrivener 3.

iPad settings allowed me to maintain that (circa 3-4 years ago); but now they don't anymore (unless I'm missing something).

There have been many iOS upgrades in the interim, and also I upgraded Scrivener from 2 to 3.

Today I suddenly realized that my project in iOS is auto-correcting quotes to be smart quotes. I don't want this. It didn't happen (to the best of my knowledge) 3-4 years ago, and now it appears (to me) to be broken.

Have I missed something in the interim? Was that setting removed from Scrivener iOS keyboard settings?

Really appreciate any help on this.

User avatar
Silverdragon
Posts: 1442
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Sat May 02, 2020 8:30 pm Post

Yes, it was removed from the iOS Scrivener settings in v. 1.2.0, as I recall. I too am disappointed that I now have to turn this on/off for my entire iOS device, and that the fine control over which punctuation gets "educated" is gone.
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.5.1
  • Website: https://silverdrag0n.wordpress.com

ra
random_pattern
Posts: 111
Joined: Sun Nov 15, 2009 1:25 am

Sun May 03, 2020 1:27 am Post

Thank you. Now I know I wasn't losing my mind. Appreciate your response.

User avatar
Silverdragon
Posts: 1442
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Thu May 07, 2020 5:07 am Post

I've done a little more digging, and I have come up with a workaround. I tested this on my iPad 6, and while it's not as convenient as the in-Scriv preference, it does let me have smart quotes set on my iPad and still get straight quotes into my scriv project.

  1. Make sure that the extra keyboard row in Scriv is ON. (Settings App->Scrivener->Editor->Keyboard Row)
  2. Edit any Scrivener document.
  3. In the extra Keyboard row, long press the double-quotes button.
  4. Select the double straight quotes (just above the parentheses.)
  5. Again in the extra Keboard row, long press the apostrophe. Replace it with the straight apostrophe (just above the double straight quotes.)
Now you can use the extra keyboard row to input those straight single quotes, double quotes, and apostrophes without interference from the iOS smart quote routines. It's a minor pain, more so if you're using a physical keyboard as opposed to an onscreen keyboard, but it does make dumb punctuation possible without disabling smart punctuation on the rest of your device.

Hope this helps!

BTW, the iOS smart punctuation only seems to work for the Apple onscreen keyboard. if you use a third-party onscreen keyboard (I use several, but the most useful for general purpose input is SwiftKey) this problem goes away.

PPS. Just tested this with my (seldom-used) 3rd party BT keyboard for my iPad. Yes, the hardware keyboard is just as annoying as the built-in Apple keyboard, i.e. it follows the smart quotes setting in iOS. However, the extra keyboard row shows up and works just fine if configured as above.
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.5.1
  • Website: https://silverdrag0n.wordpress.com