Font Defaults to Bold-Italic

Qu
QuietMarin
Posts: 1
Joined: Sat Aug 27, 2016 1:47 am
Platform: Win + iOS
Contact:

Sat Aug 27, 2016 2:08 am Post

I installed a custom font on iOS (Cambria) that had several variants. Unfortunately, I opened the bold-italic variant first, and now it wants to default to that. Specifically, if I write in an empty document on my Windows desktop using Cambria regular (neither bold nor italic), and then sync and open it in Scrivener iOS it will show up as Cambria Bold Italic. If I make changes, sync, and open on my Desktop it will be Bold-Italic there as well.

I can "Select All" in iOS and change the font back to regular Cambria, and I can even set this as the default, but then when I go into a new document in the same project it is still bold-italic. Also, if I used either bold or italic originally I end up losing those.

Is there a way I can fix this directly? Or uninstall the font and try reinstalling, or removing just the bold-italic variant, or something?

Thanks!

sc
scshrugged
Posts: 498
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Sat Aug 27, 2016 2:56 am Post

Try this -- open the project > touch in the editor pane to make it active > select the paint brush in the editor menu bar > that should open to the style tab pane, if not select it > your active font will be at the top of the list > select it to open the text options pane > either select a different font from the scroll list, or tap the circled i at the end of Cambria to open a pane which holds the variants > select what you desire and tap done

EDIT: see following post regarding italics
Last edited by scshrugged on Sat Aug 27, 2016 12:34 pm, edited 1 time in total.
I'm a Scrivener user, not an L&L employee.

sc
scshrugged
Posts: 498
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Sat Aug 27, 2016 12:29 pm Post

My previous post doesn't work to correct the specific issue that @QuietMarin raises. I hadn't experimented enough with italics.

Once an italic font style is chosen iScrivener always reverts to it, regardless of what new choice you've made through text options. When you select a line (or the following line) within the editor that had/has italics in it, your new choice is reverted to italic.

As a clunky work around -- I could select all of the doc text, change its font style, copy the selected text and then paste it into a new doc.
I'm a Scrivener user, not an L&L employee.

Jo
JoeBanks
Posts: 4
Joined: Tue Apr 28, 2020 9:19 am
Platform: Win + iOS

Tue Apr 28, 2020 10:31 am Post

I have this same problem in iOS - my chosen font of Cambria always reverts to bold-italic in the text options even when I change it to regular in the text options for Cambria and "Set as Default Formatting". What am I doing wrong?

Jo
JoeBanks
Posts: 4
Joined: Tue Apr 28, 2020 9:19 am
Platform: Win + iOS

Tue Apr 28, 2020 11:04 am Post

I should add that this reversion to bold-italic in iOS happens after I open the file in Windows (where the text is in Cambra regular) and sync.