can’t remove line break between documents

gr
grahampcharles
Posts: 10
Joined: Thu Jul 05, 2012 8:39 pm
Platform: Windows

Wed Jul 25, 2018 8:45 pm Post

I’m having trouble suppressing the extra line between text documents in my compile. My case is: Level 1 is a “Part” folder and Level 2 is a “Chapter” folder — within each Level 2 folder I have one to several text files that represent different chapter parts, but that I don’t want separated in the final product.

Here’s the relevant part of the .scomp I’ve created:

Code: Select all

Folder Titles:
 Level 1: "PART <$R:part>"
 Level 2: "CHAPTER <$W:chapter>\n\n<$title>"

Folder Title Format:
  - Alignment: Center
    Line Spacing: 2
    Paragraph Spacing After: 24

Text Title Format:
   - Paragraph Spacing After: 0


I think this should suppress all lines between the text files that make up my chapters, but a blank line is being inserted all the same.

What I’ve tried:
* Making sure there’s not a bare “return” character at the end of the text file itself. (There’s not.)
* Removing Document Separator and Line Break After/Before options.

I’m at a loss. Any ideas?

Thanks,

g.

gr
grahampcharles
Posts: 10
Joined: Thu Jul 05, 2012 8:39 pm
Platform: Windows

Mon Dec 03, 2018 6:43 am Post

In poking around, I found that the default Script appearance manages to remove the page break between documents at the same level. Buuuut... I can’t find the .SCOMP for the Script appearance. Can anyone point me to where the default Appearance files (or copies of them) might be kept?

I’m feeling a little frustrated.

Thanks,

g.

gr
grahampcharles
Posts: 10
Joined: Thu Jul 05, 2012 8:39 pm
Platform: Windows

Sun Jan 24, 2021 6:15 am Post

Two years later, I figured this out. It turns out that if you remove the Document Separator option, Scrivener defaults to "\n\n" — that is, a double line feed.

Two things about this:
    1. That seems like a weird default, but,
    2. Whatever, that’s the default. Why don’t you *document* .SCOMP files somewhere? I can’t tell you how many hours I spent on this, for want of a simple list of all the options and their defaults. An undocumented feature is no feature at all.

Okay, rant over. Here’s the solution. Put this into your .SCOMP:

Code: Select all

 Document Separator: "\n" # single LF — if this is left out, you get two \n\n

User avatar
gr
Posts: 2273
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Sun Jan 24, 2021 2:46 pm Post

Accolades for your perseverance.

L&L should update their provided compile formats so that none relies on the Document Separator default. The term should appear in each, even if only to infirm the default. This would be the swiftest and most direct way to prevent anyone else having your same trouble.

For what it is worth (and not that this helps with your long travail, but) it is at least mentioned on the following page that the default is blank line between docs, and the doc separator yaml parameter is displayed there too in an example.

https://scrivener.tenderapp.com/help/kb ... ngs-on-ios

But the real vehicle of scomp guidance at this point is the provided .scomp files themselves, hence my initial suggestion.

I think the scomp/yaml approach ios Scriv uses it pretty cool, though I have not really dug into it much, because all my compiling happens in the desktop app. It will be interesting if desktop scriv goes that way. It is hard to imagine how a full-bore scomp for desktop compile will go down with folks that have absolutely no background in coding!


gr
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin