Font Shortcuts not working

Mi
Mig190
Posts: 4
Joined: Mon Jan 09, 2017 9:40 pm
Platform: Mac + iOS

Mon Jan 09, 2017 9:50 pm Post

Hi...I've been using Scrivener for years. But since the last update, certain keyboard shortcuts for fonts do not work. Example, I like using Goudy Old Style, but the keyboard shortcut to italicize it won't work, but the keyboard shortcut for bold will. With other fonts, all the keyboard shortcuts work. Other Mac programs have no issues with any of the keyboard shortcuts for any font, including Goudy Old Style. Thanks in advance.

Miguel

User avatar
AmberV
Posts: 22433
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Jan 10, 2017 1:03 pm Post

I do not have Goudy Old Style installed, but if you check in Font Book and click on its disclosure triangle, do you see an italic variant installed on your Mac? If not there is nothing to select when pressing Cmd-I.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Mi
Mig190
Posts: 4
Joined: Mon Jan 09, 2017 9:40 pm
Platform: Mac + iOS

Tue Jan 10, 2017 10:45 pm Post

There is a italic variant in the Font Book. And the keyboard shortcut works in Pages and other programs. It just doesn't work in Scrivener.

User avatar
AmberV
Posts: 22433
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Tue Jan 10, 2017 11:24 pm Post

Pages is another monster, not really comparable to Scrivener unfortunately. What other programs are you comparing with? I would try TextEdit, as that is going to be very close to the Scrivener editor, especially at this level of operation.

And in Scrivener itself, if instead of using the shortcut you use the second dropdown menu next to the font name in the Format Bar, do you see “Italic” in the list? It should be, if it is in Font Book, but maybe something is getting lost in the translation.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Mi
Mig190
Posts: 4
Joined: Mon Jan 09, 2017 9:40 pm
Platform: Mac + iOS

Wed Jan 11, 2017 7:50 pm Post

In TextEdit, the italic shortcut did not work and the option in the drop-down menu is grayed out. But if I select the italic button on the toolbox menu, the italic will work. Scrivener is the same way ... the drop-down menu is grayed out, but I can select the italic button with my cursor and I can write in italic.

I tested it with Microsoft Word and the keyboard shortcut works fine and it is not grayed out in the drop-down menu. So to use your words, it is in the Font book, but something is getting lost in translation.

User avatar
AmberV
Posts: 22433
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Wed Jan 11, 2017 10:23 pm Post

Yeah, Word does its own thing as well, in fact if a font doesn’t have an italic variant it will even go so far as to fake it, just slanting the font glyphs on the fly. I don’t think this is quite that problem though since the italic button works.

Maybe try using Font Book’s validation utility in the File menu to see if the font needs repair or if maybe you have duplicates that are confusing the software. It may also be worth it to reset your font cache with a tool like Maintenance. You need to reboot and things may be a bit slow for a while until the caches are rebuilt, but this problem is weird enough that it’s worth a shot.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Mi
Mig190
Posts: 4
Joined: Mon Jan 09, 2017 9:40 pm
Platform: Mac + iOS

Thu Jan 12, 2017 10:56 pm Post

No luck. The Font is valid and there are no duplicates in Font Book. I also cleared my Font Cache and the shortcut in Scrivener is still not working and the pulldown menu is still grayed out.

jk
jkonrath
Posts: 7
Joined: Sun Apr 17, 2011 5:14 am
Platform: Mac

Mon Feb 19, 2018 9:39 pm Post