Click tab bug, Ctrl zoom - going crazy, location

al
alwrite
Posts: 13
Joined: Fri Jul 13, 2012 5:31 pm
Platform: Windows

Thu Sep 26, 2013 7:45 am Post

Re (Beta 0.9.0.1)

Point 1: Can you make a pre-final release release and put back ctrl key zoom functionality - going nuts without it. For the record, I think I’m using Scapple now even more than Scrivener; and no other text tool gets near the use Scrivener gets. But I suspect I'm using Scapple beyond dev's development parameters, sorry.

Point 2: Opened a new note in latest release and I used the tab key in a note and saw it moved everything in the note over by some tab amount. I decided I didn’t want to do that so just dropped the idea of using tab. Subsequently I was creating more notes and sometimes would click in the point around the start of a note’s text and the text inside the note would automatically all ‘tab’ across. It ‘untabbed’ using the undo hot keys.

Point 3: Some of my notes are relatively big - storehouse of text to unpick, summarize or restructure. When I click on one of these, and it is bigger than my zoomed view, the screen is moved to the center of the big note and not where I clicked on the note. I don’t want to be relocated to some other part of the screen just because I clicked a big note or big background.

Also when I click a note and click again, I don’t want to be taken to the end of the note but put at least in the vicinity of where I clicked. [Edit:This behavior is not consistent; sometimes I stay where I clicked, sometimes I'm popped to the bottom of the note.]

Point 4: And now, as I construct this note in Scapple, the text is below the bottom of the visible screen and the scroll bar is not accommodating the growing length of my note and I don’t want to step out of the note to adjust this so I’m typing this in, blind. (As a work around, I had been using the trick of creating a dummy note on some far nether region point of the screen to preserve a cohesive working area.

Point 3 again: I think you guys are real close to perfection here, but for me when I click somewhere I don’t want my screen location altered, ever. Just saying in a friendly way.

Point 5: I was just in the process of selecting this text, or the portion of it I want to select, by using the mouse, clicking at the bottom of the text and ‘pulling the mouse up to select the amount of text I want to copy. But my note extends beyond the top of the screen and dragging my mouse up does not drag the view up so I can’t complete selecting text in this way. And with ctrl zoom off it seems more complicated to zoom out to get the view to make the selection. There is another factor here: I’ve got the text scaled at a comfortable viewing size, so I don’t want to re-size the text just so I can select a portion of text in the note.

Just in: If I use my mouse wheel, while holding clicked state (dexterity required) I can scroll up and select as I go - so I can live with this.

It could be argued I should use another medium to create this note, but this note is a quick and dirty method for me to dash off a hopefully useful message to Scapple devs about how I use this tool. This is a note I want to write, deliver and then destroy without going out of my current writing environment. As someone has already written this has the potential to replace paper and pen(cil) - that’s a pretty big thing in my book. So staying zoomed in and in position and able to use copy tools is elegance for me. Oh oh, it just happened again, the rest of my note is below the screen … and now I’m typing blind again!


Cheers

Now let’s see how my ‘blind’ typing went … (not too bad)

Maybe something could be done in Options to address this.

User avatar
MimeticMouton
Posts: 8679
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Sep 27, 2013 6:21 am Post

Thanks for the feedback! Using the mousewheel + Ctrl to zoom has already been fixed internally; it broke as a side-affect of some changes made to enable the right-mouse-button drag for connections and we didn't catch it before the beta release.

I've reproduced and filed the bugs you note about the lengthy notes extending past the visible space with the various scrolling problems and the board shifting when clicking on the note. You're right, the board shouldn't shift when you select a note; that's not intentional. In testing the scrolling issues while editing the note and selecting text, I was able to scroll the board while making the selection using the arrow keys, so you might try that until this is fixed.

I was not able to reproduce the phenomenon you described where notes indented after clicking near the beginning of the text. Are you able to repeat this and provide steps? Indenting should only happen with Tab or Ctrl+W. If you have the option enabled for notes to inherit the style of the selected note, then new notes created while an indented note is selected would also be indented, but that doesn't sound like what you're seeing.
Jennifer Hughes
(MM for short)

al
alwrite
Posts: 13
Joined: Fri Jul 13, 2012 5:31 pm
Platform: Windows

Sat Sep 28, 2013 1:55 am Post

Thanks for your thoughtful reply ... I think I've said that to you before. You communicate very nicely.

Anyway ... I flicked Scapple on, I created a 3 line note with a return between each line, I placed the cursor at the start of the second line, I hit the tab key, all the lines moved to the right, I did crtl-z to undo the tabbed state, the tabbed state undid, I created a new note accidentally by clicking in the edge between the text of the first line and the note border - but I double clicked and created a new note but the new note had the default note text already tabbed - so the inheritance thing was still on even though I undid the tabbed state. And that was not my original problem.

I tried again to click in front of the first word of my original note with the intention of placing the cursor at the start of the note. I clicked in that spot and the note suddenly tabbed the text as if I had used the tab key in front of the text.

If you can't reproduce this I can only surmise that my computer could be at fault, it has been playing up lately with occasional unexpected crashes. However, I have not had any text typing or formatting issues with any other program, and I've used several. I'm using Windows 7 64bit and regular sort of features.

So it's odd.

Cheers

User avatar
MimeticMouton
Posts: 8679
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Sep 28, 2013 3:32 am Post

Aha, I've got them now. I must not have had the undo order correct before. Thanks very much! Meanwhile if you run across this, use Shift+Tab to remove the indent; that seems to get rid of it for good.
Jennifer Hughes
(MM for short)