Bolding selected text in a Note doesn't work in 1.40 on M1 MacBook Air running Big Sur

to
tokerud
Posts: 1
Joined: Tue Jun 30, 2009 7:21 pm

Wed Dec 09, 2020 10:45 pm Post

I have Scapple 1.40 running on a Mojave MacBook and also on a new M1 MacBook Air. On the Air, bolding or unbolding doesn't work inside a note. But it works fine in 1.40 on my Mojave MacBook.

User avatar
RobG
Posts: 250
Joined: Thu Jan 09, 2020 9:22 am
Platform: Mac

Tue Dec 15, 2020 1:41 pm Post

It works for me on an older Mac with Big Sur.

Does it depend at all on which font you are using? If you use the menus or the keyboard shortcut?

hi
hieuvijjo
Posts: 1
Joined: Wed Feb 24, 2021 4:17 am
Platform: Mac

Wed Feb 24, 2021 4:27 am Post

I can confirm the same bug on M1 Mac Mini running Big Sur.
Immediately after I start Scapple, I can bold text as usual. However, after a few minutes of usage, the function stops working and I have to restart Scapple to bold text again. The bolding text doesn't work as expected whether I use hotkeys or I select menu Format > Bold.
Please help and fix the issue soon. It's a quite annoying bug.

User avatar
RobG
Posts: 250
Joined: Thu Jan 09, 2020 9:22 am
Platform: Mac

Thu Feb 25, 2021 9:45 am Post

OK, we'll look into it. How long after opening Scapple does it happen?

An
Antine
Posts: 1
Joined: Fri Feb 26, 2021 12:58 am
Platform: Mac

Fri Feb 26, 2021 1:03 am Post

I have same problem with the same equipment, M1 Macbook Air/Big Sur, although I have not been able to use bold at any point. I'll be looking forward to an update.

User avatar
kewms
Posts: 7570
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Feb 26, 2021 5:37 pm Post

What specific version of Big Sur? The latest release, 11.2.2, fixes some other display anomalies so it might be worth a look.

Katherine
Scrivener Support Team

ma
magicq99
Posts: 2
Joined: Sat Mar 13, 2021 2:03 pm
Platform: Mac

Sat Mar 13, 2021 2:12 pm Post

I can also confirm this. I just purchased Scapple and use it on a MacBook Air with a M1 chip. I use the latest OS Version 11.2.3

The basic text styles (bold, italic, underline, strikethrough) cannot be applied to a selected note or a selected text. Neither the buttons in the "Note format" inspector nor the hotkeys (CMD-B, etc) have any effect. Selecting the style from the "Format" -> "Font" menu also has not effect.

However, bold text is displayed, if it is already present. For example, when applying the builtin "Title" Note Style, the text appears correctly as bold. In this case, clicking the "bold" button in the inspector or pressing CMD-B still does not have any effect, so the bold style cannot be removed in this case. But it is removed, if any of the other Note Style presets is applied.

It seems like that the buttons and hotkeys for the basic text styles do not work. But the text styles are correctly applied, if they are applied via any other means, like the Note Styles.

Text styles are also correctly applied if the Note Style is copied and pasted using Alt-Cmd-C/V.

So it appears to not be a display issue.

It should also be noted, that other text styles like text size or color can be applied correctly. Only the 4 basic text styles in the first row of the inspector seem to be effected by this bug.

jc
jcarman
Posts: 193
Joined: Sun Nov 01, 2009 6:28 pm

Sat Mar 13, 2021 5:36 pm Post

I have the same issue, but I have an Intel 2020 MacBook Air. Big Sur 11.2.3.

User avatar
xiamenese
Posts: 4798
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Sat Mar 13, 2021 6:23 pm Post

Hmm. I've just installed Scapple 1.40 on my M1 MBA running 11.2.3. Cmd-B on a note bolds all the text, selected text within an existing note becomes bold with Cmd-B. That is on first opening. This, my only board, was created with Scapple 1.40 on the iMac running 10.15.7, if that makes any difference,

@HIEUVIJJO, did you work out how long it took for it to become non-functional for you?

:)

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.3, 16GB RAM, !TB SSID
iMac 27" (late 2015) 11.3, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.5 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

ma
magicq99
Posts: 2
Joined: Sat Mar 13, 2021 2:03 pm
Platform: Mac

Mon Mar 15, 2021 9:15 am Post

This seems to be a weird bug, because right now it works correctly. I did not install any software updates since yesterday. In fact I did not even reboot the machine, just kept it closed and in sleep mode over night.

So far I cannot confirm whether the bug appears after some time of use. But yesterday it definitely did not work, and it behaved like I have described above.