Scapple Mind Map Formatting Bad in Scrivener

User avatar
TromboneAl
Posts: 1064
Joined: Sun Jan 19, 2014 2:17 pm
Platform: Mac

Mon Jan 11, 2021 3:36 pm Post

When I move a Scapple mind map into Scrivener, as described in section 9.5.4 of the Scapple manual, this is the result:

Screen Shot 2021-01-11 at 7.27.51 AM.jpg
Screen Shot 2021-01-11 at 7.27.51 AM.jpg (422.31 KiB) Viewed 391 times


I don't remember that being a problem in the past. Is there a way to make this work??

Thanks,

Al

PS When I move old maps into Scrivener, they display properly:

Screen Shot 2021-01-11 at 7.38.33 AM.jpg
Screen Shot 2021-01-11 at 7.38.33 AM.jpg (308.13 KiB) Viewed 390 times
Al Macy
I usually have the latest Scrivener and Scapple versions.
Let me copy/paste the version from the About box, and I will add it to my signature.

User avatar
kewms
Posts: 6987
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Mon Jan 11, 2021 5:21 pm Post

What version of Mac OS? What version of Scrivener? What version of Scapple?

What you're actually seeing is the Mac OS Quick Look preview of the Scapple file. So it's unfortunately not something that we have a lot of control over, from either the Scapple or the Scrivener side. Alternatives would be to import as a PDF file, or to open the file in Scapple directly.

Katherine
Scrivener Support Team

User avatar
TromboneAl
Posts: 1064
Joined: Sun Jan 19, 2014 2:17 pm
Platform: Mac

Mon Jan 11, 2021 11:10 pm Post

Feel free to move this to the Scapple forum.

Mac, Scriv, Scap versions: 11.1, 3.2.2, 1.4.

I don't want to sound confrontational, but:

1. Like the resolved problem with the jagged or cloud Scapple notes, you do have control over how Mac displays your maps.

2. This happens within Scapple also. If you load the attached Scapple file, and move one note from one to the other, you'll see the same issue. To get this, I dragged and dropped the note "Desires" from one Scapple mind map to the other.

Screen Shot 2021-01-11 at 3.03.21 PM.jpg
Screen Shot 2021-01-11 at 3.03.21 PM.jpg (210.41 KiB) Viewed 358 times


Scene Louella Discusses Arthur.scap
(10.33 KiB) Downloaded 7 times
Al Macy
I usually have the latest Scrivener and Scapple versions.
Let me copy/paste the version from the About box, and I will add it to my signature.

User avatar
kewms
Posts: 6987
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Tue Jan 12, 2021 12:16 am Post

Moving to Scapple forum.

Mentioning up front that the same problem appears in Scapple itself would have been helpful.

Bug reports are most likely to reach the appropriate person if you open a support ticket, here:
https://www.literatureandlatte.com/contact-us

Katherine
Scrivener Support Team

User avatar
TromboneAl
Posts: 1064
Joined: Sun Jan 19, 2014 2:17 pm
Platform: Mac

Wed Jan 13, 2021 2:38 pm Post

kewms wrote:
Mentioning up front that the same problem appears in Scapple itself would have been helpful.

Katherine


I didn't realize that until after I started this thread, when I started debugging it. That is, I wanted to see why some maps displayed okay, and when I dragged something from a known bad map to a test one, I saw that the problem happens in Scapple also.

I suspect this is related to the fix to the jagged/cloud, but I don't have time to continue investigating it.
Al Macy
I usually have the latest Scrivener and Scapple versions.
Let me copy/paste the version from the About box, and I will add it to my signature.

User avatar
AmberV
Posts: 24540
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Jan 13, 2021 3:43 pm Post

Are you seeing this happening with any newly created boards? If so, it may be related to this bug, that we spotted shortly before going on holiday.

New boards will have a larger amount of padding around notes, while older boards retain their original padding for the sake of maintaining original layout. If we didn’t do that, then you would get results exactly like this in the board itself. Note in that thread, the bug is in printing and exporting to PDF—we forgot to add the backward compatibility code to those functions it looks like. The issue may be the same for the Quick Look engine.

If you can confirm it only happens with old boards, then I’ll add it to the list for that specific bug. And note that in that thread I linked to, there is a workaround you can use to “upgrade” a board to the new padding model.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles