automatic note sizing

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Fri Dec 21, 2012 5:21 pm Post

Please make the size of the note adjust automatically to fit the text. Right now, if I type one or two words in a note, they don't fill up the space available. This does strange things to the links, which go to the middle of the (invisible) box, rather than to the text. I know I can resize the box myself, but I don't want to have to do that.

User avatar
AmberV
Posts: 23998
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Dec 21, 2012 5:31 pm Post

It sounds like you may have disabled "Auto-size notes" in the General preference tab. Ordinarily, notes will resize to fit the content up to a certain point (value of "Default width" in New Notes tab).
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Fri Dec 21, 2012 6:05 pm Post

Thanks for this, AmberV, but I then looked at my prefs and that box is still checked. Possibly a bug?

User avatar
AmberV
Posts: 23998
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Dec 21, 2012 6:09 pm Post

Possibly, I would try resetting your preferences file first. Maybe something got jammed up in between beta updates. It's this file:

~/Library/Preferences/com.literatureandlatte.scapple.plist
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Sat Dec 22, 2012 3:41 am Post

Thanks, AmberV, but this file doesn't show in my library. I've tried downloading Scapple again, and again no preferences file in the library - at least, not in the place you suggested. Any thoughts on what to do next? Please be specific, as I'm not very familiar with libraries and other folders I rarely use. Many thanks again!

User avatar
AmberV
Posts: 23998
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Dec 22, 2012 4:41 am Post

Use the "Go" menu in Finder (holding down the Option key if you are on 10.7+), and you should see a "Library" menu item. Click that, then find the Preferences folder. Double-click, and then in the search bar type in "scapple". That should reveal the file.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Sat Dec 22, 2012 8:57 pm Post

Sorry about this, AmberV, but I still have a problem. I'm using Mac OS 10.6.8. The "Go" menu in Finder doesn't have a "Library" item (only Computer, Home, Desktop, iDisk, Applications, Documents and Utilities). There's a "Go to Folder..." option which brings up a search bar but, when I enter Scapple, it's not found. Thanks for your continuing help.

User avatar
MimeticMouton
Posts: 8722
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Dec 22, 2012 9:09 pm Post

If you type "~/Library" in the search for Go to Folder, it should take you to your user library. If you've already selected your home folder in the Finder sidebar, you can just type "Library" in the search, but using "~/Library" should work regardless of where you've got the focus.

Actually, just copy and paste the path from above so you can go straight there: "~/Library/Preferences/"
Jennifer Hughes
(MM for short)

User avatar
AmberV
Posts: 23998
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Dec 22, 2012 10:35 pm Post

And further on that, if you paste the whole thing (including the Scapple plist file bit), Finder will take you straight to that folder and highlight the file for you (though in my experience it doesn't always scroll to it, it will still be highlighted off-screen).
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Sun Dec 23, 2012 4:45 pm Post

Thanks to AmberV and MimeticMouton for your patience. I've now found the prefs file, deleted it and, of course, it comes back when I use Scapple again. Trouble is, my notes are still not automatically sized (and I've made sure that the appropriate box is checked in the Preferences options). Are you able to replicate this on Snow Leopard? Is it perhaps something I'll just have to live with? Scapple is great otherwise.

User avatar
AmberV
Posts: 23998
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sun Dec 23, 2012 9:14 pm Post

Okay, I'm not on Leopard, so maybe there is something I need to check when I get back home. I might need a precise set of instructions I can follow, starting with default settings and a new blank document. Right now I just have my 10.8 computer, so no rush.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Mon Dec 24, 2012 4:11 am Post

Thanks, AmberV. I'm not clear, though, if you need anything more from me other than my original comment that automatic note-sizing wasn't working. (You say "no rush", so it sounds as though you do want something more specific.)

User avatar
MimeticMouton
Posts: 8722
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Mon Dec 24, 2012 4:58 am Post

I haven't been able to reproduce this on 10.6.8, so if you have specific instructions for how to replicate the issue, that would be great. E.g.

1. Create a new Scapple map
2. Double-click with the mouse to create a new note
3. Type "this is a new note"
4. Press the Escape key

Screen captures of your preferences (both the the "New Notes" pane and the "General") might be helpful too to make sure we've got the same set up.
Jennifer Hughes
(MM for short)

go
gomersni
Posts: 20
Joined: Tue Dec 20, 2011 4:14 pm
Platform: Mac

Mon Dec 24, 2012 2:59 pm Post

MM and AmberV: problem solved. I wasn't hitting Escape to end editing. DUMB :-( Sorry about that. (I should certainly read the instructions more closely, but Escape isn't something I'm familiar with from other applications and therefore isn't intuitive; that's my only excuse.) I must say this exchange of correspondence has shown me how good L&L support is - and in the days right before Christmas too. Thanks again, both.

User avatar
MimeticMouton
Posts: 8722
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Mon Dec 24, 2012 5:08 pm Post

Ah, glad that's resolved! Yes, the note won't resize until you've completed working in it (that could get highly annoying otherwise). If you'd rather use the Return key to end editing, instead of Escape, you can check that in the General preferences. And of course if you click somewhere outsize of the note, it will submit your edits and the note will resize; I just happen to work mostly keyboard myself.

Happy holidays!
Jennifer Hughes
(MM for short)