Page 1 of 1

Strange dragging bug

Posted: Fri Nov 09, 2012 9:40 pm
by sschertz
So far I've only had this happen in one scapple map, so I'm not sure if it is repeatable.

In this one map, if I click the canvas some distance away from a particular note and drag (so as to select a group of notes), it seems to insist on selecting that note and start dragging it.

I hope I'm explaining this clearly. Essentially, I'm clicking about a full inch away from a note, but as soon as I start to drag, that note (which I did NOT click on) starts to move as though I clicked and dragged it instead.

At one point in this particular map, I did rearrange things a bit, so it almost seems as though it has remembered that the note USED to be in this spot, and is acting as though it still is.

I've tried to create new maps and repeat this, but so far I haven't had much luck.

Re: Strange dragging bug

Posted: Sat Nov 10, 2012 10:20 am
by KB
That is very strange. It sounds as though the hit-testing is reporting a card beneath the mouse position when there isn't one, but given how the code works, I can't understand how this could happen. I'd be very grateful if you could find a way to get it to happen repeatedly so that I could reproduce it.

Thanks,
Keith

Re: Strange dragging bug

Posted: Sat Nov 10, 2012 4:47 pm
by sschertz
I haven't been able to get it to happen in a new map yet, but I did get it to happen in the same one I was originally working with, although in a different spot. I haven't systematically tested this, but I THINK it only occurs while in full-screen view. Also, in this case, it started after I scrolled the map to see the top.

I recorded a short screen recording showing this in action on my map. Is there an email address where I could send this, along with the map itself? I'd rather not post them on the public forum.

Re: Strange dragging bug

Posted: Sat Nov 10, 2012 5:44 pm
by KB
Hi,

Great, thanks. You can send them to our regular support email address, mac.support AT literatureandlatte DOT com, or to scapple.support AT literatureandlate.com.

All the best,
Keith

Re: Strange dragging bug

Posted: Fri Nov 23, 2012 2:44 am
by Eddy
I too have experienced this bug - did you get to the bottom of it Keith, or would you like another map to look at?

Cheers!

Re: Strange dragging bug

Posted: Fri Nov 23, 2012 10:37 am
by KB
Could you send me another map? That would be great - I don't recall receiving one from sschertz yet, unless I missed it.
Thanks!
All the best,
Keith

Re: Strange dragging bug

Posted: Fri Nov 23, 2012 3:36 pm
by sschertz
Hmm, I sent an email with the map on Nov 12. I had some issues because the .mov file illustrating the issue was rather large. I'll try sending just the map alone again.

Re: Strange dragging bug

Posted: Fri Nov 23, 2012 4:28 pm
by KB
Strange - what email address did you send it to? Was it to mac.support or scapple.support AT literatureandlatte DOT com? Either should work... I just checked our support system to make sure your email hadn't fallen through the gaps and just not been queued to me for some reason, but I can't find it at all, so it does look as though it never made it through.

Re: Strange dragging bug

Posted: Sat Nov 24, 2012 1:15 am
by sschertz
It was the scapple.support email, both times. Coming from a gmail account via apple mail - as far as I can tell on my end, it was sent (it isn't stuck sitting around in an outbox or anything like that.)

Re: Strange dragging bug

Posted: Sat Nov 24, 2012 1:59 am
by KB
Strange - could you please try the mac.support@ email address instead, then, just in case we are experiencing some strangeness with our newly-set-up Scapple account?

Thanks,
Keith

Re: Strange dragging bug

Posted: Thu Nov 29, 2012 1:26 am
by Eddy
Sent the map a couple of days ago to both addresses. Hope it arrived ok :)

Re: Strange dragging bug

Posted: Mon Dec 03, 2012 10:15 am
by KB
Thanks for the map! Now that I can reproduce it, this is on my list for fixing - it's a tricky one.
Thanks and all the best,
Keith