Set language

ze
zeitenflug
Posts: 3
Joined: Fri Mar 08, 2013 8:55 am
Platform: Mac

Tue Sep 27, 2016 3:23 am Post

Hi,

I'd really like to set the language of a document within Scrivener. As a writer, I frequently work for publishers both in the US and in the UK. My default language on MacOS is US English. This makes Scrivener assume that my documents are US, even when they aren't. If I switch the system preferences, it makes Scrivener assume, all my documents are UK, even when they aren't. I can use "spell check now" and set the language - however, this is not permanent, and Scrivener tends to lose the setting next time I start Scrivener. Also, if you have more than fifty chapters in a novel, it really makes this a pain to spell-check.

The current status is, if you want to switch the language Scrivener is using, you have to do it in MacOS system preferences, then reboot, then start Scrivener. And you have to remember to set it back, when your Scrivener session is over. This really is a nuisance and costs tons of time.

Minimal proposed solution: Setting a language through Scrivener -> preferences -> corrections

Ideally: Setting a language for each document through Scrivener -> right click -> spelling & grammar -> set language

Tom

User avatar
AmberV
Posts: 24648
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Sep 30, 2016 12:29 am Post

We do not have much control over how spell check works, that’s one of those things where as a developer you ask for the system to do a thing, and it does it in your window, but the hosting application that is having the operation done to it doesn’t have any say on how that is done.

That said, you really shouldn’t have to reboot just to change which spell check dictionary you are using. It sounds like you might be inheriting your spell check default settings via adjusting the localisation for the entire system (which yes, is most easily accomplished with a reboot). All you really have to do though is change one drop-down in the Keyboard System Preference pane, under the “Text” tab to impact all spell check instances system-wide (the underscores don’t update, just hit Cmd-[ and Cmd-] to jump back and then forward in history and thus refresh the text display).
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

mr
mrfuches
Posts: 18
Joined: Mon Apr 04, 2011 12:40 pm
Platform: Mac + Windows
Location: London
Contact:

Fri Jan 25, 2019 11:58 am Post

Same here. Every time I open a project I have to open the Spelling and Grammar window and tell Scrivener, AGAIN, that this project is in U.S. English. (I live in the UK, so my system dictionary is set for that; I write overwhelmingly for US audiences, so my writing uses US spellings.) EVERY SINGLE TIME. Surely, you can make the project remember its spelling preference? Thanks very much.

Jo
JoRo
Posts: 828
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Fri Jan 25, 2019 1:01 pm Post

Apparently, it's a system-level setting that Apple doesn't let individual apps override:

viewtopic.php?p=282485#p282485

Request to Apple, perhaps?

Slàinte mhòr.

User avatar
xiamenese
Posts: 4701
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Fri Jan 25, 2019 1:06 pm Post

mrfuches wrote:Same here. Every time I open a project I have to open the Spelling and Grammar window and tell Scrivener, AGAIN, that this project is in U.S. English. (I live in the UK, so my system dictionary is set for that; I write overwhelmingly for US audiences, so my writing uses US spellings.) EVERY SINGLE TIME. Surely, you can make the project remember its spelling preference? Thanks very much.

First off, I have to admit that I have check spelling turned off while writing. I tend to do the spell checking on my compiled RTF opened in NWP—where documents or even strings can be marked as being in particular languages—though occasionally I run it in Scrivener.

That said, I've just checked this on my MBP. Edit > Spelling and Grammar > Show Spelling and Grammar is always set to the default "Automatic by Language, so I changed it to Indian English, closed the project and shut down Scrivener. I then re-opened Scrivener and the project and Show Spelling and Grammar was back to "Automatic by Language".

I can understand the frustration this can cause; whether KB can find a way round it is beyond my scope. For me, I've always found Apple's in-built spell checker to be not very good, but in 10.14 particularly it's so borked that it's even more of an irritation.

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

Ma
Maelduin
Posts: 889
Joined: Fri Apr 25, 2008 7:49 pm

Fri Feb 08, 2019 11:08 am Post

Every Mac, every program I've ever used has tried to convince me that I speak American. I see it as a symptom of the hegemony of the running dogs of the capitalist paper tiger.
Image

 

 

cron