strange bug in 1.702

User avatar
Marta
Posts: 537
Joined: Sat Feb 05, 2011 2:23 am
Platform: Windows
Location: Los Angeles
Contact:

Wed Feb 12, 2014 8:38 pm Post

A bit difficult to explain, and a screengrab did not show it, but there are SOME folders in a project that -- when opened in corkboard view, that section shakes.
Imagined a shaky zoom in/zoom out by a bad cameraman and you get the idea
they are folders with graphics.
However I have folders with many more graphics that DO NOT shake

I closed the Beta, opened Scrivener's standard release, looked at those folders. No problem

I closed that, went back to the Beta, same folders continued to shake

HOWEVER when I changed the WIDTH of the corkboard, those folders stabilized. I then could go back to my original width, and they stayed stabilized

will now hum the theme of Twilight Zone :D
Marta
Scrivener 1.9.7.0
http://www.spookyfilms.com

User avatar
garpu
Posts: 2024
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Thu Feb 13, 2014 12:06 am Post

Huh. I can't reproduce this one, and I'm usually affected by most strange bugs.

1.) What kinds of files does it do it with? All text? Lots of nested texts? Research folder with lots of multimedia and pdfs?

2.) Update your video card drivers? Almost sounds like a graphics glitch. Corrupt drivers can do all sorts of strange things.

3.) What corkboard settings are you using? (Corkboard background? Square cards? Pins/no pins?)
Slackware-current 64-bit, XFCE

User avatar
MimeticMouton
Posts: 8718
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Feb 13, 2014 1:59 am Post

Pretty sure this is from a resizing problem that's happening when "cards across" is set to auto. I've gotten the same thing and have already filed a bug for it. Did you have the same setting for the corkboard options from the editor footer?
Jennifer Hughes
(MM for short)

User avatar
Marta
Posts: 537
Joined: Sat Feb 05, 2011 2:23 am
Platform: Windows
Location: Los Angeles
Contact:

Thu Feb 13, 2014 3:01 am Post

MimeticMouton wrote:Pretty sure this is from a resizing problem that's happening when "cards across" is set to auto. I've gotten the same thing and have already filed a bug for it. Did you have the same setting for the corkboard options from the editor footer?


I don't know what this means
"Did you have the same setting for the corkboard options from the editor footer?"
But I didn't change any settings

BTW: speaking of settings, the new 1.702 beta reset my setting to the original factory defaults-- where I want my backups, the image I use for my corkboard, default font for new files, colors on links, etc.

I changed them all back but thought you should know
Marta
Scrivener 1.9.7.0
http://www.spookyfilms.com

User avatar
tiho_d
Posts: 956
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Thu Feb 13, 2014 4:26 am Post

Did you uninstall v1.7.0.1 and install v1.7.0.2 afterwards, Marta or you installed v1.7.0.2 over v1.7.0.1?

User avatar
MimeticMouton
Posts: 8718
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Feb 13, 2014 4:42 am Post

Marta wrote:I don't know what this means
"Did you have the same setting for the corkboard options from the editor footer?"
But I didn't change any settings

Sorry, I was unclear. Did you have the "cards across" in corkboard options set to "auto"?
Jennifer Hughes
(MM for short)

User avatar
Marta
Posts: 537
Joined: Sat Feb 05, 2011 2:23 am
Platform: Windows
Location: Los Angeles
Contact:

Thu Feb 13, 2014 8:37 am Post

MimeticMouton wrote:
Marta wrote:I don't know what this means
"Did you have the same setting for the corkboard options from the editor footer?"
But I didn't change any settings

Sorry, I was unclear. Did you have the "cards across" in corkboard options set to "auto"?


yes, it was set on auto
PS. The project was closed. When I re-opened to check your auto question, folders were fine (no shake)
Marta
Scrivener 1.9.7.0
http://www.spookyfilms.com

si
simeva
Posts: 492
Joined: Thu Oct 06, 2011 2:30 pm
Platform: Windows
Location: Sheffield

Thu Feb 13, 2014 9:43 am Post

I saw this shaking behaviour when I had the 'cards set to auto' problem described here.

User avatar
MimeticMouton
Posts: 8718
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Feb 13, 2014 9:56 am Post

simeva wrote:I saw this shaking behaviour when I had the 'cards set to auto' problem described here.

Yep, it's the same problem. The cards shouldn't be auto-sizing when the cards across is set to auto, and it's making for a number of visual glitches. This should be fixed for the next update.
Jennifer Hughes
(MM for short)