Chapter numbering compile error

L'
L'escritora
Posts: 11
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Tue Feb 11, 2014 8:44 pm Post

okay, so I have my chapters all marked "include" in the Compile stage. However, I noticed that with the beta version chapter 1 keeps its title but is ignored in the numbering. e.g.

1 (chapter number)
Chapter Name

Is what's coded, but for the first chapter the 1 is skipped. Chapter 2 is numbered as 1. Wrong!

Unless:

1) I use <$r> -- which I would have thought yielded the lowercase roman numerals (i, ii, iii), but it uses I,II, III as if I had specificed <$R>. But, at least chapter 1 is acknowledged and the subsequent chapters get their proper numbers. Incidentally, <$R> is also successful.

2) I use <$rst><$n> -- Chapter 1 is titled and numbered (yay!) but now all of subsequent chapters are also numbered 1.

Note that I also tested using <$t> -- Chapter 1 has the title but no number, Chapter 2 is titled and numbered "ONE." Also, I thought that code was supposed to generate a mixed case title, of One. Instead it's in all caps, ONE, as if I had used <$W>. Oh, and <$W> yields the same result as <$t> as far as failing to acknowledge chapter 1.

I noticed that the first time I checked the code, it used <$N>, uppercase "N," and when I corrected it to lowercase "n" it made no difference.

Edited to add that I got the codes from Codes for Compiler" sticky in the Windows tech support forum.

L'
L'escritora
Posts: 11
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Wed Feb 12, 2014 6:41 pm Post

My original post was for Beta 1.7.0.1. The bug is present in Beta 1.7.0.2 as well.

User avatar
MimeticMouton
Posts: 8877
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Feb 13, 2014 10:20 am Post

Could you let me know what format you're compiling to and perhaps post a screenshot of your binder? I'm not reproducing the errors you describe in a simple test case, so there seem to be some extra factors I'm missing. Where are you supplying the numbering, as a title prefix in compile or directly in the binder title?
Jennifer Hughes
(MM for short)

L'
L'escritora
Posts: 11
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Thu Feb 13, 2014 8:47 pm Post

Hello,

It seems to cut across formats: mobi, rich text, plain text, and Preview. I only ever compile to those formats. Further, I don't formally number the chapters. I never had to. In other words, in the binder, each folder has the chapter name, but not the chapter number.

I can't post a screenshot right now, but here's the structure

Manuscript
|
|
Folder for part one (titled, sans number)
->Folder for Chapter 1 (titled, sans number)
->Folder for Chapter 2 (titled, sans number)

This has worked until beta 1.7.0.1. Incidentally, I noticed that the number for the Part 1 folder is skipped post-compile as well. So, when I compile to Preview/Rich Text/Plain Text the document will have:

Title (on part 1's page)
Title (on chapter 1's page, a separate page that immediately follows Part 1)
1 Title (on chapter 2 page)
I Title (on part 2 page)

As I said, I tried various codes to get the first part/chapter to say "1 Title" and not just "Title." And, few of those codes functioned as they ought to have. The code that should output "i, ii, iii" instead outputs "I, II, III," and the code that should output "One" instead outputs "ONE."

I hope this clarifies things. Thanks for your help.

L'
L'escritora
Posts: 11
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Thu Feb 13, 2014 11:41 pm Post

Okay, I'm home now. Here's the screenshot of the binder:

Screenshot-of-binder.jpg
Screenshot-of-binder.jpg (40.05 KiB) Viewed 1134 times


Now here is the compile. The numbers are missing for Chapter 1 and Part 1. Observe that this is the "Preview" compile, so that's why they appear to be on the same page. In the output document they aren't.

Screenshot-of-chapter-1-compile-issue.jpg
Screenshot-of-chapter-1-compile-issue.jpg (30 KiB) Viewed 1134 times


In that same compile, here is chapter 2:

Screenshot-of-chapter-2-compile-issue.jpg
Screenshot-of-chapter-2-compile-issue.jpg (51.13 KiB) Viewed 1134 times


I notice that this is consistent across my custom compiles. Basically, I took the default standard manuscript and added the second folder level (the chapter folders) and changed whether the header numbers are numerals (1,2,3) or text (One, Two, Three). Yes, the beta scrivener knows the custom settings are there, because it honors all the other features of those settings, e.g., using Goudy Old Style and Myriad Pro instead of Courier New for the output text. I hope this helps.

User avatar
MimeticMouton
Posts: 8877
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Feb 14, 2014 12:42 am Post

Thanks for the screenshots! Since this is an issue you're seeing with all your custom compile settings, could you export the settings and attach those here as well? I can use that and the screenshots then to build a sample project modeling your structure and see what's going wrong.

To export the compile settings, open compile and choose Save Preset if necessary to save the settings (if you've already saved them so they're available from the "Format As" pop up menu, you don't need to do this step). Then choose Load Preset, select the custom preset from the list, and click Export to save the settings somewhere convenient so you can upload them here.
Jennifer Hughes
(MM for short)

L'
L'escritora
Posts: 11
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Fri Feb 14, 2014 2:51 am Post

I wasn't allowed to upload an ini file, so I re-saved it as the ANSI format .txt file. Let me know if that will work for you, or if I should re-save in another format.
Attachments
Novel Standard Manuscript Revised.txt
(29.27 KiB) Downloaded 54 times

User avatar
MimeticMouton
Posts: 8877
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Feb 14, 2014 7:29 am Post

Thanks so much; that helped me figure out where the bug is so we can get this fixed. It's coming from the "Not on page one" checkbox in the "Page Settings" section of compile. If you deselect that, the part/chapter numbering should appear correctly. (It will of course mean that during the workaround you'll get the page numbers on page one as well, but that should be an easy fix in a word processor after compiling.)

The other issue you're seeing where the placeholder tags are always coming out as the capitalised version is because in the "Case" tab of the section layout (from the Formatting pane in compile, where you set the prefix), the title prefix is set to uppercase. If you change that to "normal", the prefix and replacement text will appear as you've entered it.
Jennifer Hughes
(MM for short)

L'
L'escritora
Posts: 11
Joined: Wed May 30, 2012 2:36 pm
Platform: Windows

Fri Feb 14, 2014 3:49 pm Post

Thank you! That fixed it. I never even noticed the "not on page one" setting before. Thanks for your help on this :)