BETA 1.5.1.1 RELEASED (*NEWEST - 24th Jan 2013*)

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Thu Jan 24, 2013 9:53 am Post

Hi Beta Testers,

We had a Scrivener crash issue with 1.5.0.9 which has now been addressed in this new release along with another bunch of bug fixes from the beta forum. We have new builds for both Windows and Linux available. Read more details below…

1.5.1.1 Beta Windows Download:
http://www.literatureandlatte.com/scrivenerforwindows/Beta/Scrivener-1511-installer.exe

1.5.1.1 Scrivener Linux tar Package here - > http://www.literatureandlatte.com/scrivenerforwindows/Beta/Scrivener-1.5.1.1.tar

1.5.1.1 Scrivener Linux deb Package here - > http://www.literatureandlatte.com/scrivenerforwindows/Beta/scrivener-1.5.1.1-beta.deb


Bug Fixes in 1.5.1.1

0. Fixed - Scrivener crashes when a project is open and you try to create a new project or open another one - hence a new release - teach me for even suggesting that this could be the last beta before release :) This bug was introduced as a side-effect of another bug fix.

1. Fixed - Inspector Inline Notes lose formatting.

2. Fixed - If I create a text document and apply various colours to the text then compile to .mobi or .epub with the "Remove text color" option checked, the styles in the epub still assign text colours as can be seen by viewing the files.

3. Fixed - Allow the user to specify custom GUI font for Scrivener - Just say "Menu font" or such in the options rather than "GUI". I realize it touches more than the menus, but this is roughly what Windows says, and it will be more user-friendly even than "interface"--GUI is just going to be technobabble. Also, Can we add some indication by the text in the Options that this will require a restart before it is visible? Right now there's no feedback when you hit "Apply" so it seems like the setting didn't take.

4. Fixed - Scrivener freezes and must be force quit when using Find by Formatting to search for text and the next instance of the formatting type does not contain the search term.

5. Fixed - Copy and paste adds extra space before inline footnote. Now the footnotes are compiled with one space in front and no space at the end. for everything else, like copy/paste nothing is modified behind the scenes.

6. Fixed - Links within the document text, document and project notes, and inspector comments and footnotes are lost on saving and reopening a project--the hyperlink code is stripped from the RTF files. This occurs links created in 1.5.0.9 and for pre-existing links. This also currently affects Scrivener links from the latest beta Mac build at time of writing (22136) as it uses a new method to encode the links directly in the RTF.

7. Fixed - Further issues with:- Special characters used in document titles are not properly encoded in the toc.ncx file when compiling to .epub and .mobi, which causes validation errors and text to be undisplayed in readers (e.g. in Adobe Digital Editions, missing titles from the TOC and the title and text from the body). This occurs when either & or < is used in a document title that appears in the table of contents. These characters do appear properly encoded elsewhere in the epub/mobi files. This was mostly fixed in 1.5.0.9, however issues still exist with: Angle brackets, Ampersands in Adobe Digital Editions and Ampersand in meta-data title. (ALL FIXED IN 1.5.11)

8. Fixed - The German close quote is flipped vertically (it uses a double high-reversed-9 quotation mark U+201F instead of a left double quotation mark U+201C). Fix Note: Scrivener now uses pairs of (0x201E, 0x201C) instead of (0x201E, 0x201F). Use pairs of (0x201F, 0x201D) for Greek according to: http://www.tlg.uci.edu/~opoudjis/unicod ... ation.html

9. Fixed - Synopsis image lost on duplicate. If an document with an image synopsis is duplicated, the new copy loses the synopsis image; it should be retained just as a text synopsis is. Additionally this bug occurs when duplicating between projects. Items with image synopses, when dragged from one project binder to another, will lose their images.

10. Fixed/Added - Suggestion: Add Dutch smart quotes style - Add the „…” quotation typography option for smart quotes (Dutch, Polish, Romanian, and several other languages use this style). Nearly all other styles are already represented. As we have a Dutch translation almost done - it makes sense to add it also. Fix Note:- Dutch added and some more styles added according to Wikipedia (http://en.wikipedia.org/wiki/Non-Englis ... tion_marks). Added tooltips for the combo box to show the corresponding country for every quote sign pair.

11. Additional fixes for Partial formatting reversion in linked footnotes & comments bug fixed in 1.5.0.9. The comments and footnotes correctly revert to the default ruler and font settings as described in the 1.5.0.9 report, but now all character formatting is lost as well (bold, italic, text colour, highlight)--this should be preserved. This has now been fixed.


KNOWN ISSUES:
1. Updated shortcut needed for superscript and subscript.
2. User Manual for release 1.5 not implemented.

Regards,

Lee & Tiho

Li
Lilith
Posts: 351
Joined: Sat Nov 13, 2010 3:50 pm
Platform: Windows
Location: Belgium

Thu Jan 24, 2013 5:03 pm Post

Is this just me, or is this really the fastest version I have ever seen ?

User avatar
garpu
Posts: 2015
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Thu Jan 24, 2013 6:12 pm Post

It's pretty fast, yep. :)
Slackware-current 64-bit, XFCE

User avatar
tiho_d
Posts: 866
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Fri Jan 25, 2013 8:42 am Post

We did some optimizations. I am very happy that you have noticed it, guys. Thanks for mentioning it here!

User avatar
narrsd
Posts: 658
Joined: Wed Sep 22, 2010 8:34 pm
Platform: Win + iOS

Fri Jan 25, 2013 10:08 am Post

Hard not to notice, Tiho -- it really zips!

User avatar
StaceyUK
Posts: 958
Joined: Mon Apr 13, 2009 5:00 pm
Platform: Mac, Win + iOS

Fri Jan 25, 2013 2:58 pm Post

Agreed! Really liking the new beta.
Blessings, Stacey

System Specs

Windows 7
Scrivener 1.9.7 / 2.8 /3.0.3/1.1.5 (1301)
Scapple 1.0.0.0
Windows 2.9.0.26 Beta

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Fri Feb 01, 2013 1:17 pm Post

Big smiles here :)

ur
urlwolf
Posts: 31
Joined: Thu Sep 29, 2011 11:55 am
Platform: Windows

Tue Feb 05, 2013 1:16 am Post

Is there a bug tracker? Or should we post bug and feature requests here?

ur
urlwolf
Posts: 31
Joined: Thu Sep 29, 2011 11:55 am
Platform: Windows

Tue Feb 05, 2013 1:24 am Post

Ok, I'll post here...
I just installed the tar on fedora 18 and it looks beautiful. Integrates well with gnome shell.
On ubuntu, though, it looks like a win 98 app.This is the version I use daily, and I cannot remember if I changed some defaults (to make it a bit prettier).

Any way to touch appearance so it goes back to default, or gnome in my case?
Thanks
PS: I'm running gnome shell on ubuntu too, so the two environments should be very similar.

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Feb 05, 2013 1:26 am Post

If you find a bug in the most recent beta (1.5.1.1), please create a new topic for it in the beta forum here and provide as much detail as you can about the bug and steps to reproduce it, if you can. Let us know also what version of Windows you are using and anything else about your setup that appears pertinent to the bug (e.g. if it has to do with typing, and you use a custom keyboard, that would be relevant). Take a quick look through the previous topics as well to make sure that the bug hasn't already been reported by someone else; if you see it, just add a new post to that existing thread if you have additional information to provide. Thanks!
Jennifer Hughes
(MM for short)

ur
urlwolf
Posts: 31
Joined: Thu Sep 29, 2011 11:55 am
Platform: Windows

Tue Feb 05, 2013 1:28 am Post

It could be that I installed this deb when I was running kde. It didn't pick up any styling. KDE has some tool to sking gtk apps so they look like gnome. In this case it might have failed.

Another option may be to nuke my preferences file, and reinstall. But I have a lot of shortcuts, options, etc...

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Feb 05, 2013 1:30 am Post

Urlwolf - I suggest posting in the Linux forum if you haven't--you might get some helpful input from other users on Ubuntu sooner than Lee or Tiho can comment on this.
Jennifer Hughes
(MM for short)

no
norstrom73
Posts: 5
Joined: Sat Dec 15, 2012 3:36 pm
Platform: Windows

Wed Feb 13, 2013 3:05 pm Post

I'm getting this error when clicking the link to download the update:

"The requested URL /scrivenerforwindows/Beta/Scrivener-1511-installer.exe was not found on this server.

"Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Is this me? Or is the link on the page not working?

Thank you.

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Feb 13, 2013 3:48 pm Post

norstrom73 wrote:I'm getting this error when clicking the link to download the update:

"The requested URL /scrivenerforwindows/Beta/Scrivener-1511-installer.exe was not found on this server.

"Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Is this me? Or is the link on the page not working?

Beta testing for this has closed, as 1.5.3 has now been released, so the 1.5.1.1 beta is no longer available.
Jennifer Hughes
(MM for short)

no
norstrom73
Posts: 5
Joined: Sat Dec 15, 2012 3:36 pm
Platform: Windows

Wed Feb 13, 2013 5:11 pm Post

Well now I feel a little silly. :oops:

Then where can I find the 1.5.3 release? When I open Scrivener I'm getting a prompt telling me the Windows Beta expired on Feb 01 and to download an updated version from this site.

Thanks