User avatar
Posts: 1023
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney

Sun Dec 23, 2012 11:19 pm Post Beta Download ... taller.exe

Beta Expiry = 1st Feb 2013

Likely release date is still Jan 2013. We are currently working through other bugs reported and will release in the next few weeks. This should include the updated manual with all the new 1.5 features.

I just want to thank you all again for your continued support with beta testing and wish you all a wonderful Christmas and New Year.

Bug Fixes for

- Inspector footnotes reverting after using the context menu to convert them to comments

- Comments within comments is implemented

- Marking selected plain text as an inline annotation via keyboard shortcut Ctrl+Shift+A sometimes requires doing the shortcut twice

- Spellchecker works with En Default and Custom Quotes now

- Fixed straighten quotes option when compiling. Works with En Default and Custom Quotes

- Inspector comments are excluded when compiling to formats other than RTF, DOC, and DOCX. They should be treated the same as annotations, simply compiling inline using the markers specified in Compile. FIX NOTE: Please check Footnotes functionality. Footnotes Override font was applied only to RTF, Doc, Docx files before. Footnote Font Overriding is applied to all formats now, if footnotes are kept. Footnotes are converted to Endnotes for NON RTF, Doc and Docx formats

- When compiling to an RTF-based format, if the final character of a paragraph is linked to an inspector comment or footnote, neither the note nor any document text following the linked text appears in the compiled output

- It is possible to include invalid filename characters in the title of a Scratch Pad note; the note will not save, and all text in the note and title will be lost. FIX NOTE: Renaming a document to an existing document name raises a warning and cancels renaming to avoid data loss due to overwriting other documents

- When a page break comes directly before a document (DocA) that is compiling only its title and that does not have page padding, the compiled document contains a break both before and after DocA's title. Occurs for pdf, rtf, doc, docx, odt, and that it happens whether the page break is inserted via Edit > Insert, Page Break Before, or a Page Break separator in compile. FIX NOTE: This Bug might influence other cases with Titles included in compilation. Testing of many Title Document cases is recommended

- Fixed drag shape of index cards on cork board to reflect actual shape of index card i.e. rounded or square edge rectangles

- Fixed some unicode parsing bugs

- Corkboard - fixed rounding drag shape when rounded cards are dragged

- Corkboard - fixed the clipped index cards while dragging. Cards that are selected, but not visible are also displayed now during drag and drop

- Corkboard - Dragging cards that are far away and not visible might result in a big image for drag and drop, much bigger than the screen. Mac is using another approach for Drag n Drop and displays only the first dragged card with a red mark showing the total number of cards dragged. Implementing the Mac Drag n Drop style is better and more accurate in general as we combine all drags into one place. We might think about implementing the Mac Style in the future 2.0 release. Our current implementation is more Windows style and makes perfect sense too

- Corkboard - The semi transparency while dragging results into different shades within the card because of the shadow rectangles. We have removed the shadows while dragging and kept the transparency

- When cells in the first column of a table are merged, the table cells shift and get deleted when the project is closed and reopened. FIX NOTE: this bug is fixed however for nested tables (tables within tables) there are still issues

- Removed the font-family from Mobi and ePub formats

- All arrow keys now work as expected with the binder and editor (left, right, up and down)

- Bug fixed with comments not terminated properly


User avatar
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Mon Dec 24, 2012 2:26 pm Post

Thanks for the birthday present! :)
Slackware-current 64-bit, XFCE

Posts: 25
Joined: Sat Aug 20, 2011 5:03 am
Platform: Windows

Mon Dec 24, 2012 11:02 pm Post

Well, this is a nice surprise for Christmas.

Posts: 2
Joined: Wed Dec 26, 2012 2:04 pm
Platform: Linux + Windows

Thu Dec 27, 2012 7:15 pm Post

Thank you!

Posts: 43
Joined: Sat Sep 08, 2012 6:11 pm
Platform: Windows

Sun Dec 30, 2012 7:46 pm Post

I just downloaded this and retried some of the things I posted here.

The numbering issues still persist (no surprise, since the release notes didn't say anything about them. I think part of the issue may be that I have non-default margins, and when you unindent out to the outer level, you get a different level of indentation than items originally created at the outermost level.

The Scratch Pad titling is fixed (per the release notes), thanks.

I tried putting my laptop to sleep a few times and hibernating it once, and did not see the problem where Scrivener disappears either. That's great because I was worried about data loss. Still, I didn't see anything about a fix for this issue, so I wouldn't be surprised to see it again. If I see it return, I'll post a follow-up.

Still very much looking forward to the day when creating Scrivener links is easier.

Thanks for all the great work here!

Posts: 11
Joined: Fri Dec 28, 2012 5:36 am
Platform: Windows

Tue Jan 01, 2013 3:35 am Post

I am new to Scrivener. I just downloaded version and I have been using it for the past few days.
I noticed that the new release has comments working on it and I would like to try this feature as I miss it from Word. However I don't wish to delete my current version of Scrivener so I am wondering if there would be any issue if I had both and loaded on the same machine?

User avatar
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Tue Jan 01, 2013 6:49 pm Post

rookie wrote: However I don't wish to delete my current version of Scrivener so I am wondering if there would be any issue if I had both and loaded on the same machine?

Nope. I believe in the README, they recommend installing it to a different directory, namely ScrivenerBETA.
Slackware-current 64-bit, XFCE

Posts: 11
Joined: Fri Dec 28, 2012 5:36 am
Platform: Windows

Tue Jan 01, 2013 8:10 pm Post

Thank you so much for your reply. I will give it a shot now. Thanks.

Posts: 11
Joined: Fri Dec 28, 2012 5:36 am
Platform: Windows

Tue Jan 01, 2013 9:44 pm Post

I just installed the new version and started playing around with the "comments".

I am not sure if this is the right place to post this but I would like to point out two issues that I have with comments. First I would like to be able to edit the comments. From what I can tell now I can not go back and edit an existing comment. I would also like to see a numbered correlation between the comment and a number in the text.

I guess there are three changes I would to see implemented. I would also like to increase the size of the text in comments.


Posts: 48
Joined: Thu Dec 06, 2012 1:06 pm
Platform: Windows
Location: France

Wed Jan 02, 2013 2:42 pm Post

Hi Rookie, to edit a comment you have to double-clik on it in the Inspector area.
To locate in the Inspector the comment to edit, you can click on the commented text in the editor.

User avatar
Posts: 716
Joined: Wed Sep 22, 2010 8:34 pm
Platform: Win + iOS

Wed Jan 02, 2013 8:51 pm Post

Well, a great New Year's present to find...

Somehow I kind of suspected you might be up to something like this, and checked via Scrivener itself, but was 'all up to data' a day after Christmas.

So finding this proves I visit the forum, yes ;)

You guys are really burning up the keyboards, I think. Simply lots appearing in Scrivener, and thanks for it.

I had a look at the inspector footnotes presentation as well as their compiled output again briefly, just to be responsible since posting on these, but really I am just patient. I think there might have grown one more problem, that there's no text in the inspector view, but that's probably just part of the general not-yet-transmutation-fully-to-inspector-version status.

Lee, and Tiho, also Keith and entire crew, much good fortune in the new year. Pay no attention to any American politics -- it's reached the Wizard of Oz stage. Actually I am not far from where L. Frank Baum lived. Also Dr. Seuss. It's a real zoo sometimes around here ;).

Due to Christmas, I am also one of those anticipating in iPad variant fortunes...really interested in what you guys come up with there.

Last edited by narrsd on Thu Jan 03, 2013 7:29 pm, edited 1 time in total.

Posts: 6
Joined: Tue Nov 02, 2010 6:51 pm
Platform: Windows

Thu Jan 03, 2013 5:23 pm Post

Thank you for the Xmas present! I was using Beta 1.2. 5 something or other and I couldn't compile. In fact, I hadn't checked the forums for a while, because I had an earlier free version that I had been very kindly given for contributing to the the forum discussion of beta testing in 2010/2011. So I was under the impression I didn't even need to check the forums. And every time I pressed "search for updates," in Scrivener, it came back saying Scrivener was updated. So, I thought I was up to date and that I didn't need to do anything. Flash forward to today, when for the first time, I tried to compile the behemoth I've been working on for the past 2 years (novel #2, already over 50,000 words, and I'm not even halfway through, so there will be serious editing whenever I get to the end).
Every time I even pressed the compile button, Scrivener simply closed and went away. When I opened it back up again, everything was there, but it refused to even acknowledge compiling as an option. So I went to the forums and downloaded the latest beta and now it compiles beautifully. I am a complete technical idiot, so this was a double relief: easy to do, easy to fix. Happy New Year!