Page 1 of 1

Scrivener has encountered an invalid system date[FIXED]

Posted: Sat Jun 16, 2012 1:54 am
by gwsk5597
After installing the latest beta (#7), I found the program refused to start. Inexplicably, it thinks I've changed my system date, which I definitely haven't done. So I have to say that maybe something in the registration part of the program might now be broken.

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 2:00 am
by AmberV
Thanks, I'm getting the same thing on the one machine I've updated. I've already informed Lee.

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 2:37 am
by Bdillahu
Yep, same here. Win 7, 64bit, installed "over" the previous beta version.

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 4:15 pm
by AmberV
Can you all confirm if this has gone away? I was informed that it might have just been a timezone bug, and to give it a night for the day to change. Basically it was coded to check for the date of the build time, and being built in Australia, anyone on the other side of the date line would have been a day prior. Now that a night has gone by for the rest of us, it should be working. My copy is now loading.

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 4:28 pm
by gwsk5597
It's gone. Really weird bug, though.

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 6:41 pm
by Bdillahu
I concur, it's working here on the US East Coast (Eastern time zone) now...

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 8:37 pm
by AmberV
Great, thanks all!

Re: Scrivener has encountered an invalid system date...

Posted: Sat Jun 16, 2012 9:58 pm
by MimeticMouton
Oh good, I was wondering if that was what it was...

Re: Scrivener has encountered an invalid system date...

Posted: Sun Jun 17, 2012 1:32 am
by LAP
Phew!

Okay, I'll augment the code to be tolerant of other timezones. I'm very sorry to scare folks like that.

Lee

Re: Scrivener has encountered an invalid system date...

Posted: Mon Jun 18, 2012 7:47 pm
by nemesishaven
This happened to me too. I assumed it was because I tried to install the beta on the 15th of June (EST), when its release date was the 16th. I just moved my clock forward a day and it was fine (I've since moved it back).

Re: Scrivener has encountered an invalid system date...

Posted: Mon Jun 18, 2012 7:51 pm
by AmberV
Amusing that tampering with the clock fixed the check that suspected you of tampering with the clock. :)

Well at any rate going forward this shouldn't be an issue.