Scrivener has encountered an invalid system date[FIXED]

gw
gwsk5597
Posts: 25
Joined: Sat Aug 20, 2011 5:03 am
Platform: Windows

Sat Jun 16, 2012 1:54 am Post

After installing the latest beta (#7), I found the program refused to start. Inexplicably, it thinks I've changed my system date, which I definitely haven't done. So I have to say that maybe something in the registration part of the program might now be broken.

User avatar
AmberV
Posts: 23719
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Jun 16, 2012 2:00 am Post

Thanks, I'm getting the same thing on the one machine I've updated. I've already informed Lee.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Bd
Bdillahu
Posts: 54
Joined: Wed May 25, 2011 3:36 am
Platform: Mac, Win + Linux
Location: Atlanta, GA
Contact:

Sat Jun 16, 2012 2:37 am Post

Yep, same here. Win 7, 64bit, installed "over" the previous beta version.

User avatar
AmberV
Posts: 23719
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Jun 16, 2012 4:15 pm Post

Can you all confirm if this has gone away? I was informed that it might have just been a timezone bug, and to give it a night for the day to change. Basically it was coded to check for the date of the build time, and being built in Australia, anyone on the other side of the date line would have been a day prior. Now that a night has gone by for the rest of us, it should be working. My copy is now loading.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

gw
gwsk5597
Posts: 25
Joined: Sat Aug 20, 2011 5:03 am
Platform: Windows

Sat Jun 16, 2012 4:28 pm Post

It's gone. Really weird bug, though.

Bd
Bdillahu
Posts: 54
Joined: Wed May 25, 2011 3:36 am
Platform: Mac, Win + Linux
Location: Atlanta, GA
Contact:

Sat Jun 16, 2012 6:41 pm Post

I concur, it's working here on the US East Coast (Eastern time zone) now...

User avatar
AmberV
Posts: 23719
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Sat Jun 16, 2012 8:37 pm Post

Great, thanks all!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
MimeticMouton
Posts: 8711
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Jun 16, 2012 9:58 pm Post

Oh good, I was wondering if that was what it was...
Jennifer Hughes
(MM for short)

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Sun Jun 17, 2012 1:32 am Post

Phew!

Okay, I'll augment the code to be tolerant of other timezones. I'm very sorry to scare folks like that.

Lee

ne
nemesishaven
Posts: 35
Joined: Thu Aug 04, 2011 6:36 pm
Platform: Windows

Mon Jun 18, 2012 7:47 pm Post

This happened to me too. I assumed it was because I tried to install the beta on the 15th of June (EST), when its release date was the 16th. I just moved my clock forward a day and it was fine (I've since moved it back).

User avatar
AmberV
Posts: 23719
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Jun 18, 2012 7:51 pm Post

Amusing that tampering with the clock fixed the check that suspected you of tampering with the clock. :)

Well at any rate going forward this shouldn't be an issue.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles