A heads up on Crossover

User avatar
xiamenese
Posts: 4695
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Wed Oct 14, 2020 11:21 am Post

Just a heads up…

Crossover has just announced the release of Crossover 20 for Mac, Linux and ChromeOS. I upgraded on my Mac and tried to install the new RC 11 in both Windows 7/64bit and Windows 10/64bit bottles. In both cases the installation seemed to go as normal, though rather quickly. Unfortunately, Scrivener wont run in either case. I'll send a report into CodeWeavers in due course.

I updated to RC 11 in Windows 10 running in VirtualBox without problem, though I did that from within the app, not using the installer.exe I had downloaded.

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

La
Lambekin
Posts: 18
Joined: Sat Jul 21, 2018 10:18 am
Platform: Linux

Tue Oct 20, 2020 6:03 pm Post

I have the same problem on Linux. Have already reported it with Crossover.

I wonder what is going on, though - it could either be the upgrade to Wine 5.0, or a change within Scrivener itself.

User avatar
xiamenese
Posts: 4695
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Tue Oct 20, 2020 9:02 pm Post

Lambekin wrote:I have the same problem on Linux. Have already reported it with Crossover.

I wonder what is going on, though - it could either be the upgrade to Wine 5.0, or a change within Scrivener itself.

I heard back from CodeWeavers. They said:
Thank you for writing us and reporting this issue. Since this is a beta you are testing we cannot file a bug for a fix just yet until it is out of beta. This means if we do implement a fix in crossover 20 when the application is out of beta it could potentially break again. We do appreciate this report and will note this as a possible regression.

I will write back to them to point out that Scriv 3 may be a beta, but I have been using successive Scriv betas for two years. Crossover 20 is the only one that has broken it completely.

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

La
Lambekin
Posts: 18
Joined: Sat Jul 21, 2018 10:18 am
Platform: Linux

Wed Oct 21, 2020 8:10 am Post

I have found the cause: Scrivener crashes if it tries to load the text-to-speech engine. As a workaround, rename the subfolder 'texttospeech' inside the Scrivener folder to something like 'texttospeech_old'. This will prevent the application from loading the *dll file, and allow the application to launch.

I wil also report this to Crossover, and add a dedicated thread here so that people can easily find this solution.

User avatar
xiamenese
Posts: 4695
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Wed Oct 21, 2020 8:37 am Post

Thanks for this. As a Mac user—therefore typically have no reason to dig into the inner workings of apps!—I presume a Ctrl-click (Right click) on the app icon in the finder will open it up. I will have a look when I have a moment—on my iPad at present, though. If I b****r it up, I’ll be no worse off than I am at the moment!

:D

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

La
Lambekin
Posts: 18
Joined: Sat Jul 21, 2018 10:18 am
Platform: Linux

Wed Oct 21, 2020 9:16 am Post

You're welcome - and best of luck!

Ru
RuffPub
Posts: 111
Joined: Fri Oct 09, 2020 1:51 am
Platform: Mac + Windows

Wed Oct 21, 2020 9:20 am Post

B
xiamenese wrote:
Lambekin wrote:I have the same problem on Linux. Have already reported it with Crossover.

I wonder what is going on, though - it could either be the upgrade to Wine 5.0, or a change within Scrivener itself.

I heard back from CodeWeavers. They said:
Thank you for writing us and reporting this issue. Since this is a beta you are testing we cannot file a bug for a fix just yet until it is out of beta. This means if we do implement a fix in crossover 20 when the application is out of beta it could potentially break again. We do appreciate this report and will note this as a possible regression.

I will write back to them to point out that Scriv 3 may be a beta, but I have been using successive Scriv betas for two years. Crossover 20 is the only one that has broken it completely.

Mark


Crossover’s response is perfectly reasonable, in fact similar to L&L policy on OS betas. Hardly any company will expend effort on compatibility with betas. Too many things can change.

The fact V3 beta worked for 2 years is a bonus.

La
Lambekin
Posts: 18
Joined: Sat Jul 21, 2018 10:18 am
Platform: Linux

Wed Oct 21, 2020 9:37 am Post

RuffPub wrote:
Crossover’s response is perfectly reasonable, in fact similar to L&L policy on OS betas. Hardly any company will expend effort on compatibility with betas. Too many things can change.

The fact V3 beta worked for 2 years is a bonus.


The people at Crossover are very helpful in my experience. Asking them to look into a problem with a beta doesn't hurt - also since it may help with the further development of Wine as a whole.

Besides, we already know what Scrivener module causes the problems to occur. If the developers at Crossover can implement a fix or workaround for this problem this will help a lot of people.

User avatar
xiamenese
Posts: 4695
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Wed Oct 21, 2020 11:37 am Post

Lambekin wrote:You're welcome - and best of luck!

Yay, that worked. I have it running in a Win-7 Bottle. It required a significant amount of futzing around to locate, but I got there. I guess I ought to post a note of the full path if any other Mac-users need to know.

Thank you for your detective work!

:)

Mark
The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

User avatar
andrewbond
Posts: 46
Joined: Sat Jul 05, 2014 2:31 am
Platform: Linux
Location: Everett, WA
Contact:

Sun Dec 06, 2020 9:23 pm Post

Lambekin wrote:You're welcome - and best of luck!


Yes, thank you so much. I was finally able to upgrade to 20.0.2. I tried multiple times with v20 and RC11/12/13 on two distros (Fedora 33 and Mint 20).

I also filed a bug with Codeweavers, but as noted above, they wouldn't do much because it is a Beta product. As Scrivener is the only application I run in Crossover it was more irksome than anything else. 19.0.0.2 worked fine.

If Codeweavers has already been informed of the "fix", I won't bother with also reporting it.

(On Mint, at least, Scrivener 1.9 is able to run on Crossover 20 w/o issue. My wife is still running 1.9 and I put Mint on an ancient laptop to allow her to keep working when her Windows box when it fails)
Fedora 33
CrossOver Version 20.0.4
Scrivener Version: 2.9.9.18 64-bit

User avatar
andrewbond
Posts: 46
Joined: Sat Jul 05, 2014 2:31 am
Platform: Linux
Location: Everett, WA
Contact:

Sun Dec 06, 2020 9:36 pm Post

Should this topic be stickied until Codeweavers fixes v20?
Fedora 33
CrossOver Version 20.0.4
Scrivener Version: 2.9.9.18 64-bit

User avatar
devinganger
Posts: 2512
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272
Contact:

Mon Dec 07, 2020 12:38 am Post

Lambekin wrote:
RuffPub wrote:The people at Crossover are very helpful in my experience. Asking them to look into a problem with a beta doesn't hurt - also since it may help with the further development of Wine as a whole.


Don't tell them it's a problem with Scrivener. Tell them it's a problem with the Qt text-to-speech engine for that version of Qt -- looks like it's 5.15.2.0 of that DLL.
--
Devin L. Ganger
Not a L&L employee; opinions are those of my cat
Life has a way of moving you past wants and hopes -- Kevin Flynn

User avatar
garpu
Posts: 2085
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Tue Dec 15, 2020 4:37 am Post

devinganger wrote:
Lambekin wrote:
RuffPub wrote:The people at Crossover are very helpful in my experience. Asking them to look into a problem with a beta doesn't hurt - also since it may help with the further development of Wine as a whole.


Don't tell them it's a problem with Scrivener. Tell them it's a problem with the Qt text-to-speech engine for that version of Qt -- looks like it's 5.15.2.0 of that DLL.


https://bugs.winehq.org/show_bug.cgi?id=44386 Is it this bug? It's been a problem for Scrivener since day 1. It was fixed for a bit, but has a regression.
Slackware-current 64-bit, XFCE