Scrivener Registration Problem

WA
WAS8097
Posts: 23
Joined: Thu Mar 28, 2019 8:58 pm
Platform: Linux + Windows
Contact:

Thu Apr 23, 2020 4:10 pm Post

Having had problems registering Scrivener under either Wine or Crossover, I was in contact w/ L&L for any suggestions. One of their agents referred me to this forum to address my questions. Since I expect this is for persons using the Linux version of Scrivener - which I have installed successfully and which _seems_ to open properly a file I composed w/ the Win 1.9.16 version - I doubt whether any of you will have had experience w/ this problem, but I address the below nonetheless.

After installing Crossover I was able to successfully install and open Scrivener using both the 1.9.16 version downloaded from the L&L site and the Crosstalk Available Applications version (which also was 1.9.16) Both of them presented the same problem, viz, on attempted registration using my e-mail address and my Serial Number, I received the error messages in the two (2) below files. (Apparently no more than three (3) attachments are allowed, so I can only include two (2) of them w/ this message.)

The Crosstalk installation window showed it downloaded both Net 4.0 and 4.6.2, and installed the Net 4.0 Framework. Whether it installed 4.6.2, I don't know. I looked at the Log file and extracted the relevant lines to a new text file, and have it attached hereto. They are meaningless to me. If it did not install also 4.6.2, perhaps this is why Paddle complains about Net 4.5. (Though I know that Net Framework 4.0 was installed by Crosstalk, I don't know enough about Net to determine which 4.0 files that were installed, as indicated by the log file, constitute the 4.6.2 upgrade.)


One of the technicians at Crosstalk suggested I try to intall it in a Win 10 Bottle. I suppose that if would install all of 4.0, and maybe even 4.7 or 4.8, would solve the problem, since it would seem that a version of Net later than 4.6 would install all of the earlier components. However, a person responding to one of my posts indicated this was unlikely; I don't know.


Apparently there has been a persistent problem w/ Paddle. The <paddle.exe> version is dated 09/12/19, and the Configuration file is dated 07/25/19. I wonder if these the latest of each?

I also note the following line from the configuration file:
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5" />
Since it is complaining about not seeing Net 4.5, could this be the problem?


Would editing the line in the Paddle Configuration file be an option to resolve the problem?


Finally, I wonder if it is possible to use the Wine Configuration or Tools utility in Crosstalk to install
NDP462-KB3151800-x86-x64-AllOS-ENU
in the Scrivener Bottle? (This of course is the EXE file for installing the complete Net 4.0 Framework up to and including 4.6.2.)

If only the Net 4.0 Framework, but not the upgrade to 4.5 or 4.6.2, installed perhaps this would solve the problem. (Perhaps then the Paddle utility w/ Scrivener (the registration process) will be able to find 4.5.)


Any thoughts on any of the above?

Scriv-CO_A.png
Scriv-CO_A.png (17.92 KiB) Viewed 344 times

Scriv-CO_B.png
Scriv-CO_B.png (15.81 KiB) Viewed 344 times
Attachments
Scriv-CO_Log.txt
(5.47 KiB) Downloaded 85 times

WA
WAS8097
Posts: 23
Joined: Thu Mar 28, 2019 8:58 pm
Platform: Linux + Windows
Contact:

Thu Apr 23, 2020 4:12 pm Post

I now attach files of the other two (2) error messages referred to in my preceding message.

Scriv-CO_C.png
Scriv-CO_C.png (7.59 KiB) Viewed 343 times

Scriv-CO_D.png
Scriv-CO_D.png (18.88 KiB) Viewed 343 times