Grey screen, won't let me edit/write

su
suedinym
Posts: 2
Joined: Wed Jul 05, 2017 7:49 pm
Platform: Linux

Wed Jul 05, 2017 8:01 pm Post

I was using Scrivener last night, and everything was just fine. When I started it up this morning, the screen was gray and it won't let me write anything, or see what I wrote last night. I can add new pages and folders, add to the meta data etc, and compile it to a pdf, and read the pdf-- I just can't write anything in the draft portion.

Last night the pages were white and the binder tree was black type against a white background. Now it's white against grey.

If I open the tutorial or any other file, it looks the same way. It seems like it could be something elementary that I'm missing, but I can't figure out what it is. I've been using Scrivener for Linux off and on for some years now and this never happened before. My system is xubuntu 64-bit Linux 16.04.

Image

su
suedinym
Posts: 2
Joined: Wed Jul 05, 2017 7:49 pm
Platform: Linux

Wed Jul 05, 2017 9:02 pm Post

I don't know what I did that caused it to do that, but I reset the options/preferences to default and it is letting me write now.

ev
evilmrb
Posts: 9
Joined: Wed May 01, 2013 8:55 am
Platform: Linux + Windows

Sun Jan 28, 2018 12:35 pm Post

This has happened to me several times too. I did something similar to fix it.
Rather than reset to defaults I saved my own preference settings to a file. Whenever the problem occurs, I load that file. It's a pain though.

rc
rcentros
Posts: 10
Joined: Wed May 01, 2019 10:54 pm
Platform: Linux

Fri May 03, 2019 7:55 pm Post

I've run into this a couple times already (in less than a week). I guess this is something not unexpected when using a beta for an OS newer than the application was designed for. At first I reinstalled Scrivener but that didn't clear it (for any document?). And then I found the reset to Default button, which worked but than I had re-change to all my customizations. I didn't know about saving preferences, which I've done now. Do you have to save each project's preferences, or is once enough for everything? Thanks.
Linux Mint Cinnamon 19.1 + Linux Mint Mate 20.0

User avatar
garpu
Posts: 2082
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Thu May 09, 2019 1:13 am Post

Yeah, known bug. I haven't had it happen recently on the beta version of Scrivener, but I did get it once.
Slackware-current 64-bit, XFCE

rc
rcentros
Posts: 10
Joined: Wed May 01, 2019 10:54 pm
Platform: Linux

Fri May 17, 2019 7:14 pm Post

garpu wrote:Yeah, known bug. I haven't had it happen recently on the beta version of Scrivener, but I did get it once.

Since I backed up my preferences it's done it one time. I restored to my preferences instead of default that one time and it hasn't happened since — so maybe that's the key. Something in the default settings might trigger the grey screen?
Linux Mint Cinnamon 19.1 + Linux Mint Mate 20.0