Page 1 of 1

Update possible or new install?

Posted: Wed Dec 30, 2015 11:00 am
by scrivenerwriter
Hi everybody,

great that new Linux versions of Scrivener are released!

But what to do now? My running version is 1.7.2.3 beta (64 bit) on Linux Mint.

a) Do I have do delete it (by Synaptic or how?) and then to install one of the new versions? Or is it possible to do an update/upgrade from my installed version to a newer - and how?

b) As expiry date for my actually version is January, 1st 2016, do I have to install one of the new versions before or is it also possible do do that later?

c) Do I better use 1.7.2.4 or 1.9.0.1?

Thanks in advance for your help!

Re: Update possible or new install?

Posted: Thu Dec 31, 2015 12:24 pm
by Graybyrd
The current downloads for Linux have the expiration date removed, so you'll want to do that. As for which version, it's your choice. The 1.9 version is file-compatible with the new versions for Mac and Windows. The 1.7.2 version retains the original file format. If you choose the newer version (1.9) it will auto-update any older format files you open, but they then cannot be opened by older versions of Scrivener (if that should be a concern).

Re: Update possible or new install?

Posted: Thu Dec 31, 2015 4:24 pm
by scrivenerwriter
Hi,

thanks for your help and information about the versions!

Is there anybody out there who could tell me anything about my questions a) and b) ??? Because I'm not sure about the way of installation.
Do I have to delete my actually version (how?) and do a new install of the new version? Or is there any possibility to open my actually version and click anywhere to do the update/upgrade (how?)?
Could I do that after the expiry date?

Thanks so much in advance!

Re: Update possible or new install?

Posted: Thu Dec 31, 2015 9:08 pm
by philjaq
I cannot speak specifically about Scrivener but only in general about updates of applications in linux systems.

You are using linux Mint which is built upon Debian, similarly to UbuntuStudio which I use. You will therefore be taking the 64 bit version of the .deb file for the version of Scrivener you chose.

I have always found that when upgrading any application to a later version, UbuntuStudio (and my Debian laptop) will simply install the new version of the package over the older one without any conflict with your personal files (in your ~/user directory) and no need to remove the old version beforehand. If you wish to be extra careful, you can easily make a backup copy of your personal 'scrivener' work files but I have never had any files in my user directory structure destroyed by an upgrade of an application.

On my desktop with UbuntuStudio, I just click on the .deb (64 bit) file on this website. The browser dialogue asks whether I want to save to disk or to open the file with 'Ubuntu Software Centre'. I select 'open with Ubuntu Software centre' and that is sufficient to get the installation completed.

My Debian laptop doesn't seem to have an equivalent to the 'Ubuntu Software Centre' and the Synaptic Package Manager needs a repository address to collect the deb package from. So in this case, I download the .deb file to my hard disk and then use gdebi to install the package. (Procedure is described in the sticky thread at top of the linux part of this forum).

I don't know whether Mint has an equivalent to the Ubuntu Software Centre.

It is unlikely that the process of upgrade (installation of the new later package) will be affected by a timeout of the old version.

Re: Update possible or new install?

Posted: Tue Jan 19, 2016 7:38 pm
by scrivenerwriter
Thanks for your help!
I’m so sorry for my late answer and beg your pardon.

It’s as easy as you said and without timeout problems:
You don’t have to remove the older version (but you could), but you can only doubleclick on the .deb file that is then installed by GDebi. That’s all!
Synaptic is only needed if for example you installed 1.9.0.1 and want now 1.7.2.4. Then you first remove the newer version by synaptic before installing the older one. Again, that’s all!

Just one thing, there’s a bug with the interface language, ... it remains in English.
If somebody could help me, please see:
https://www.literatureandlatte.com/forum/viewtopic.php?f=33&t=33545

Thanks again in advance!