Page 1 of 1

TOC really doesn't works

Posted: Fri Aug 07, 2015 6:34 am
by Monolecte
Hi, every-tux-body!

So, as I said in title, I try to make TOC as in the manuel and I have this :
Image

Perhaps I need another variable than <$p>?

Re: TOC really doesn't works

Posted: Fri Aug 07, 2015 7:09 pm
by AmberV
Just to clarify one thing, the Scrivener user manual is typeset using the LaTeX document system, and its ToC is produced using a fairly stock call to the {\tableofcontents} macro (enclosed in a multicols environment with its indent model slightly tweaked to accommodate the narrower column width). It wouldn’t be possible to replicate that look precisely with Scrivener all by itself.

Re: TOC really doesn't works

Posted: Fri Aug 07, 2015 10:19 pm
by Monolecte
I know, but my issue is about page numbers in the ToC...

Re: TOC really doesn't works

Posted: Fri Aug 07, 2015 10:46 pm
by AmberV
Oh I see, I was looking at the overall format, not the numbers. :) Try putting it at the beginning of the book instead, the process isn't designed to work backward from what I can tell.

Re: TOC really doesn't works

Posted: Sat Aug 08, 2015 6:00 pm
by Monolecte
Thanks, good idea, but it doesn't work anymore... :shock:
Image

Re: TOC really doesn't works

Posted: Sun Aug 09, 2015 2:12 pm
by Monolecte
But it works for output to .doc and .rtf, but not to .pdf or .odt...

Re: TOC really doesn't works

Posted: Mon Aug 10, 2015 5:50 pm
by AmberV
Okay, yes, I was going to suggest that you try RTF and make the PDF from a word processor. I’m not 100% on this, but it could be the simpler PDF generator (on Windows it is possible to use Microsoft Word if it is installed) has trouble with this feature. I did some tests and came up with similar results with PDF. I’m not sure why ODT would be different, but I’ll ask and see what is up with this feature and these other formats.

Re: TOC really doesn't works

Posted: Mon Aug 17, 2015 3:57 pm
by Monolecte
Thanks : I'll working my DTP with OpenOffice.