Copy and paste issue

cp
cperfumo
Posts: 9
Joined: Mon Aug 04, 2014 9:26 am
Platform: Linux

Mon Aug 04, 2014 12:00 pm Post

Hi there,

First of all, thanks a lot for making this software available on Linux!

I have recently installed the 1.7.2.3 Linux beta released 22nd July 2014 on Ubuntu 14.04.

I observed that when I copy/cut and paste any text, the pasted text has a different font than the original text.

Has anyone else encountered this problem?

Cheers

Cristian

li
linux68s
Posts: 16
Joined: Fri Jul 04, 2014 11:36 pm
Platform: Linux

Mon Aug 04, 2014 1:51 pm Post

I've got the same issue. 1.7.2.3 on Mint 17.

be
benvdh
Posts: 2
Joined: Wed Feb 22, 2012 12:36 pm
Platform: Windows

Sun Aug 24, 2014 6:00 pm Post

Yes, I encountered the same issue with 1.7.2.3 on Fedora 20 (both 32-bit).

It seems that copy pasting using ctrl-shift-c and ctrl-shift-v preserves the formatting. It's also available through: Format > Formatting > Copy Formatting, and: Format > Formatting > Paste Formatting. Only the key combination in the menu for paste formatting appears to be incorrect.

Kind regards,

Ben

User avatar
DustyLedge
Posts: 9
Joined: Sun Dec 02, 2012 1:01 pm
Platform: Linux + Windows
Location: England

Tue Sep 23, 2014 2:52 pm Post

There is certainly some new (unwanted) behaviour in COPY/PASTE (CTRL-C and CTRL-V) of version 1.7.2.3 beta (32 bit) - 21 Jul 2014.
  • Text highlight is no longer copied/pasted.
  • As a related (?) issue, the toolbar items for Text Colour and Highlight no longer display the usual selection pop-up. The right-click menu is a work-around.
  • Copying a line and then pasting it does not preserve the original line spacing. For example, the original line has "1.0x" spacing, but the new line has "1.0x 12.0/12.0".
  • SHIFT-CTRL-V does avoid the line spacing issue, but this wasn't necessary in the previous version of Scrivener.
I'm running Linux Mint 17 Xfce.
--Thomas (DustyLedge)

User avatar
garpu
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Wed Sep 24, 2014 3:15 am Post

Hrm. Not getting it. (Slackware.) Something else installed?
Slackware-current 64-bit, XFCE

ka
kataja
Posts: 25
Joined: Sat Sep 28, 2013 5:19 pm
Platform: Linux

Fri Sep 26, 2014 7:51 pm Post

I've noticed the same. The text that was in Liberation Serif, sometimes (I hevent been able to see a pattern) comes out as courier. Usually rediong the operation fixes it.

1.7.2.3. beta (32 bit) on Ubuntu linux (and unity) 12.04, my little cute Acer Aspirer One netbook.

cS
cStuartHardwick
Posts: 18
Joined: Sat Dec 13, 2014 12:37 am
Platform: Linux

Fri Dec 19, 2014 10:33 pm Post

I have the same issue on 1.7.2.3 running on Fedora 20 and Xubuntu 13. When I copy paste or select drag some body text, the font always changes to Times New Roman. If I then undo and past again, it reverts to the preset (body text, in this case, Courier New). There is no logical explanation I can see. Times is NOT the font the original LibreOffice doc used before import, is not the default set in Scrivener, and is not the body text preset font. Why the heck would it change?

The default copy paste behavior in any other rich text editor would be to leave the formatting as-is.

Which brings up another point. Come on guys, I LOVE scrivener, but "copy and match style" should be called "Paste special-text" because that's what it is, and what it's called in ever other editor written in the last twnety years. As J Wilber wrote in our coding standards at Softdisk so many years ago, "don't invent a new way interface when there is already a well accepted and perfectly good standard".

Of course, I might be missing some subtletly. What I like about Scrivener is the seperation of content from style. Given that, I want the default past/drag behavior to by style neutral, but markup resiliant. That is, I want it to retain bold/italics, etc., but adopt the font and font characteristics (size, etc.) or the text it's pasted into. I don't see how any other behavior makes sense in Scrivener, which is why what my copy/past and select drag (to move) is doing is do dang annoying.

Not that I'm complaining, you understand. I am greatful to have Scrivener for Linux at all, and eager to pay for support.

cS
cStuartHardwick
Posts: 18
Joined: Sat Dec 13, 2014 12:37 am
Platform: Linux

Fri Dec 19, 2014 10:38 pm Post

kataja wrote:I've noticed the same. The text that was in Liberation Serif, sometimes (I hevent been able to see a pattern) comes out as courier. Usually rediong the operation fixes it.

1.7.2.3. beta (32 bit) on Ubuntu linux (and unity) 12.04, my little cute Acer Aspirer One netbook.


Hey kataja, I bought three backup Acer Aspire One's when they quit making them. That was the ultimate writing machine! I only just now started using an Acer Chromebook c710 running SeaBIOS with Fedora to get more processor power (dual core), battery life, and memory (16G max) and the slightly larger screen.

al
alec
Posts: 13
Joined: Sat Jul 02, 2011 4:37 pm
Platform: Linux
Contact:

Wed Feb 04, 2015 4:08 pm Post

So appreciate Scrivener, and especially the Linux version. I've paid for the Windows version, but instead use the 1.7.2.3 beta (64 bit) - 21 Jul 2014 version under Linux Mint 17.1 (Cinnamon).

I can't imagine having to write without Scrivener and Linux (and Neo, but that's another story).

This copy/paste issue started to make me twitch during today's editing session. Each time I hit CTRL-V, the snippet was pasted as non-installed Courier 12-pitch, single-spaced. Redefining the keys as follows based on benvdh's observation removed the distraction.

1. Tools -> Options -> Keyboard
2. In the Description box, select Edit -> Paste
3. In the Edit Shortcut -> Key Sequence box, click to select, then press ctrl+shift+v
4. In the Description box, select Edit -> Paste and Match Style
5. In the Edit Shortcut -> Key Sequence box, click to select, then press ctrl+v
6. Select Apply, then select OK.

This switches the keyboard shortcuts for Paste and Paste and Match Style. So far it's working for me. This may be helpful to others as a temporary fix.

Alec
Last edited by alec on Wed Feb 04, 2015 9:37 pm, edited 1 time in total.

User avatar
DustyLedge
Posts: 9
Joined: Sun Dec 02, 2012 1:01 pm
Platform: Linux + Windows
Location: England

Wed Feb 04, 2015 4:21 pm Post

I had given up on this for a while now, just remembering to use CTRL-SHIFT-V, but I just read alec's post and saw the logic of the change suggested by benvdh. Done. Now to retrain my fingers to do a simple CTRL-V :)

--Thomas.

PS. I, too, have a Windows lic for Scrivener, but have been full-time Linux Mint Xfce since June last year. I really appreciate having Scrivener available for Linux and hope to see it continue developing in parallel with the Windows version.
--Thomas (DustyLedge)

li
linux68s
Posts: 16
Joined: Fri Jul 04, 2014 11:36 pm
Platform: Linux

Fri Feb 20, 2015 3:03 am Post

awesome fix! thank you Alec.

al
alec
Posts: 13
Joined: Sat Jul 02, 2011 4:37 pm
Platform: Linux
Contact:

Mon Feb 23, 2015 9:48 pm Post

Glad it helped.