Scrivener Linux beta released 22nd July 2014

Posts: 4
Joined: Thu Aug 22, 2013 9:08 pm
Platform: Linux

Sun Nov 23, 2014 9:47 am Post

Thank you Scrivener Team so much. This release makes me very happy. The previous release I had used for a year was the one where the built in new project templates didn't work & no matter what you clicked on it came up blank, & any time you tried to import anything it would crash. I am happy to say that in this new release everything works! :D I am so happy, thank you.

Posts: 4
Joined: Mon Mar 05, 2012 4:58 am
Platform: Linux

Sat Dec 13, 2014 8:57 pm Post

Here's what I get when I run v. on my Ubuntu 13.10 laptop:

Code: Select all

% scrivener

[It runs fine, but when I close the program:]

Code: Select all

Segmentation fault (core dumped)

I'm not losing any data, and it's not dying as I'm trying to use it. I'm just not convinced that it should be dumping core on exit.

If you need more info, just ask.

Posts: 1
Joined: Sat Sep 06, 2014 6:56 pm
Platform: Linux

Sun Jan 11, 2015 10:25 am Post

First of all: thanx for bringing Scrivener to Linux! Is without any doubt the best text writer for me :)

But secondly: I use Scrivener for more than a year already, never encountered any problems, until now :( It's not a big problem, but it's very annoying to me. Sometimes I want to highlight a text with a nice color, but that doesn't seem to work anymore. When clicking on the pencil, the colorbox doesn't open. I also can't remove the highlight when it's already in place.

The problem started after I removed an old version of Scrivener and installed and opened the project I'm currently working on. I use Ubuntu Gnome 14.04 LTS 64-bit.

Is this a known bug, or am I the only one experiencing it?

Posts: 180
Joined: Tue Jan 10, 2012 4:30 am
Platform: Linux + Windows

Mon Jan 12, 2015 5:34 pm Post

I've noticed goofy behavior with the colorbox in this version. But 1.8 Linux BETA ought to be out really soon, right? Uh-huh . . . ! kraml

Posts: 2
Joined: Mon Jan 19, 2015 12:58 pm
Platform: Linux

Mon Jan 19, 2015 1:06 pm Post

Thank you for supporting Linux. I have installed it on the latest Sabayon (think Gentoo), and so far it has performed flawlessly. Though I have used relatively few features so far, the basic ones I have used work very well.

I look forward to being able to purchase this software.

Once again thanks.

Posts: 1
Joined: Tue Jan 20, 2015 9:19 pm
Platform: Linux

Wed Jan 21, 2015 1:05 am Post

Hi everyone. Thanks for bringing this program to Linux. I heard a lot of great thing from my coleagues in academia, so I decided to give it a try. I installed 64bit version (with no problem) on Xubuntu 14.04, running on Acer Chromebook C720. So far, it is performing good, except for some issues with changing the color of the highlighter, and some other minor glitches, but I am just warming up for now. The real test will be the use with chromebook keyboard with special characters.

Now, I installed trial version on my Win machine, just to get an idea of the differences between the two. Will post what I find out. But for now, it looks like a great tool that combines number of different features that I can recomend to my students, to ease up their writting assingements and help them formulate clear ideas.

Keep up the good work!


Posts: 1
Joined: Wed Jan 21, 2015 1:47 am
Platform: Mac + Linux

Wed Jan 21, 2015 1:53 am Post

Having trouble launching the app due to the libpng being too old and my distro (Gentoo) not providing packages that old. I tried fooling scrivener into using the old version with a symlink, but the shared library has a version specified in the ELF header which defeated that bit of cleverness. Because of this, I can't use Scrivener on Linux. Are there any plans to remedy this? I imagine it makes things very difficult for a lot of users who keep their systems up to date (probably most users, since Unix and Linux users tend to be enthusiasts and like to be up to date)

Edit: scratch that, partially. I just installed libpng12 alongside libpng16 (I was not expecting this to work when I tried it!) and now Scrivener launches. I know this won't work for certain systems, so I'd still like to see the hardcoded version fixed, but at least I found a workaround that doesn't seem to have broken anything.

Posts: 133
Joined: Sun Nov 14, 2010 3:54 am
Platform: Linux

Tue Feb 03, 2015 5:58 pm Post

Are there any plans to update to 1.8.5?

Posts: 1
Joined: Mon Mar 16, 2015 8:24 pm
Platform: Linux

Tue Mar 17, 2015 11:05 am Post

Running fine on Mint 17.1
ex software engineer, bit rusty, never a linux person, but happy to run tests if you need.

Posts: 2
Joined: Thu Apr 09, 2015 10:08 pm
Platform: Linux

Thu Apr 09, 2015 10:20 pm Post

thank you very much for this program. works like a charm, just installed in my home folder an have not had any problems apart from installing icelandic dictionary. The dictionary was downloaded into the dict folder but it would not appear in the list of dictionaries (restarted scrivener several times and checked permissions etc.). But when I ran "sudo yum install aspell-is" it installed icelandic globally and then it appeared in the list so it looks like it's not using the Aspell that comes with scrivener


Posts: 1
Joined: Sat Apr 25, 2015 7:37 pm
Platform: Linux

Sat Apr 25, 2015 7:43 pm Post

Really pleased to see this supported on Linux. Installing on Ubuntu and eager to see a new build sometime soon; totally happy to buy the software for official Linux support! Thanks for what's here so far. :)

Posts: 2
Joined: Sat May 16, 2015 11:10 pm
Platform: Mac + Linux

Sat May 16, 2015 11:45 pm Post

Adding on to the reports by JohnSmallBerries and ovation1357 (both of which I can confirm) I can also report:

  • Fullscreen Mode: Unable to adjust the "Paper Height" slider. Pressing ALT changes from Width to Height as expected, but the slider is pegged to the right and won't adjust.

  • Tools > Scratch Pad: Unable to enter or modify text. Can click buttons, but not rename notes (even a newly created note that is presently highlighted) or enter any text on the notes. The window is pegged in the upper-left corner, lacks decoration, floats on top of everything and appears on all virtual desktop workspaces. Lacks a proper window ID and doesn't show up in any task switching or window list elements.

Debian 7.8 (Wheezy), 32 bit; needed to do a manual update of libc6 since this version maxed at v2.13 and it needed >= v2.15, but everything else has been beautiful.

This is also my first experience with Scrivener, and altogether it's a gorgeous one - exactly what I was looking for. I've seen a lot of others out there, and they just tended to get in the way; mandating structures which didn't quite work (or were useful for only one type of composition), bloated, etc. I'm on a woefully underpowered box here (repurposed first series Chromebook) and it's been nice and low on the resources. I get the impression that the cleanliness in the interface extends to the code (which I say as a professional coder myself).

Thank you for doing this - for making the software, for trying it out on linux, and for generating substantial good will in your attitudes and licensing practices. Y'all rock, and I look forward to more opportunities to give you money throughout the years.

Posts: 10
Joined: Thu Nov 04, 2010 10:55 am
Platform: Mac + Windows

Mon May 18, 2015 2:21 pm Post


Any update on this? It is almost a year since last update...

Posts: 4
Joined: Wed Apr 06, 2011 11:24 pm
Platform: Windows

Sat May 30, 2015 11:33 am Post

I just tried installing this and there is ... nothing. I can't even find a folder on my system that shows Scrivener installed.

Posts: 1
Joined: Sat Jul 18, 2015 5:22 pm
Platform: Linux

Sat Jul 18, 2015 5:33 pm Post

THANK You for releasing Scrivener in Linux. I've been using Scrivener in Wine for about 2 years now and while it works, there are some things that don't work well in Wine. I haven't used a Windows computer in about 10 years, and wasn't about to leave Linux for one program, so I tolerated the Wine issues. I just learned about the Linux beta version last night while I was checking for forum for a solution to a problem I was having in the Wine version. I downloaded the Linux ap, and my problem was solved! I love Scrivener, and I love Linux, and it makes me stupid happy to be able to run Scrivener on my Linux machines. THANK YOU