Scrivener 1.7.2.2 Linux released 15th July 2014

User avatar
LAP
Posts: 1023
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Tue Jul 15, 2014 3:08 am Post

Hi All,

We are very happy to announce a new, vastly improved, Scrivener for Linux 1.7.2.2 beta. With over 500 bug fixes and all the additions included in the recent Windows 1.7.2 release, Scrivener is now available for Linux users. See Windows official release notes for 1.7.x here:
http://www.literatureandlatte.com/scrivWinChangeList.php

Download here (now 32bit and 64bit versions available):
http://www.literatureandlatte.com/scrivenerforlinux/scrivener-1.7.2.2-i386.deb
http://www.literatureandlatte.com/scrivenerforlinux/scrivener-1.7.2.2-i386.tar.gz

http://www.literatureandlatte.com/scrivenerforlinux/scrivener-1.7.2.2-amd64.deb
http://www.literatureandlatte.com/scrivenerforlinux/scrivener-1.7.2.2-amd64.tar.gz

Important Notes:
In light of spending a painful five days trying to get Scrivener 1.7.2.2 to compile for Linux, Scrivener is no longer able to link against glibc 2.13 (released 04 Feb 2011). We now link against glibc 2.15 (released 21 Feb 2012). When we build Qt we use gcc compiler v4.7.2 that comes with glibc 2.15. We use the default compiler provided in the oldest officially supported Ubuntu version. To continue to use the older glibc would mean using an older compiler and libraries which cause problems with the latest versions of 3rd party packages we use in Scrivener 1.7.2.2. If you are using glibc 2.13, you will need to upgrade to 2.15 to use Scrivener v1.7.2.2. If you don't wish to upgrade glibc you can continue to use Scrivener 1.6.1.1.

There some issues with yesterdays 1.7.2.1 release that have been addressed in this release of 1.7.2.2. See comments from this post if you are interested in the details: http://www.literatureandlatte.com/forum/viewtopic.php?f=33&t=28179

We hope you enjoy this version of Scrivener and appreciate our continued efforts to provide free builds to the Linux community.

Lee & Tiho

P.S. Update on RPM packaging:
Unfortunately, an RPM pckage is not going to be possible for us. There are a few issues which prevent us from using it despite our desire to. Firstly, there can be no inclusion of pre-built binaries or libraries. See here: https://fedoraproject.org/wiki/Packagin ... _libraries

Secondly, and linked to the first point, the License must be a GPL licenses. Given these two barriers (that are designed to promote free software) it is not realistic for us to release our source code and change our licensing just so we can provision our software gratis to Fedora users. The community will need to work around this limitation if they wish to use Scrivener on Fedora.

Mi
Middling
Posts: 4
Joined: Wed Jun 04, 2014 10:04 am
Platform: Mac

Tue Jul 15, 2014 10:23 am Post

Installed without a hitch on Linux Mint 17 Cinnamon 64bit.

Scrivener still requires the installation of libaspell-dev for the spelling checker to work, which i don't think should be required (being that it's a development package).

In addition the spelling checker ignores the language variant the system is set to. It'll only check the American spelling of a word even if the system language is set to British English. I'm fairly sure this worked correctly in earlier versions.

User avatar
garpu
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Tue Jul 15, 2014 6:29 pm Post

Woohoo! 64 bit and working well here. With bonus PDF handling, too! Does this mean that with 1.7 supported under linux that Scapple will follow? :)
Slackware-current 64-bit, XFCE

Gr
Graybyrd
Posts: 182
Joined: Tue Apr 29, 2008 5:39 am
Platform: Mac, Win + Linux
Location: Whidbey Island, WA
Contact:

Tue Jul 15, 2014 8:04 pm Post

Most excellent! 32-bit .deb installs & runs perfectly ... many, many thanks, Lee & Tiho. I note that the "snapshot" function works correctly without first deleting the camera click .wav file in the resources folder. Nice. The scratchpad function still does not allow a cursor/edit in the text window until one (at least on my debian install) clicks the "grab" fist, pulls down the partially exposed window edge to show the 'cancel' button, clicks that, and then again clicks in the scratchpad text window ... then it works fine (???) ...

Haven't found that Linux contribution box you guys mentioned, but it sure deserves some hits. Thanks again for this great upgrade!
On my honor, I will do my best not to do anything unlawful, infringing, disruptive, harmful, threatening, abusive, tortious, defamatory, libelous, lewd, profane, obscene, hateful or otherwise objectionable. Pinky Promise. :mrgreen:

Ra
Radio99Dial
Posts: 14
Joined: Wed Apr 23, 2014 8:52 pm
Platform: Linux + Windows

Tue Jul 15, 2014 8:35 pm Post

Installed without a hitch on my Lenovo Thinkpad T540p running Mint-17 Cinnamon 64. It seems to work perfectly too. I'm really grateful that this is provided to the Linux community. Thanks!

EDIT: Also, I installed it on Mint Debian 64 with Mate. It installed and works great on the Debian too.

ha
happydemic
Posts: 38
Joined: Wed Jul 16, 2014 8:14 am
Platform: Linux + Windows

Wed Jul 16, 2014 8:32 am Post

Installed 1.7.2.2 32-bit .deb on Ubuntu 12.04 from the command line. Updated from 1.6.1.1 without problems.

Huge improvement on the last version! Thank you so much. A joy to write with.

Two minor snafus - neither of these is an issue for me so I didn't check logs and haven't collected any useful information - sorry. Thought I'd mention them anyway.
1. Couldn't get the .deb to install by opening it in Software Centre (Software Centre ignored it) so used the command line - no errors.
2. Import and Split of a .doc leads to Scrivener hanging indefinitely (note most of my .docs are generated by LibreOffice).

de
deusexmachinae
Posts: 1
Joined: Wed Jul 16, 2014 8:20 pm
Platform: Linux + Windows

Wed Jul 16, 2014 8:24 pm Post

Installed the 64 bit version on Ubuntu 14.04 without a hitch.

The only problem I've ran into is that Project Statistics isn't working. When I click it the whole software just freezes and I need to force quit.

Both 32 and 64 bit versions have the same problem.

User avatar
tiho_d
Posts: 1200
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Jul 16, 2014 8:31 pm Post

Hi guys, it seems like PDF export has some troubles, as few users already reported broken functionality. All the functionality reported as broken is connected with PDF export(RTF>PDF conversion) under Linux. Can you please, let me know, whether everyone is having problem with Project Statistics, compiling to PDF, exporting an RTF file to PDF or only some of you. It would be nice to clarify why it works on some, but not on other machines.

User avatar
garpu
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Wed Jul 16, 2014 10:12 pm Post

Using 64 bit Scrivener, Slackware 14.
Project statistics: Crashes Scrivener.
RTF compile: fine.
Compiling PDF: crashes
Export to pdf: crashes

(Using KDE if that matters.)

ETA: You need a strace/core dump?
Slackware-current 64-bit, XFCE

ta
taxidriver
Posts: 26
Joined: Tue Feb 21, 2012 7:58 am
Platform: Linux

Thu Jul 17, 2014 12:07 pm Post

Thanks for your work.

ta
taxidriver
Posts: 26
Joined: Tue Feb 21, 2012 7:58 am
Platform: Linux

Thu Jul 17, 2014 12:38 pm Post

For Italian users: windows commercial version works?
I don't have automatic ortography correction in all the linux versions, and seems impossible download tne italian dictionary.
My solution is use another editor to write and then paste on scrivener to organize...
Maybe soon I'll buy a new notebook with W8... The things are better there?

Ra
Radio99Dial
Posts: 14
Joined: Wed Apr 23, 2014 8:52 pm
Platform: Linux + Windows

Thu Jul 17, 2014 2:28 pm Post

In case it is helpful to know:

With 64 bit Scrivener on Mint-17 Cinnamon (64 bit)
Project Statistics: Crashes Scrivener.
Compiling PDF: crashes
Export to pdf: crashes
RTF compile works fine.

Other than this, I am so happy to have this linux release of Scrivener. Even if the above noted issues never get fixed, it's still a huge help to me to be able to write my manuscripts in Scrivener. Thanks again.

gi
gilljac
Posts: 1
Joined: Thu Jul 17, 2014 3:05 pm
Platform: Linux + Windows

Thu Jul 17, 2014 3:16 pm Post

I am trying to install the 1.7.7.2 64 bit version in Ubuntu 14.04. I'm getting the following message:
------------------------------------------------------------------------
"The Package is of Bad Quality" (message header)
The installation of a package which violates the quality standards isn't allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath.

Lintian check results for /home/***/Downloads/scrivener-1.7.2.2-amd64.deb:
E: scrivener: maintainer-name-missing lee@literatureandlatte.com
Use of uninitialized value $name in pattern match (m//) at /usr/share/perl5/Lintian/Check.pm line 203.
------------------------------------------------------------------------
Should I abort the install or ignore and install anyhow?

UPDATE: I clicked the Ignore and Install button, and it installed. I see no difficulties with the installed program. I then downloaded the tarball, extracted it to a folder, and when run from the folder, it works as expected without any warnings.
Last edited by gilljac on Thu Jul 17, 2014 4:14 pm, edited 2 times in total.

User avatar
garpu
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Thu Jul 17, 2014 3:48 pm Post

Question...what happens if you download the *.tar one, untar it somewhere in your home directory, then try to run Scrivener that way? Will it run? using ldd on it can tell you what (if anything) you're missing.

Did the 32-bit one run?
Slackware-current 64-bit, XFCE

User avatar
garpu
Posts: 2049
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Fri Jul 18, 2014 10:50 am Post

If people need a workaround for the compile to PDF bug, the newest version of Scrivener works out of the box via WINE. (And compiles to PDF, whatever.) You'll want to use the most current version of WINE, though.
Slackware-current 64-bit, XFCE