Opening Windows Created Project in the Linux Version - Blank

da
danhanly
Posts: 3
Joined: Sun Mar 02, 2014 8:34 pm
Platform: Linux + Windows

Sun Mar 02, 2014 8:36 pm Post

I'm getting blank documents throughout my project. The structure is there (my chapters/parts have been retained) but the content of the pages is not.

Looking through the files, the content does all seem to be there as .link and .rtf files, but when I load these through Scrivener, I'm getting nothing.

Can someone help please?

For reference, I'm running Xubuntu 13.10 and I've just downloaded/installed the latest beta of Scrivener.

da
danhanly
Posts: 3
Joined: Sun Mar 02, 2014 8:34 pm
Platform: Linux + Windows

Sun Mar 02, 2014 8:42 pm Post

Okay, this is a little awkward...

I've fixed it.
I was looking through my files in the project through the file manager and I edited a synopsis text document and saved. Then I tried launching again, and it worked!

Don't know why, don't know how, but I'll take it.

User avatar
vamp
Posts: 5
Joined: Wed Aug 27, 2014 1:59 am
Platform: Linux
Location: New Zealand

Thu Aug 28, 2014 5:48 pm Post

I just opened my project (created in Linux) and all my text was gone. Heart attack! I shut Scrivener down (it did this weird thing where it seemed stuck in a backup loop, must have seen the wee bar half a dozen times before it shut down properly), then reopened and my stuff was back *phew* Did a quick plain text compile which I should do every time I end a writing session using a beta version (redundant backups oh yes) but didn't yesterday. Learnt my lesson!

I have a link on the desktop to the project file (the .scrivx) which is what I clicked when i opened to nothing. When I reopened, I used the application button on the launch bar (I'm in Ubuntu 14.04). I'm not sure that would make a difference, but perhaps. I'm sure I used the desktop link yesterday with no problems, however.
Ubuntu 16.10 64bit (Scrivener not working :( )
Bodhi Linux 4.0.0 32bit

User avatar
vamp
Posts: 5
Joined: Wed Aug 27, 2014 1:59 am
Platform: Linux
Location: New Zealand

Thu Aug 28, 2014 6:20 pm Post

This is also awkward.

My 'link' to the .scrivx apparently became it's own project, and created it's own Files, Settings, and Snapshots folders on the desktop. So the file structure was there, but of course there was no text inside!

This could be a linux thing, I'm a newb so don't know for sure. But I won't be doing that again! Launch bar button only from now on: check.

A similar thing happened when I tried to rename the project folder soon after I created it. It made a whole new project instead. I just left it, haven't had the inclination to figure out which was the real one yet. I should probably do that now O.O
Ubuntu 16.10 64bit (Scrivener not working :( )
Bodhi Linux 4.0.0 32bit

ka
kataja
Posts: 25
Joined: Sat Sep 28, 2013 5:19 pm
Platform: Linux

Sun Aug 31, 2014 4:55 pm Post

BTW, if and when you use compilation for extra backups, it is good to test them by opening before you close Scrivener for that session.

I just noted (and wrote a more detailed error report) that duplicated chapters result in broken compilation to .odt format (i.e. Open Office and Libre Office format)