Linux Beta Released (NOT LATEST)

User avatar
Posts: 1027
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney

Mon Nov 11, 2013 6:11 am Post

Hi All,

We are happy to announce a new Scrivener for Linux beta with all the fixes and additions included in it from the Windows 1.5.6, 1.5.7, 1.6.0 and 1.6.1 releases. See all release notes here:

This beta expires 1.Dec.2014

Download here:
[url]http://www.literaturHi All,

We are very happy to announce a new Scrivener for Linux beta with over 500 bug fixes and all the additions included in the recent Windows 1.7.2 release, now avialble in Linux. See Windows release notes here:

Download here (now 32bit and 64bit versions available):

Scrivener is no longer able to link against glibc 2.13 (released 04 Feb 2011). We now link against glibc 2.15 (released 21 Feb 2012). When we build Qt we use gcc compiler v4.7.2 that comes with glibc 2.15. We use the default compiler provided in the oldest officially supported Ubuntu version. To continue to use the older glibc would mean using an older compiler and libraries which cause problems with the latest versions of 3rd party packages we use in Scrivener If you are using glibc 2.13, you will need to upgrade to 2.15 to use Scrivener v1.7.2.1. If you don't wish to upgrade glibc you can continue to use Scrivener 1.6.

Also, some users might experience issues with cross-connected Qt libraries. We would suggest following link for help understanding and resolving this: ... eta.tar.gz[/url]

User avatar
Posts: 2082
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Tue Nov 12, 2013 3:21 pm Post

Awesome! Does this mean it'll support Scapple eventually, too? :)

ETA: What should I be seeing with PDFs? I'm seeing pages, but no text. (It'll open in an external editor just fine.)
Slackware-current 64-bit, XFCE

Posts: 20
Joined: Mon Mar 21, 2011 10:34 pm
Platform: Mac

Wed Nov 13, 2013 2:26 am Post

Hi, I have just downloaded the tar file but can't unpack it. I am using Arch and when I run makepkg, I am told the PKGBUILD does not exist. Is there one for Arch?

User avatar
Posts: 2082
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Wed Nov 13, 2013 7:58 pm Post

When I was using arch linux, I used the *.tar package, unpacked it to /opt and ran it via You'll need the 32-bit libraries installed for it. (do ldd bin/Scrivener in the Scrivener directory, and it'll tell you exactly which you'll need installed.)
Slackware-current 64-bit, XFCE

Posts: 180
Joined: Tue Jan 10, 2012 4:30 am
Platform: Linux + Windows

Sat Nov 16, 2013 5:34 am Post

Thanks for the update! Software center plunked it right in there. Seems to function well--quick test at this point. Thanks again.
--Ubuntu 12.04LTS

Posts: 2
Joined: Thu Oct 17, 2013 1:45 pm
Platform: Linux

Thu Nov 21, 2013 6:51 am Post

I'm getting the following when I try to add a file (Ctrl-Sh-J , pulldown menu (from green button), or right-click --> add)
I invoked Scrivener from a terminal to catch the error. It immediately crashes when I try the above. I suspect this is a result of a recent Linux Mint update/upgrade. as it's worked successfully before.

Code: Select all

Cannot mix incompatible Qt library (version 0x40801) with this library (version 0x40800)
Aborted (core dumped)

Pertinent info.
uname -a reports:
Linux T30 3.12.0-031200-generic #201311031935 SMP Mon Nov 4 00:46:34 UTC 2013 i686 i686 i386 GNU/Linux

Linux Mint 13 (Maya) fully updated

I'll try to "fallback" the Kernel in the meantime - it is a bit 'bleeding-edge...
If the devs. need any more files or info., pse let me know.
UPDATE: Rollig back kernel had no effect. (+ apt-get update/upgrade)
As I really need Scrivener to work to finish my project, I'm going for a full reinstall of Linux.
I did reinstall Linux - I was previously using Mint Mate 13, but found it a bit bloated for my ancient computer (when I get a job again, I'll upgrade...). I went for Mint XFCE 15, seems more responsive.
Anyway, Scriv. Beta is in the repository, and, using that, everything works fine now.
As all my work is on Dropbox, the reinstall/recover was painless. Thanks all for the help. I can't imagine a tool better suited to pull text, datasheets, code snippets, circuit diagrams etc. together for a hardware/software project.
(Remote 'lab' - Raspberry Pi-based, to stick in a forest, measure environment etc., controlled over the Internet, and hopefully snap pictures like this... )
Last edited by andycrofts on Sat Nov 23, 2013 11:03 am, edited 1 time in total.

User avatar
Posts: 2082
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Thu Nov 21, 2013 1:11 pm Post

nonono, don't do that. Start scrivener using Scrivener/bin/ instead of the binary.
Slackware-current 64-bit, XFCE

Posts: 99
Joined: Thu Oct 19, 2006 7:45 pm
Platform: Linux
Location: New York, NY

Thu Nov 21, 2013 9:07 pm Post

Be aware that the "incompatible Qt error" can occur when the default Qt style (which in Ubuntu is set to match the Gtk style) is only available for the 64-bit Qt library.

You can force the Qt style to "Clean Looks" (supported by 32-bit) by using the '-style' argument:

Code: Select all

  bash# bin/Scrivener -style=CleanLooks  &

Obviously, this should be set in bin/ unless you have LD_LIBRARY_PATH and such in your environment already.

The style can be set for all applications using the qtconfig tool:

Code: Select all

 bash# qtconfig-qt4 &

User avatar
Posts: 156
Joined: Fri Dec 01, 2006 11:43 am
Location: Germany

Mon Nov 25, 2013 9:53 am Post


Software Center warns me to install the deb package:

Lintian check results for /home/juh/Downloads/scrivener-
E: scrivener: maintainer-name-missing
Use of uninitialized value $name in pattern match (m//) at /usr/share/perl5/Lintian/ line 203.

Any hints?

Posts: 23
Joined: Tue Nov 01, 2011 8:57 am
Platform: Linux + Windows

Thu Nov 28, 2013 12:24 pm Post

Here the new version crashes reproducible when I want to make snapshots. The 1.5.x.x crashed, too.

This is the error message I got:

Code: Select all

Cannot mix incompatible Qt library (version 0x40804) with this library (version 0x40800)

I work on Linux Mint Olivia Cinnamon.

And the package manager says the Beta expires July 2012? Will be 2014, I hope. ;-)

Package Installer - scrivener_223.png
Hope this means 2014?
Package Installer - scrivener_223.png (47.99 KiB) Viewed 20342 times

Jim M
Posts: 2
Joined: Wed Apr 06, 2011 12:37 pm
Platform: Windows

Sun Dec 01, 2013 1:02 pm Post


On my system, I have noticed the "About Scrivener" window has no "X button and therefore, there's no way to dismiss it and close Scrivener without restarting the system.

I am running Debian 7.2 amb64/GNOME 3.4.2

Jim M
About Scrivener.png
About Scrivener.png (101.07 KiB) Viewed 20145 times

Posts: 1
Joined: Sun Dec 08, 2013 5:57 pm
Platform: Mac + Linux

Sun Dec 08, 2013 6:03 pm Post

Hi Jim,

Yes, there hasn't been an X-window close button on the "About" screen in any version of the Linux software. I'm on Ubuntu 13.10 64-bit, and I found that I can close the "about" window by right-clicking on the menu bar, which reveals a drop-down menu. At the bottom of the contextual menu, you'll see the option "Close". Click that and you're golden. :D


Posts: 49
Joined: Tue Oct 26, 2010 12:10 pm
Platform: Linux

Mon Dec 09, 2013 9:43 pm Post

Jim M wrote:Greetings,

On my system, I have noticed the "About Scrivener" window has no "X button and therefore, there's no way to dismiss it and close Scrivener without restarting the system.

I am running Debian 7.2 amb64/GNOME 3.4.2

Jim M

Jim M, have you tried to press the "Esc" key?

I am running Scrivener for Linux in debian sid, but with i3 as window manager. When I press Esc, the "About Scrivener" window dissapear.
aptosid xfce/scrotwm amd64

Posts: 8
Joined: Tue Dec 10, 2013 12:25 pm
Platform: Linux

Tue Dec 10, 2013 12:37 pm Post

I just installed this version successfully by using the quite complicated installation instruction.

So far Scrivener works fine. Even Kindle-Export, Snapshots and Spell-Checking works, all the things many people have struggled with. The only thing that does not work so far is changing the interface language. It does not change according to the settings but stays English.

For reference: I am using Ubuntu 13.04 in 64bit with KDE-Desktop in German.

I am an Linux-only user and would really like to buy a copy. Even if the Linux version is not supported in the same way as the other versions, it would be a good idea to make the Linux-Version obtainable as well. It would be great to be able to support you guys. As far as I see it, most errors reported here are due to the difficult installation instruction and possible installation errors that can occur with little linux system knowledge. This should be fixable with an updated deb package etc.

Why not make the Windows-Licence usable for Linux as well. As far as I see it, the code is the same anyway. So one can buy a copy for Windows and use the beta for Linux indefinitely as well.

Posts: 9
Joined: Mon Dec 09, 2013 3:29 am
Platform: Linux

Tue Dec 10, 2013 5:22 pm Post

I've tried everything. Missing library files galore if you only install ia32-libs....

I'm running CrunchBang Waldorf on a T530 64bit arch. I guess it would be a waste of my time to ask way Scrivener hasn't been ported to a 64bit arch?????

---------------------------------- other content deleted for sanity's sake------------------------

First off: Thanks to scrandy, for the exact package name!

To get Scrivener running under CrunchBang 64bt (Waldorf), you should only have to do the following:

Code: Select all

dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs-gtk
sudo apt-get install libgstreamer-plugins-base0.10-0:i386

Then, download the Scrivener .deb package to your downloads directory. Use the FIle Manager, right click on the package under downloads, and use the "Gdebi Package Installer".

Should be up and running at this point. Type "scrivener" at a command line prompt, or in your Run Program GUI.

Last edited by titianmom on Tue Dec 10, 2013 6:07 pm, edited 3 times in total.