can't uninstall expired version - help please

Posts: 1
Joined: Sat Sep 28, 2013 2:46 am
Platform: Linux + Windows

Sat Sep 28, 2013 2:57 am Post


I've just switched distros to Ubuntu Studio 13.04 (64 bit) due to a soundcard issue with standard Ubuntu. When installing Scrivener this time around I made the stupid error of downloading and installing the deb for an older beta, which then came up as expired when I tried to run it.

Now the latest deb version won't install, and I can't find a way to uninstall the expired version. No 'uninstall' option in Software Centre.

I'm getting by running the executable from the tarball of the current version, but would prefer to install the latest deb if I can. Suspect the blockage is the older version I can't uninstall.

Would be really grateful for any suggestions. As is probably obvious, I'm newish to Linux.

Posts: 99
Joined: Thu Oct 19, 2006 7:45 pm
Platform: Linux
Location: New York, NY

Sat Sep 28, 2013 4:00 pm Post

On the command line (using an app called Terminal or Konsole or Shell or something like that) run:

Code: Select all

sudo dpkg -r scrivener:i386

If that gives you an error, use the --force-all parameter:

Code: Select all

sudo dpkg --force-all -r scrivener:i386

The dpkg utility is the command-line tool for managing installed or downloaded packages. A summary of its usage can be found here:

Posts: 2
Joined: Fri Jan 31, 2014 1:26 pm
Platform: Linux

Fri Jan 31, 2014 1:44 pm Post

Thanks for that, edf. Updating to the newest beta on my laptop today because expiration and realized I couldn't remember a thing about the install, like if I had to do anything manually, and all the readme said was uninstall the old version when upgrading.

Worked a treat.