Page 3 of 3

Re: LINUX Beta Released

Posted: Sat Jan 19, 2013 10:20 pm
by cb474
brYKou wrote:You can try to install MultiArch. Like this, your system will be able to install i386 libraries needed.
I have done this a while ago, and now I don't have any more troubles for 32Bits dependancies

Thanks for the suggestions. I had already enabled MultiArch using the command:

Code: Select all

dpkg --add-architecture i386

That installed lots of lib32 packages. And, as I said above, before I enabled MultiArch, dpkg would fail and not even let me intsall the .deb package of Scrivener. But now even with MultiArch, I get the error mentioned above. Any other thoughts?

Re: LINUX Beta Released

Posted: Sun Jan 20, 2013 12:38 am
by cb474
I solved my problem, after reading this post about how ia32-libs has been deprecated in favor of enabling multiarch: ... 0&t=122296.

I followed the instructions for enabling multiarch there, including the modification of sources.list, which I don't know if that was done before or not.

Then when I ran synaptic it told me I had a broken package, which turned out to be an older version of Skype I was running. So I marked Skype for complete removal, which curiously caused synaptic to say that removing Skype required installing several packages, including the one I was missing (libgstreamer-plugins-base0.10-0:i386). All four packages installed at this point were:


After that Scrivener ran fine! And installing the newest version of Skype worked too, without messing anything up.