Page 1 of 5

1.2.6 Scrivener for Linux Released (NOT LATEST)

Posted: Thu Aug 16, 2012 9:39 pm
by LAP
Hi All,

This release is a slight improvement over 1.2.5. It main purpose is to address the annoying font hinting bug.

Items addressed in the 1.2.6 release:
1. Fixed Crashing RTFI inspector. It was completely removed with the last release. Now it is back in in working condition.
2. Font Hinting for new documents has been improved significantly.

You can find the archive package and the Debian installer here:

http://www.literatureandlatte.com/scriv ... ner.tar.gz
http://www.literatureandlatte.com/scriv ... 6-beta.deb

Tested on clean 10.10 32 bit Ubuntu.

Expires - 30th June 2013 – (Scrivener 1.2.6)

Tiho & Lee
P.S. Expect another update around Nov/Dec 2012 regardless with more features.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Thu Aug 16, 2012 9:50 pm
by garpu
Doesn't crash when you drag stuff and we get the Sci-fi translation. Awesome. :)

Whoops. Found a bug. Switching languages doesn't really switch languages. (Under Options > General, tried both Science Fiction and Italian.)

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Fri Aug 17, 2012 10:05 am
by RevDave
Thank you for the fix. That part looks good. Unfortunately the incompatible qtlibrary problem with KDE on Kubuntu still exists.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Fri Aug 17, 2012 12:21 pm
by glaedr
RPM Version

Any update on the qt thing? :( I still can't open Scrivener at all.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Sat Aug 18, 2012 8:48 pm
by RevDave
Woohoo!

I found something that worked. I took the lead from cellfourteen on page 3 of the thread on the 1.2.5 release. He mentioned running lsof while Scrivener was running (I saw it best when I was running Scrivener under Unity (I am on Ubuntu 12.04, but wanting to run under KDE)). It was wanting to access libQtDBus. And the only one available was the one from kde not from scrivener/lib.

So I found a version of 4.8.0 for libQt (libqt4-dbus_4.8.0-1ubuntu10+patches_i386.deb) from
https://launchpad.net/~francisbrwn9/+ar ... ld/3280048

I then just used dpkg-deb --extract package directory_for_extraction

Then navigated up the tree, copied the 4.8.0 lib to the /usr/share/scrivener/lib, created a couple soft links as cellfourteen talked about and voila. It worked in KDE.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Sun Aug 19, 2012 9:09 pm
by glaedr
At least someone can run it. Unfortunately it doesn't seem to work in OpenSuse. :(

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 20, 2012 3:00 am
by lemke0
Ok. I'm using Ubuntu 12.04. A downloaded the deb file and installed it. I went to Painel Inicial (Inicial Panel??? I don't know the name in English) and found Scrivener in search. I click it, nothing happens.

Someone knows what am I doing wrong?

EDIT

Trying command line

alexandre@ubuntu:~$ Scrivener
/usr/bin/Scrivener: 2: /usr/bin/Scrivener: /usr/share/scrivener/bin/Scrivener: not found

I went to /usr/share/scrivener/bin and tried to run Scrivener. Nothing happens, but the file exists.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 20, 2012 4:11 am
by garpu
lemke0 wrote:alexandre@ubuntu:~$ Scrivener
/usr/bin/Scrivener: 2: /usr/bin/Scrivener: /usr/share/scrivener/bin/Scrivener: not found

I went to /usr/share/scrivener/bin and tried to run Scrivener. Nothing happens, but the file exists.


Does it start if you do "./Scrivener" within the Scrivener directory? Sounds like you need to edit your PATH.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 20, 2012 4:14 am
by lemke0
Thank you for your answer. What happens is that:


alexandre@ubuntu:/usr/share/scrivener/bin$ dir
accessible graphicssystems phonon_backend scrhashsum
Aspell iconengines reportdmp Scrivener
bearer imageformats resources sqldrivers
codecs inputmethods rtfi Tutorial.scriv
alexandre@ubuntu:/usr/share/scrivener/bin$ ./Scrivener
bash: ./Scrivener: Arquivo ou diretório não encontrado

The last line translates as "File or directory not found"

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 20, 2012 4:53 pm
by lemke0
Funny thing. I installed a game (Limbo) and I saw "libqtsomething" beeing installed together. Now Scrivener runs normally.

:D :D :D :D :D :D

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 20, 2012 5:23 pm
by garpu
Limbo's a good game. :) (I also test for Humble Bundle.)

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Tue Aug 21, 2012 2:34 am
by lemke0
garpu wrote:Limbo's a good game. :) (I also test for Humble Bundle.)


Cooooooooool

I uninstalled Limbo and ran "sudo apt-get autoremove". A lot of the pachages from Limbo install were gone, but Scrivener still runs normally.

As I don't have a list of all packages that Limbro required, I am unable to find out what exactly was that fixed Scrivener.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Tue Aug 21, 2012 11:37 am
by garpu
It could've very well been some sort of path or library path variable being tweaked, or it could've run ld.so.conf or something to add new library paths.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Wed Aug 22, 2012 7:31 pm
by garpu
Hey cool. Just noticed you can import mp3s and video files now. :)

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Sat Aug 25, 2012 12:30 am
by lemke0
garpu, you are right.

I made a clean Kubuntu install and tried a lot of sh and bin files (mainly from HIB :) ) and none of them worked, with the same error. All of them worked fine after I installed Limbo.