Page 2 of 5

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Sat Aug 25, 2012 11:39 pm
by glaedr
The script in the other thread is working for me now. :) Though it can't find the templates but I hardly use them anyway.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 27, 2012 6:21 pm
by kush
lemke0 wrote:/usr/bin/Scrivener: 2: /usr/bin/Scrivener: /usr/share/scrivener/bin/Scrivener: not found

"sudo apt-get install ia32-libs" solves this problem.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Aug 27, 2012 8:53 pm
by lemke0
kush wrote:
lemke0 wrote:/usr/bin/Scrivener: 2: /usr/bin/Scrivener: /usr/share/scrivener/bin/Scrivener: not found

"sudo apt-get install ia32-libs" solves this problem.


Thank you very much!

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Wed Aug 29, 2012 1:49 am
by illinois68
Thank you, lemke0.

When Scrivener is offered for sale to Linux users, I will gladly pay. I have bought Apple and Windows versions.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Tue Sep 25, 2012 4:51 pm
by RobHamm
Rockin', thanks. Two minor things that are--for practical purposes--non-issues, but that you might want to be aware of, are that when installing over 1.2.5, it still says, "Same version is installed," indicating that the internal version number in the .deb file is still 1.2.5, and that the expiration date still shows as July 31, 2012.

Again, not that either has any practical effect--Just thought you'd want to know.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Mon Oct 01, 2012 2:39 pm
by Bwdjai
RevDave wrote:Thank you for the fix. That part looks good. Unfortunately the incompatible qtlibrary problem with KDE on Kubuntu still exists.


From this I would guess you have forced Scrivener to run under KDE?

Could you tell me how?

Thanks, Bwdjai

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Wed Oct 03, 2012 10:17 pm
by randomclass
Bwdjai wrote:From this I would guess you have forced Scrivener to run under KDE?


Try opening a terminal and running Scrivener like this:

Code: Select all

unset QT_PLUGIN_PATH
Scrivener


You might need to change the Scrivener line to point to where your Scrivener is located.

If it works, it looks like KDE's environment variables are interfering with Scriveners version of QT's variables.
A quick fix would be a script that starts Scrivener by running those commands (what I'm doing), a better fix would be to have Scrivener (un)set a bunch of environment variables at launch (but it's been a long time since I've done any programming so no idea how easy that is to do in KDE).

Rod

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Tue Oct 09, 2012 2:33 pm
by Bwdjai
Thanks Rod, that didn't help.

I had a developer friend take a quick look and happy that he managed to fire it up I left contented.

However, if I try to open a file, other than one I have saved, Scrivener exits.

By saving a file and then changing the name of my exisiting.file to the saved.file name I have manage to open and continue to edit my original manuscripts. I can then open a 'recent file' which Scrivener knows all about?? :?

This is not the end of the world and in fact I am happy just to have it back running.

Hopefuly someone will come up with the definitve answer in the meantime as I really do like KDE ande do not want to go back to gnome just for this ... :wink:

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Thu Oct 11, 2012 5:05 pm
by sub_acoustic
Was about to install this but Ubuntu Software Centre gives me this error

Lintian check results for /home/hamish/Downloads/scrivener-1.2.6-beta.deb:
Use of uninitialized value $ENV{"HOME"} in concatenation (.) or string at /usr/bin/lintian line 108.
E: scrivener: maintainer-name-missing lee@literatureandlatte.com
Use of uninitialized value $name in pattern match (m//) at /usr/share/lintian/lib/Lintian/Check.pm line 197.


Guessing this is nothing too serious...

Anyway I'm on 64-bit so I needed to force architecture...it installed, but does not work....
Scrivener doesn't even start up...how much longer till a bulletproof commercial version is released? Slightly impatient, but then I have half a project that I can't even work on...I'll try to roll back to 1.2.5, I only started getting the RTF reader error today, after months without problems

Okay that's weird, removed 1.2.6,
reinstalled 1.2.5, got RTF reader error again
removed 1.2.5
reinstalled 1.2.6
works perfectly!

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Sat Oct 13, 2012 1:32 am
by SamAdams
I am a newbie to ubuntu, Just bought a new laptop and when I try to install scrivener it goes to software center but it seems like it never recognizes it's installed. I didn't have any trouble installing on an ubuntu desktop..any ideas?


Thanks in advance for any help

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Sun Oct 14, 2012 5:35 pm
by teemcp
SamAdams wrote:I am a newbie to ubuntu, Just bought a new laptop and when I try to install scrivener it goes to software center but it seems like it never recognizes it's installed. I didn't have any trouble installing on an ubuntu desktop..any ideas?


Thanks in advance for any help


Are you using the Unity interface on laptop?

I had the same install problem on desktop w/ Unity, but laptop worked no problem using Gnome 3.
I logged out of Unity on desktop, logged back in under Gnome, and the install worked just fine via Software Centre.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Tue Oct 16, 2012 12:43 pm
by rkathey
I installed it on 12.4 under Unity and it worked fine. Of course, I had the previous version installed and so may have already made the configuration changes required.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Tue Oct 16, 2012 4:40 pm
by ThatPoshGirl
I installed in 12.04 under gnome. The application doesn't show up in the software center, but it is installed and works fine.

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Wed Oct 17, 2012 2:16 am
by SamAdams
Are you using the Unity interface on laptop?

I had the same install problem on desktop w/ Unity, but laptop worked no problem using Gnome 3.
I logged out of Unity on desktop, logged back in under Gnome, and the install worked just fine via Software Centre.
[/quote]

Thanks so much teem, your suggestion worked!! Thanks again

Re: 1.2.6 Scrivener for Linux RELEASED

Posted: Wed Oct 17, 2012 6:29 pm
by meta
Seems to work for me on 64 bit Kubuntu 12.04. I have a bunch of 32 bit compatibility libraries installed, though.

Still, excited to try it out for my next documentation project.