Scrivener Scratchpad Uses Invalid Linux Pathname

Posts: 9
Joined: Wed Jan 30, 2008 9:04 pm
Platform: Linux
Location: GA

Wed Feb 06, 2013 9:34 pm Post

I can confirm Graybyrd's observation with the latest beta. Simply clicking the fist and then hitting cancel enabled me to create new notes, rename them, and edit/add text. I still can't drag or resize the window.

The information below may be completely irrelevant to this issue and may not be an issue at all. It's all I've got to offer. From terminal...

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/ /usr/lib/i386-linux-gnu/pkcs11/ cannot open shared object file: No such file or directory
QPixmap::scaled: Pixmap is a null pixmap

64-bit Ubuntu 12.10 w/ KDE

Posts: 25
Joined: Wed Mar 17, 2010 11:12 am

Mon Feb 18, 2013 9:27 am Post

Hmm. I haven't been able to edit the text using Graybyrds 'workaround', though I am able to select text that was already entered and send it to Scrivener.
Thanks very much to those working on this problem. It would be really nice to see the scratchpad working. (I'll keep looking in here every once in a while.)

Posts: 2234
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Oct 06, 2014 8:54 pm Post

I'm seeing this problem (scratchpad cannot edit texts, the window isn't movable, any keystrokes are passed straight through to the main Scrivener window) in the latest beta ( 32 bit) on Bodhi 3 RC1 based on Ubuntu 14.04, using Enlightenment 19 as the desktop.

From the fact there have no posts on this subject for a long while, I assume the bug has been fixed, yet it's still not working for me. For those who have it working, was there anything special you did?

Posts: 25
Joined: Wed Mar 17, 2010 11:12 am

Mon Dec 01, 2014 12:49 am Post

Not fixed for me I'm afraid.
I haven't checked whether I've got the latest Linux version though. Will have to do so when I'm next on my Mint Linux laptop.
All the best,

Posts: 38
Joined: Wed Jul 16, 2014 8:14 am
Platform: Linux + Windows

Tue Dec 02, 2014 12:06 am Post

I have the same problem. I cannot put any text into Scratchpad notes or rename the notes, including after applying the fist-cancel workaround.

Ubuntu 14.10, Scrivener 32-bit.

Posts: 67
Joined: Mon Dec 03, 2012 11:07 am
Platform: Linux + Windows

Thu Dec 04, 2014 12:24 am Post

The scratchpad isn't really part of my workflow, so I'd almost forgotten this niggle, but I just did a little experimenting. (Latest beta, Mint 17.) It turns out I can now cut and paste into the Scratchpad window from within Scrivener, but still not type in it, and the scratchpad window is still not movable.

Posts: 38
Joined: Wed Jul 16, 2014 8:14 am
Platform: Linux + Windows

Fri Aug 28, 2015 3:37 pm Post

Scrivener, Ubuntu 15.04 64 bit.

I made a little Scratchpad discovery today which I thought I would share with the rest of the class.

So the problem is that after the Scratchpad opens, it cannot receive any keyboard input either in the Note name pane or in the Note content pane. This means that when you have the fault you can do anything you can accomplish with a mouse, but nothing which requires the keyboard. You can always cut, paste etc by using the right-click menu which comes up when you click into the right-hand (note content) pane. You can even rename notes if you double-click on the note name, and then paste in your new title via the right-click menu. But you can't get the keyboard input.

Graybyrd's fix - clicking the 'fist' (Print Screen or Selection window) and then choosing 'Cancel' - seems to work for quite a few people but not for me.

What *does* work for me is clicking the fist, making the buttons on the new window viewable if necessary, selecting 'Grab an area with Mouse', selecting an area and releasing it, and then going back to the Scratchpad.

But the Scratchpad is still definitely not movable for me.

Posts: 14
Joined: Sat Jan 13, 2018 5:30 pm
Platform: Linux

Sat Feb 17, 2018 10:16 pm Post

Graybyrd's Scrathpad post, earlier in this thread, works for me.

I use the Tool menu to launch the Scratchpad. Click on the fist. Move my cursor to the bottom edge of the underlying dialogue window, drag the controls down into view, and hit the Cancel-button with the mouse cursor. The Scratchpad content and note names can then be edited. Overall window is still frozen in place.

The fix appears to need the mouse movement when dragged the button of the underlying dialogue and then hitting the cancel button - because I tried substituting the mouse movement step with just 2 Tab-keys & Enter-key to get to hit the Cancel-button and it does not work. Which would explain why Happydemic's version of the fix, above, relies on mouse movement as well.

I'm using Scrivener (beta) 64-bit on UbuntuStudio 16.10 on a Asus with Centrino 2 & nVidia.

Thanks all!