Page 1 of 1

libgthread

Posted: Thu Oct 06, 2011 3:25 pm
by weedfreak
After installing I try to run Scrivener and get the message

Code: Select all

Scrivener
/usr/share/LiteratureAndLatte/bin/Scrivener: error while loading shared libraries: libgthread-2.0.so.0: cannot open shared object file: No such file or directory

Where can I get this lib from? it does not, at first glance, to available from Debian repositories.

ldd also shows that libglib is missing due to the fact that I only have the 64 bit libs installed, posts here seem to imply that this is only needed for spell checking, perhaps I am wrong. Do I really need 32 bit libglib even if I have no interest in spell checking - yet?

Forgot to mention that the same error is present if I install from tarball or deb, interestingly the deb install does not throw a hissy fit about the missing libraries.

Re: libgthread

Posted: Tue Oct 11, 2011 10:53 am
by gaffe77
Had the same problem.

I think you need to install ia32-libs-gtk

Best,
Geoff

Re: libgthread

Posted: Sun Oct 16, 2011 8:07 pm
by JG Starsoupsky
@weedfreak

For Debian-based distros, use dpkg -S to find the source package. On my system this gives

Code: Select all

$ dpkg -S libgthread-2.0.so.0
libglib2.0-0: /usr/lib/i386-linux-gnu/libgthread-2.0.so.0.3000.0
libglib2.0-0: /usr/lib/i386-linux-gnu/libgthread-2.0.so.0


This may not solve your problem, but it's worth seeing if you have the relevant package installed or not.
Use something like this to see if it's installed on your system:

Code: Select all

$ dpkg -l | grep libglib