Page 1 of 2

Spelling Ubuntu 11.04

Posted: Sat Apr 30, 2011 7:47 pm
by karl
I've just installed Ubuntu 11.04 and a fresh install of Scrivener 0.2.3 and now have no spell checking. Does anyone have any idea how to rectify this?

Re: Spelling Ubuntu 11.04

Posted: Sun May 01, 2011 3:56 pm
by ubersoft
Are you using 64-bit?

Re: Spelling Ubuntu 11.04

Posted: Sun May 01, 2011 4:03 pm
by karl
ubersoft wrote:Are you using 64-bit?


No, 32.

Re: Spelling Ubuntu 11.04

Posted: Tue May 03, 2011 2:02 pm
by underpope
My understanding is that spell check in Scrivener depends on aspell being installed. Is it possible that it is not on your system?

Re: Spelling Ubuntu 11.04

Posted: Tue May 03, 2011 4:06 pm
by karl
underpope wrote:My understanding is that spell check in Scrivener depends on aspell being installed. Is it possible that it is not on your system?


You are correct, it uses aspell which is on my system.

Re: Spelling Ubuntu 11.04

Posted: Wed May 04, 2011 9:02 pm
by jrs71
I have the same problem. Just upgraded to 11.04, and spelling in Scrivener is gone. Aspell is still installed.

Re: Spelling Ubuntu 11.04

Posted: Fri May 06, 2011 1:18 pm
by garpu
Are you sure it's not when you have multiple documents showing? With the new version of the beta, in both windows-wine and linux native, I don't see spell checking if I have multiple documents selected. When I'm viewing one document, it'll show.

spell-disappear.jpeg
with more than one showing
spell-disappear.jpeg (218.36 KiB) Viewed 2207 times


spell-disappear1.jpeg
with only one showing
spell-disappear1.jpeg (250.46 KiB) Viewed 2207 times

Re: Spelling Ubuntu 11.04

Posted: Sat May 07, 2011 9:44 am
by karl
No, it doesn't work with one document open either.

Re: Spelling Ubuntu 11.04

Posted: Wed May 11, 2011 6:10 pm
by Rithe
I just did a fresh install of Kubuntu 11.04, and it looks like everything is working there.

Re: Spelling Ubuntu 11.04

Posted: Wed May 11, 2011 6:53 pm
by sprat
I upgraded to Natty a few days ago and spelling was working fine in Scrivener beta 11, which was the version I had installed at the time. Today I upgraded to Scrivener beta 13 and am now missing spellcheck. Aspell was already installed. I removed it and reinstalled it just to see, then relaunched Scrivener, but no luck.

Spellcheck launches fine -- it just doesn't find any mistakes. Strange.

Re: Spelling Ubuntu 11.04

Posted: Thu May 12, 2011 1:22 am
by pearlbear
I just installed a fresh copy of the beta on 11.04, and I don't have spelling either. I've got aspell installed and working fine.

Re: Spelling Ubuntu 11.04

Posted: Thu May 12, 2011 12:13 pm
by cwoac
I had this problem on debian, fix may well be the same. You *need* libaspell-dev installed as well.

Re: Spelling Ubuntu 11.04

Posted: Thu May 12, 2011 3:27 pm
by sprat
Thanks, cwoac! I installed libaspell -dev and relaunched Scrivener -- spelling is back for me on Ubuntu 11.04.

Re: Spelling Ubuntu 11.04

Posted: Thu May 12, 2011 6:06 pm
by karl
cwoac wrote:I had this problem on debian, fix may well be the same. You *need* libaspell-dev installed as well.


Unfortunately this didn't work for me :(

Re: Spelling Ubuntu 11.04

Posted: Thu May 12, 2011 9:04 pm
by cwoac
Most peculiar. May well be reaching the point of stracing it. I'll try and figure out tomorrow which invocation is needed.