Bug Report - Blacked Out Text[BUG LOGGED]

St
SteveO
Posts: 10
Joined: Thu Nov 11, 2010 7:44 am
Platform: Windows

Thu Nov 11, 2010 8:02 am Post

I'm running Scrivener for Windows beta 3 on Vista.

Opening it today there was something amiss! ;-)

My text was presented in the editor as black text on a black background (should have been a white background). See attached screen shot.

The opening page was the only page displaying this issue. It was resolved by changing the background colour via the editor tool bar.


Steve
Attachments
11-11-2010 07-33-58 - Scrivener Screen Grab.png
11-11-2010 07-33-58 - Scrivener Screen Grab.png (7.43 KiB) Viewed 4206 times

St
SteveO
Posts: 10
Joined: Thu Nov 11, 2010 7:44 am
Platform: Windows

Thu Nov 11, 2010 8:25 am Post

Correction: another page (my doc has five pages) is showing the blacked out text; I hadn't scrolled down the page sufficiently to see it earlier.

Steve

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Thu Nov 11, 2010 9:43 am Post

Steve, which beta version are you running?

St
SteveO
Posts: 10
Joined: Thu Nov 11, 2010 7:44 am
Platform: Windows

Thu Nov 11, 2010 9:48 am Post

I'm running Scrivener for Windows beta 3

Steve

St
SteveO
Posts: 10
Joined: Thu Nov 11, 2010 7:44 am
Platform: Windows

Thu Nov 11, 2010 9:51 am Post

I can also add that this has only happened once, it's not something that happens every time I open Scrivener.

That makes it worse to track down I know ;) Sorry!

Steve

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Thu Nov 11, 2010 10:04 am Post

Thanks Steve. Keep me posted. I can't reproduce this, I even tried highlighting in black and then removing highlight, save and close etc.?

bo
boxlady
Posts: 3
Joined: Thu Nov 11, 2010 12:50 am
Platform: Windows

Thu Nov 11, 2010 4:23 pm Post

I have also had this happen, but have found its just highlighted in black with black text. You can work around it if you set the text to a different color or highlight/change after opening.

ap
apalimpsest
Posts: 2
Joined: Sat Nov 13, 2010 7:06 pm
Platform: Windows

Sat Nov 13, 2010 7:09 pm Post

I am having a similar issue. My blacked out text came from text I copied and pasted from google docs. In addition to this bug, I am somehow missing or cannot view the "font toolbar" (which I can see in the tutorial version of Scrivener but not in my current project). I also tried to un-highlight the text with no results. Everything is black (text and highlighting) and I cannot find a way to fix it. Please advise.

sh
shinobi42
Posts: 3
Joined: Thu Nov 11, 2010 2:36 am
Platform: Windows

Sun Nov 14, 2010 2:44 am Post

I just opened Scrivener to this issue as well. I had to go through and turn the highlight off on several pages. I made a backup last time I had opened the file, and I wasn't having that issue at the time. The next time I opened it several pages were blacked out. I have closed and re opened the file and now they are okay.

It may have been text that I copied from Google documents, it was in a different font than some of the text that was imported from a .rtf.

St
SteveO
Posts: 10
Joined: Thu Nov 11, 2010 7:44 am
Platform: Windows

Sun Nov 14, 2010 10:11 am Post

I've not been able to reproduce this despite really trying!

One thing I can add, my text was not pasted in from elsewhere so that's a bit of a red herring, inviting tho' it is as a possible route to finding the bug.


Question to the others who have experienced this:

I noticed this issue on two pages in my 5(??) page document, did you see it on more than one page too?

In my case the size/area of the 'redacted' text was roughly the same. On the page I took the screen shot from it covered all of the text on that page and this was the page that loaded when I launched Scriv, it was also the the last page that I had worked on. The other page affected had quite a bit more text but only a small part of it was blacked out.

I mention the above because I'm scratching my head, trying to think of way to find common factors to try and squish this bug.

Steve

ne
nerdymama
Posts: 1
Joined: Sun Nov 14, 2010 10:05 pm
Platform: Windows

Sun Nov 14, 2010 10:11 pm Post

The blacked out text bug is happening to me as well.

I am using beta 1.3 and I also copied my text from Google Docs (the culprit?).

However, I only encountered the bug when I opened the export zip file that I created in Scrivener on my Vista laptop on my Win7 machine. The text seemed fine on my laptop.

ki
kippras
Posts: 19
Joined: Wed Oct 06, 2010 11:02 pm

Tue Nov 16, 2010 5:30 am Post

I too have copied my text from Google Docs and had it do the same exact blacked out thing--but I hit "Close Project" from the File menu first. It closed Scrivener altogether and then when I opened it back up, the opening page had blacked out text in a different type font and a different size. Selecting "none" for the highlighting worked to get rid of the black highlighting.

sh
shinobi42
Posts: 3
Joined: Thu Nov 11, 2010 2:36 am
Platform: Windows

Wed Nov 17, 2010 3:54 am Post

Could it be a font related issue? Most of my text is in veranda 10, but the blacked out part is newly added text in Arial 10? (This just happened to me a second time.)

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Sat Nov 20, 2010 7:30 am Post

Strange indeed. I will log and investigate further; however, if anyone can reproduce this reliably and document it that will really help me iron this one out quickly as I'm scratching my head right now. Feel free to email me if you can do this: lee AT literatureandlatte DOT com.

ro
robcampbell
Posts: 11
Joined: Sat Nov 20, 2010 10:59 pm
Platform: Windows
Location: Wellington NZ

Sat Nov 20, 2010 11:35 pm Post

I've had a similar issue, which occurs when I paste in text (from Word (yes I still use it), OpenOffice, LibreOffice and Scrivener itself.)
Pasted in text (CTRL-C / CTRL-V) frequently appears in curious fonts (eg MS Shell Dlg 2 ; 8 point)
Highlighting the offending text, then changing to preferred font (in my case Times New Roman 12) often doesn't work.
Closing Scrivener, then re-opening sometimes reveals blacked-out text. When the black background is removed - presto - I'm in Times Roman.

This is an intermittent problem (the best kind!). But it's there.
I'm running Scrivener 1.3 on Win XP SR 3

Have fun!