Glitch with copy+paste [BUG LOGGED]

User avatar
kalidasa
Posts: 11
Joined: Mon Nov 01, 2010 11:19 pm
Platform: Windows
Location: Wollongong, NSW, Australia
Contact:

Tue Nov 02, 2010 2:14 am Post

I've encountered what I feel could be a pretty serious bug with the Windows beta - whenever I copy and paste a huge chunk of text into any of the text windows, a great deal of the pasted text won't appear where it should. Additionally, whenever I scroll down the page with the arrow keys, the cursor disappears when it reaches an invisible bit of text. The only way I've been able to get around the disappearing text is to copy and paste a paragraph at a time. It's very time consuming and extremely frustrating, as you can probably guess. I'm running the beta on Windows 7 Home Premium.

User avatar
mightygitis
Posts: 236
Joined: Tue Oct 26, 2010 3:46 am
Platform: Windows
Location: Hampton Roads
Contact:

Tue Nov 02, 2010 2:34 am Post

Two things to try.

First try copying the text into notepad. Then recopying and pasting it into Scrivener.

Second, if you have invisible text go up to View => Show Invisibles. Does your text reappear? If it did you can now turn off view invisibles and your text will remain behind.

The beta has logged issues with copying and importing large bodies of text.
I am running Scrivener Beta 1.4 onWindows XP Home Edition w/ Service Pack 3 installed on a Acer Aspire One netbook computer. I am also running it on Windows Vista Home Basic on a Dell Inspiron E1405 laptop.

Check the Bug List before you post!

User avatar
kalidasa
Posts: 11
Joined: Mon Nov 01, 2010 11:19 pm
Platform: Windows
Location: Wollongong, NSW, Australia
Contact:

Tue Nov 02, 2010 6:58 am Post

I've been using Notepad as an intermediary for copying and pasting since I started using Scrivener (I use it for Word as well), but that doesn't fix the issue. However activating "Show invisibles" did fix it temporarily - as soon as I clicked another document within the file and then clicked back on the document I had been working with, though, the text disappeared again. :? I suppose I could activate that option for every document I work with, but it's just a matter of remembering to do it each time.

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Tue Nov 02, 2010 8:31 am Post

Thank you. We are aware and trying to fix this bug as soon as possible.
Lee

st
stormlyht
Posts: 4
Joined: Tue Nov 02, 2010 4:53 pm
Platform: Windows

Tue Nov 02, 2010 5:13 pm Post

Just thought I should add my two cents here, as this was the second issue I had with Scrivener. First of all, I copied straight from WordPad and am using Window's 7. Secondly, when I went to full screen mode, all the missing text came back in the full screen and when I exited full screen it was still there in the window. Then I went to leave a note for myself under the research tab and when I returned to the text it had missing paragraphs once more. That's what brought me to the forum to look for any comments regarding it. I type fast, so when I read that if I turn off spell check it probably won't take forever to show what I'm typing I went in to turn that off. Miraculously all the text that had disappeared showed up! I even floated between parts just to make sure it was still there.

I'm going to go back to writing now, but I thought all of that could be useful so there it is!

-Stormy