Cannot vertically resize non-max Scriv window[BUG LOGGED]

Be
BethCutter
Posts: 91
Joined: Sun Oct 24, 2010 4:52 am
Platform: Windows

Thu Oct 28, 2010 9:34 pm Post

Running W7, current screen resolution: 1366 X 768. (Yeah, strange, but that's the recommended dimensions.)

When scrivener is in a non-maximized window I am unable to change the vertical size of the window.

If I pause the mouse on a side border I get the two-headed arrow and can drag the border left/right as expected.

If I pause the mouse on the top border I get the two-headed arrow but dragging up or down doesn't change the window at all.

If I pause on a corner I get the diagonal two-headed arrow but I can only change the horizontal dimension.

If I pause on the bottom border, well, I can't. The window is too tall for my screen, so I cannot see the border or the footer info line at all.

The bottom border AND the footer line both appear when the Scrivener window is maximized.

I changed my screen resolution, but it didn't affect this behavior except for making the unviewable bottom problem worse. (768 is the maximum vertical resolution the monitor will do.)

Note: I am able to resize any other window on my screen as usual, so I think this must be due to Scrivener itself.

Sp
Spitfire
Posts: 211
Joined: Sat Oct 16, 2010 6:09 pm
Platform: Windows

Thu Oct 28, 2010 10:11 pm Post

Do you have the inspector open? In another thread it was determined that the inspector had to be a specific height which I believe was somewhere in the 700px range.

Be
BethCutter
Posts: 91
Joined: Sun Oct 24, 2010 4:52 am
Platform: Windows

Thu Oct 28, 2010 11:02 pm Post

Yes, the Inspector was open! After closing it, I was able to resize the window vertically. Which is at least a workaround to let me see the word counts. Thank you! :)


Then I experiment some more and found another weirdness:

With the Inspector open, and the Scrivener window non-maximized, and the bottom of the window again invisible: I moved the window down on the screen a short distance. Then I again tried to resize the window vertically (just to be sure that glitch was still there.)

Still couldn't make the window shorter BUT if I grab the top margin and try to stretch it taller the window instead 'jumps' down on the screen! Repeated the attempt to stretch it taller, and each time got that downward jump.

Note: the window wasn't getting at all shorter, the top margin was just being repeatedly located lower on the page. Actually, maybe the window WAS getting taller as well as shifting location: when you can't see the entirety of the window you can't tell.

Weird, but it doesn't really create a problem, you can still grab and move the window back up.

Sp
Spitfire
Posts: 211
Joined: Sat Oct 16, 2010 6:09 pm
Platform: Windows

Fri Oct 29, 2010 12:43 am Post

Huh, that is weird. I just duplicated it on my netbook (as my full size laptop won't let me create a project at all) and it does jump down the screen. I'm thinking the window doesn't resize because I can't even drag the top of the window taller but someone with a bigger resolution screen should check. As soon as I click the top it jumps down.

Sp
Spartachris
Posts: 38
Joined: Fri Oct 29, 2010 3:00 am
Platform: Windows

Fri Oct 29, 2010 3:04 am Post

Same thing here, with the same monitor resolution. With me, it looks great full-screen. :?:

An
Annetheia
Posts: 13
Joined: Tue Oct 26, 2010 12:45 am
Platform: Windows

Fri Oct 29, 2010 3:58 am Post

Dittoing.

I had this same situation-only I thought it was meant to be that way.

But, I closed the inspector, and I can use both the diagonal arrow and the Up-down arrow for the height.

And my resoultion is at 15-something-something by 768; I checked that first. With, I should probobly mention on a Gateway PC, XP (home), with service pack 3.

sh
shayd
Posts: 4
Joined: Fri Oct 29, 2010 3:51 pm
Platform: Windows

Fri Oct 29, 2010 4:11 pm Post

Interesting - was having same issue, working on my netbook. Thanks for the tip about the Inspector.

With the Inspector open, I cannot fit all of Scrivener vertically on my screen (Win XP with taskbar showing, resolution 1366x768). Easy enough to switch it to full screen, which solves the problem, but annoying that I can't keep the Inspector open and make it fit in a non-maximized window. It's just a few pixels shy...

La
Laxaria
Posts: 125
Joined: Tue Oct 26, 2010 3:10 am
Platform: Mac + iOS

Fri Oct 29, 2010 4:22 pm Post

Bug has been logged.

The best (temporary) fix is really to disable the Inspector view.