Margins and fonts changing on close/reopen [FIXED]

Kr
Kromey
Posts: 3
Joined: Tue Oct 26, 2010 6:18 am
Platform: Windows

Tue Oct 26, 2010 7:44 am Post

When creating a new document, the indentation settings automatically set the first line of a paragraph to half an inch -- which is exactly where I want it, so I'm happy about that. However, after typing text into said document, then closing Scrivener, and later returning to my project, the indentation for all documents which I have typed in are reset to the far left margin.

Additionally, while new documents are defaulting to Verdana Regular 10, after typing in the document, closing and then re-opening the project, all files are reset to Verdana Regular 8.

Manually changing the font (even to the new document default of Verdana Regular 10) does appear to stick, however manually adjusting the indentation still reverts to the far left margin upon saving and re-opening the project.

In either case, a document that is created but has no content entered does not change as described above -- whatever is causing this bug is being triggered by the presence of content in the document or the act of typing in the document.

li
lizbee
Posts: 13
Joined: Tue Oct 26, 2010 4:12 am
Platform: Windows

Tue Oct 26, 2010 8:13 am Post

I had something similar happen also. I was writing in Calibri 11 pt., and the formatting was lost completely. See screenshot of original here: viewtopic.php?f=32&t=8741

The font changed when I reopened to MS Shell Dlg 2, 8 pt., and all the indenting was lost. I've been struggling to find a formatting setting that was similar to the default formatting, but I haven't had any luck.

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Tue Oct 26, 2010 8:51 am Post

I have been able to duplicate this problem and logged a bug to fix. Thank you for taking the time to provide feedback.

Sp
SpirosD
Posts: 31
Joined: Sat Jan 03, 2009 3:30 pm

Tue Oct 26, 2010 6:11 pm Post

The exact same thing happened to me, 8 point type instead of my usual 18 point type.

Did a real number on my fading eyes. Now I look like this guy → :shock:

:)

Ps
Psychomacologist2.0
Posts: 26
Joined: Tue Oct 26, 2010 4:28 pm
Platform: Windows

Wed Oct 27, 2010 12:01 am Post

I also had this problem, and I posted the details here:
viewtopic.php?f=32&t=8890&p=72087#p72087
...because I didn't realise this bug had already been noted >.>
~I aim to misbehave~
"People should not be afraid of their Governments. Governments should be afraid of their people."

Sp
SpirosD
Posts: 31
Joined: Sat Jan 03, 2009 3:30 pm

Wed Oct 27, 2010 6:46 am Post

Hi Lee, I don't know if this helps your investigation but:

I've noticed that I DON'T have the "small font upon reopening" problem when I close and reopen Scrivener at work, where I plug my laptop into a docking station and external screen. (I still have the "missing indent" problem, though)

When I disconnect the laptop from the docking station and external screen and then close and reopen Scrivener, I get the "small font upon reopening" problem again, with all fonts down to 8 points.

Hope this helps.

Ps
Psychomacologist2.0
Posts: 26
Joined: Tue Oct 26, 2010 4:28 pm
Platform: Windows

Wed Oct 27, 2010 11:56 am Post

Further update on the fonts-changing-size issue:

1. Typed some test font into a document (was testing something else)
2. Went to trash and emptied the trash folder (right click> empty trash)
3. Switched back to the document - the font had shrunk from Verdana 10pt to Verdana 8pt

This was without closing/reopening - all I did was empty the trash folder. This seems to be triggering the font size change as well.

Hope this helps!
~I aim to misbehave~
"People should not be afraid of their Governments. Governments should be afraid of their people."

Ha
Haiden
Posts: 1
Joined: Thu Oct 28, 2010 12:53 pm
Platform: Windows

Thu Oct 28, 2010 12:58 pm Post

Also having this problem. Margins reset when I close the project. However, the font size doesn't change.

Operating System: Windows 7 and Windows Vista.

Ma
Mankindof
Posts: 10
Joined: Wed Oct 27, 2010 6:01 pm
Platform: Windows
Location: Austin, TX

Thu Oct 28, 2010 1:34 pm Post

I have a feeling the font resizing is related to the indent resetting, and that both have to do with parsing the RTF tags. I experienced the same behavior: after clicking on another document within the project and clicking back into the the first document, the font has resized from 12pt to 8pt.

But when I look at the underlying RTF doc in Word or WordPad, it displays correctly at 12pt.

I saw that the tag \fs was set correctly to \fs24 (which corresponds to 12pt font size).

For fun, I changed it to \fs30. When I opened Scrivener, it correctly displayed the text at 15pt.

Further observation: When a text file reverts to 8pt font, and I set it back to 12pt, it seems to hold at that point. After I set the font back to 12pt, I could not get it to revert back to 8pt. But when I create a new text doc, close Scrivener and reopen, the text in ONLY the new text doc resets to 8pt.

Ps
Psychomacologist2.0
Posts: 26
Joined: Tue Oct 26, 2010 4:28 pm
Platform: Windows

Thu Oct 28, 2010 3:31 pm Post

Some further observations on this issue:

1. In a document where I don't adjust the font at all, it automatically types as 10pt Verdana; but when I close and reopen, it's shifted back to 8pt (as mentioned above)
2. In another document, I manually changed the font to be 12pt. This formatting remained after close/reopen
3. When the font size has been adjusted in one doc (either before typing, or by typing then selecting all and changing it) that formatting carries over to either the next empty (unformatted) doc, or to a new doc created for the purpose.
--> so, I changed the font size to 12pt, typed some, then went to the next empty doc and typed some more, and instead of being in the 'default' (10pt Verdana) it was 12pt Verdana. Same thing happened if I created a new doc and started typing in it.

4. Formatting did not carry over in this way into documents where I'd manually set font size - i.e. if I set font to 14pt and typed, then went to a doc where I'd manually set font to 12pt and typed - it would come as 12pt not 14pt. But when I went to a new or empty doc, it would come up as 14pt.

This seems buggy to me, because if the "default" text is 10pt Verdana then all docs created should automatically type in that font until I manually change it. And if I manually adjust it in one doc I don't expect that to affect how the font comes up in an unformatted doc - it should revert to the default by... well... default 8)
~I aim to misbehave~
"People should not be afraid of their Governments. Governments should be afraid of their people."