script mode - greys out after two switches [BUG LOGGED]

Ci
Cimeries
Posts: 11
Joined: Mon Oct 25, 2010 10:59 pm
Platform: Windows

Mon Oct 25, 2010 11:13 pm Post

After switching from the default editing mode to script mode, either by clicking Format > Scriptwriting > Script Mode or using the ctrl+m shortcut and then switching back, the option will become greyed out and unusable, and the shortcut will no longer work either. This is document specific so simply selecting a seperate document in the binder will allow you to change to script mode and back for that document, and when you return to the original document the problem will have gone away.

ni
ninjakittyofdoom
Posts: 11
Joined: Tue Oct 26, 2010 2:13 am
Platform: Windows

Tue Oct 26, 2010 2:48 am Post

I can confirm this one, and here's a screenshot(attached to the post).
Attachments
ScreenShot001.jpg
ScreenShot001.jpg (13.02 KiB) Viewed 926 times

jo
jo1
Posts: 11
Joined: Mon Oct 25, 2010 6:06 am
Platform: Windows

Tue Oct 26, 2010 3:15 am Post

Hitting Ctrl + M to toggle in and out of Screenwriting mode only works twice.

1 - Hit Ctrl +M, screenwriting mode turns on
2 - Hit Ctrl +M again, screenwriting mode turns off
3 - Hit Ctrl +M another time and nothing happens. Document stays in standard form no matter how many times Ctrl + M is pushed.

Switching to another document allows Ctrl + M to work for the new document, but again, only twice. Switching back to the original document seems to reset the Ctrl + M limit - you can toggle that document again, but only twice.

note: going to Format -> Screenwriting in a fresh document shows the Script Mode-Screenplay option as activated. But like the Ctrl + M feature, this option only works twice before it is grayed out and unusable. Changing to a new document reboots the feature.

po
polyt79
Posts: 5
Joined: Tue Oct 26, 2010 3:11 am
Platform: Windows

Tue Oct 26, 2010 3:22 am Post

hey mod, do you want to merge this with the existing & similar bug?

User avatar
LAP
Posts: 1005
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Tue Oct 26, 2010 3:40 am Post

Thanks everyone - bug has been noted and logged for fixing :)