Text cut off at right edge of main editor.

Ke
Ken Watts
Posts: 40
Joined: Mon Jul 03, 2017 8:40 pm
Platform: Windows

Tue Mar 30, 2021 7:08 pm Post

I'm on Windows 10 with the published version (64)

I have Options>Main Editor> Appearance> Default Editor Width set at 350 points. I've checked "use fixed width editor" and "center the editor when using a fixed width", and I've set all the editor margins at 10 points.

When I'm working in the editor the last character or three in the long lines are missing--in the sense that I can't see them.

If I move the cursor to the right it moves the right number of times before jumping to the next line, but the characters themselves are invisible.

I've tried changing the zoom from 100% to both less and more, without any improvement. I've also tried changing the editor margins, but this also has no effect.

Kind of a bummer when proofreading.

User avatar
drmajorbob
Posts: 912
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Tue Mar 30, 2021 7:14 pm Post

Ken Watts wrote:I'm on Windows 10 with the published version (64)

I have Options>Main Editor> Appearance> Default Editor Width set at 350 points. I've checked "use fixed width editor" and "center the editor when using a fixed width", and I've set all the editor margins at 10 points.

When I'm working in the editor the last character or three in the long lines are missing--in the sense that I can't see them.

If I move the cursor to the right it moves the right number of times before jumping to the next line, but the characters themselves are invisible.

I've tried changing the zoom from 100% to both less and more, without any improvement. I've also tried changing the editor margins, but this also has no effect.

Kind of a bummer when proofreading.

I'd turn off fixed-width entirely. Scrivener isn't intended for WYSIWYG editing anyway.

If proofreading in Scrivener doesn't work for you, do it in a PDF or docx.
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
MimeticMouton
Posts: 9046
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Apr 01, 2021 1:30 am Post

I'm aware of this display bug when in Scrivenings mode (unrelated to fixed-width editor); if it is the same issue, you should be able to find a sweet spot of right/left margin padding and editor zoom level that will ensure the full text is displayed, though I understand you've already been fiddling with that.

If you are seeing this even when viewing only a single document, is there a difference depending on the amount of text in the editor, determining whether or not the vertical scrollbar displays?
Jennifer Hughes
(MM for short)

Ke
Ken Watts
Posts: 40
Joined: Mon Jul 03, 2017 8:40 pm
Platform: Windows

Thu Apr 01, 2021 8:59 pm Post

I opened the same project this morning, and it was absolutely fine. I can't make it repeat, so I guess this is a one-off.