v3: mysterious line of placeholders in Chapter Title

User avatar
austriaka
Posts: 98
Joined: Wed Nov 01, 2017 8:59 am
Platform: Windows

Wed Mar 24, 2021 11:00 am Post

I am an experienced v3 user since I used it from the first time it came out as a beta version. A few minutes ago I switched to the new release and everything works fine - not much of a difference to the last beta which was already great and almost ready. But there is some sort of a glitch, which I still have in the v3, so I post it here as a bug:

Since a few version updates of the beta I noticed a strange behaviour in my chapter titles. I use "Kapitel <$n>" in the options and everything works fine. But whenever I start a compilation there is a mysterious string of placeholder tags placed before the word "Kapitel", and it also shows up in the output format.
It is inserted via "Prefix". I can delete it there and everything is fine - until the next start of scrivener and the next compilation. Then it appears again and I have to remove it manually.
I think these are residuals from a former beta version, but I really want to get rid of it.

Screenshot_10.jpg
Screenshot_10.jpg (27.88 KiB) Viewed 465 times
Attachments
Screenshot_11.jpg
Screenshot_11.jpg (56.44 KiB) Viewed 465 times
Win 10 Home 64-Bit 10.0.1809
Intel Xeon CPU E3-1230 v5 @ 3,4 GHz (Quadcore) 16 GB RAM
NVIDIA Quadro K420
payed for Scrivener 1.9.7.0 & using Scrivener 2.9.9.20 Beta 64-bit

User avatar
austriaka
Posts: 98
Joined: Wed Nov 01, 2017 8:59 am
Platform: Windows

Wed Apr 14, 2021 12:21 pm Post

Could please somebody reply to this Question?
I just found a very similar line of strange placeholder symbols within the Scrivener Manual (3.0 for windows),
<!$Scr_Cs::1>
I am sure it is not intended that they are there. It looks to me that even the authors of the manual don't know how to get rid of them?
Please repair that or tell me what to do to make them disappear!

Screenshot_20.jpg
Screenshot_20.jpg (42.56 KiB) Viewed 392 times
Win 10 Home 64-Bit 10.0.1809
Intel Xeon CPU E3-1230 v5 @ 3,4 GHz (Quadcore) 16 GB RAM
NVIDIA Quadro K420
payed for Scrivener 1.9.7.0 & using Scrivener 2.9.9.20 Beta 64-bit

User avatar
Jestar
Posts: 434
Joined: Sun Feb 19, 2017 6:51 pm
Platform: Mac + Windows

Wed Apr 14, 2021 6:42 pm Post

austriaka wrote:Could please somebody reply to this Question?
I just found a very similar line of strange placeholder symbols within the Scrivener Manual (3.0 for windows),
<!$Scr_Cs::1>
I am sure it is not intended that they are there. It looks to me that even the authors of the manual don't know how to get rid of them?
Please repair that or tell me what to do to make them disappear!

Screenshot_20.jpg

You can find a list of all the Scrivener placeholders here (Help->List of All Placeholders...):
Screenshot 2021-04-14 113626.png
Placeholders
Screenshot 2021-04-14 113626.png (15.3 KiB) Viewed 374 times

A quick look through the placeholder list shows that <$....> is how they are used. What you are showing does not follow that usage - <!$Scr_Cs::1>. This could be extra stuff that came over from an import from a different document type than Scrivener? If they are showing as text, you should be able to edit and delete that stuff, yes?
Win 10 Ent. 64-Bit 20H2
Intel Core i7-2600 @ 3,4 GHz (Quadcore) 32 GB RAM
Samsung SSD 860 EVO 500GB
NVIDIA Quadro K600
Scrivener Version: Version: 1.9.16.0 - 14 Nov 2019 & Version: 3.0.1.0 (1274136) 64-bit - 28 Apr 2021

User avatar
AmberV
Posts: 24874
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Apr 14, 2021 8:48 pm Post

That code specifically shouldn't ever come up as visible in Scrivener, it is one of the hidden codes it uses to mark style usage. Last I checked, styles don't work correctly in the Prefix and Suffix fields yet, which is probably how they ended up showing as codes like that. You can safely delete them from the text, but it might be safest to just clear the field and type it in again from scratch.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
austriaka
Posts: 98
Joined: Wed Nov 01, 2017 8:59 am
Platform: Windows

Thu Apr 15, 2021 6:04 pm Post

Thank you AmberV for your reply.
Could you please tell me how to remove it?
Whenever I delete it from Prefix Field, it shows up again when restarting Scrivener, as I mentioned before - very annoying.
And obviously the makers of the help file have the same issue. So I guess I am not the only one.

@Jetstar: Thanks for your comment.
I never imported anything into scrivener from other applications. I guess this is a residual from some older version of Scrivener v2.0 beta. And I would love to get rid of it but don't know how.
Win 10 Home 64-Bit 10.0.1809
Intel Xeon CPU E3-1230 v5 @ 3,4 GHz (Quadcore) 16 GB RAM
NVIDIA Quadro K420
payed for Scrivener 1.9.7.0 & using Scrivener 2.9.9.20 Beta 64-bit

User avatar
AmberV
Posts: 24874
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Apr 16, 2021 2:41 pm Post

Hmm, if it is refusing to go away then the code that is designed to clean up and clear empty fields is not working properly either, in this scenario. My guess would be that since it isn’t properly coded to understand styled text in the first place, it also is somewhat “blind” to its presence.

If you are willing to do a little XML surgery, the problem should be easy enough to clear. With the project closed, go into the “Settings/Compile Formats” subfolder and edit the .scrformat file in a suitable plain-text editor. First, search for the Layout with the error in it, by looking for:

Code: Select all

<Layout Name="(Name of Layout)"


Once you are in the right place, search for “<Prefix>”. You can safely remove the entire span of text between the line beginning with that, and the line ending with “</Prefix>”.

Now reload the project, check the layout, and all should be well.

Needless to say, it would be a good idea to make a copy of that .scrformat file in Explorer, just in case the editing of it goes awry. It’s a relatively simple operating, no more than deleting a few lines from a text file when you get down to it, but if you’d rather not mess with things at that level, the only other alternative I can think of would be to delete the Section Layout entirely, and rebuild it from scratch.

And obviously the makers of the help file have the same issue. So I guess I am not the only one.


Speaking, and that could probably only be said in the most general of ways. These errors were found on caption lines that had or currently have an inline annotation at the beginning of the line, and is (or was) a bug found in the Mac text editor.

Thanks for pointing out those flaws, though, I’ve fixed them and they appear to be gone for good. I’ve made a search collection so that I can periodically check though, in case it is an ongoing Mac bug.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
austriaka
Posts: 98
Joined: Wed Nov 01, 2017 8:59 am
Platform: Windows

Fri Apr 16, 2021 3:13 pm Post

Thanks AmberV for your answer.
I have tried what you suggested but failed.
There is no "Compile format" folder in my Settings folder.
The only files with file ending ".scrformat" are within the Scrivener folder and point to my compile formats (not layouts).
I opened the file with the name of my problem compilation, but did not find the <$Scr_Ps::0> part.
What I found was <$Scr_H::1> what is showing up as well since I played with style settings of the Chapter Number, but all .scrformat files seem to have that.
Any ideas?
Screenshot_23.jpg
Screenshot_23.jpg (19.28 KiB) Viewed 275 times
Attachments
Screenshot_22.jpg
Screenshot_22.jpg (54.98 KiB) Viewed 275 times
Screenshot_21.jpg
Screenshot_21.jpg (53.47 KiB) Viewed 275 times
Win 10 Home 64-Bit 10.0.1809
Intel Xeon CPU E3-1230 v5 @ 3,4 GHz (Quadcore) 16 GB RAM
NVIDIA Quadro K420
payed for Scrivener 1.9.7.0 & using Scrivener 2.9.9.20 Beta 64-bit

User avatar
AmberV
Posts: 24874
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Apr 16, 2021 3:26 pm Post

Sorry, I should have anticipated that your Format may have been saved globally, rather than to the project. Yes, if it is a format found in the “My Formats” section of the sidebar, it will be in your main Scrivener support folder.

The only files with file ending “.scrformat” are within the Scrivener folder and point to my compile formats (not layouts).


Each compile Format will have its own file, and within that file there will be settings relating to the Section Layouts it has within it, among all of the other settings that make up that format. So you have to first find the file for the format you are using (it should be named similarly to what you see in the sidebar), and then you will be looking for the Section Layout that causes this issue within that file, as described.

You may or may not see all of these codes in the XML file itself. It depends upon the nature of the bug. That is why I suggest just deleting the entire Prefix or Suffix element from the XML, so as to make sure no residual formatting is left over.

I suggested searching for the elements rather than the codes, because these codes may very well exist in a valid sense elsewhere in the format, where it has been programmed to work with styles correctly (like the Title Prefix and other areas of the Formatting tab).
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
austriaka
Posts: 98
Joined: Wed Nov 01, 2017 8:59 am
Platform: Windows

Fri Apr 16, 2021 4:14 pm Post

I tried as you suggested, even deleted the format and made it new from scratch, but the line is still here. :oops:
Win 10 Home 64-Bit 10.0.1809
Intel Xeon CPU E3-1230 v5 @ 3,4 GHz (Quadcore) 16 GB RAM
NVIDIA Quadro K420
payed for Scrivener 1.9.7.0 & using Scrivener 2.9.9.20 Beta 64-bit

User avatar
AmberV
Posts: 24874
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Fri Apr 16, 2021 4:18 pm Post

All right, could you attach a zipped copy of the Format file so I can take a look at it? If it may have personal info in it (page headers/footers etc.) then feel free to PM me.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
austriaka
Posts: 98
Joined: Wed Nov 01, 2017 8:59 am
Platform: Windows

Tue Apr 20, 2021 3:34 pm Post

Thanks AmberV for your help, I managed to remove it.
I had to export the corrupted format, edit the file with a text editor, then delete the format in Scrivener and import the corrected file. Now it seems to work.
Win 10 Home 64-Bit 10.0.1809
Intel Xeon CPU E3-1230 v5 @ 3,4 GHz (Quadcore) 16 GB RAM
NVIDIA Quadro K420
payed for Scrivener 1.9.7.0 & using Scrivener 2.9.9.20 Beta 64-bit

User avatar
AmberV
Posts: 24874
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Tue Apr 20, 2021 8:04 pm Post

All right, glad that finally managed to solve it in the end.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles