Text not wrapping

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Fri Sep 12, 2014 1:23 pm Post

I'm going to post this, even though I can't reproduce it quite yet.

I write in MMD, and did a Compile to MMD so I could run it through the desktop version of HemingwayApp (useful for quick grammar checking). I did some changes, and then did a copy/paste from it into my Scrivener doc, replacing everything (Select All/Paste).

What resulted was that none of the text was wrapping, and I couldn't scroll anywhere. If I used the arrow keys to try and go to the end, it jumped to the next line. Usually in the middle of words.

I opened the doc in Notepad++ and tried it again, and got the same results. I couldn't find anything to adjust to get it to not do this, so I just undid my changes so it was like I never did this (Ctrl+Z) and saved the docs to Dropbox to try at work.

At work, I opened Scrivener, and the MMD file in Notepad++ and tried again. It pasted the way it was supposed to. No problems whatsoever.

Home: Win8.1 x64, Scrivener 1.7.2/3 (I need to verify which version)
Work: Win7 x64, Scrivener 1.7.(2/3) - I tried twice, first at .2 and checked for updates, then at .3. Both worked fine.

There could be something in the HemingwayApp that screwed up the formatting. But it's basically a text editor, so it shouldn't. I'll try again tonight and let you know what happens.

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Sat Sep 13, 2014 1:54 am Post

Something got screwed up, and I don't know what. When I do the same things on my home computer now, everything works the way it should. I can't get it to break.

I guess, be aware that it can happen. But right now, I can't confirm how to make it happen.

User avatar
MimeticMouton
Posts: 9049
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Sep 13, 2014 10:35 pm Post

My guess is that that word wrapping was on in the text editor and created a hard break at the end of every line. There's a bug with Show Invisibles in Scrivener that prevents the carriage return mark displaying when following a space, so even if you'd turned on invisibles to check it wouldn't have been obvious from that.
Jennifer Hughes
(MM for short)

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Mon Sep 15, 2014 3:19 pm Post

Yes, it was wrapping words. But would that cause Scrivener to not wrap the words when you paste it in?

User avatar
MimeticMouton
Posts: 9049
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Sep 16, 2014 12:25 am Post

Usually when a text editor is wrapping and saves, it places a hard break at the end of the line that would then be included when copying and pasting--not just to Scrivener; you can see the same thing going from Notepad to Word, for example. I haven't used the HemingwayApp, but I'm guessing it may have done this and caused the oddity when pasting.

If you get this again, try toggling on Format > Options > Show Invisibles in Scrivener and see if you have a paragraph break between lines. If you just see a single blue dot at the end of the line, put the cursor just after it and try backspacing to remove it--like I said, there's a bug where a space at the end of the paragraph will hide all other formatting marks on the line, so deleting the extra space may reveal the carriage return.

Unfortunately at the moment there's not a way to use Find/Replace in Scrivener to do a quick cleanup of the extraneous carriage returns, but you may be able to adjust the text in HemingwayApp to avoid the extra return. Otherwise you could paste in something like Word as a midway point and use the find/replace there to get rid of the extra returns, then copy and paste that to Scrivener.
Jennifer Hughes
(MM for short)