Spell checking issue.

cg
cgray77
Posts: 29
Joined: Sat May 31, 2014 6:13 am
Platform: Windows

Fri Jun 06, 2014 1:48 am Post

I've found that in numerous occasions, scrivener stops underlining spelling errors. I have to go into tools-options-corrections and click the apply button to get them to show up. The thing is, the options are already set up "check spelling as you type" and so I shouldn't have to do this. I'm not entirely certain why it's happening, but it seems like a bug.

User avatar
MimeticMouton
Posts: 8716
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Jun 06, 2014 7:15 am Post

Thanks for the report. What dictionary language are you using? Does the check spelling while typing disable in both editor splits or just one, or only in specific documents? If you can find any particular trigger, that would help greatly in tracking this down. Has this only been occurring since upgrading to 1.7.1 or did you see it previously in 1.6.1 as well? What version of Windows are you using? We've just got one other report of this same issue, but so far no way of reproducing it. The more details you can provide, the better. Thank you!
Jennifer Hughes
(MM for short)

cg
cgray77
Posts: 29
Joined: Sat May 31, 2014 6:13 am
Platform: Windows

Tue Jun 10, 2014 9:22 am Post

I just got this, so I will probably spend weds day trying to take down how the bug occurs, but right now it seems to be intermittent rather than regular and seems to have been a result of the 1.71 upgrade.

As far as I can recall is can either occur upon starting scrivener or at intermittent points after starting it. Going to correction's options menu and hitting "apply" seems to always fix it.

Another factor is that when the bug occurs, you can't bring up alternate spellings of misspelled words by right clicking--I've tried that with knowingly misspelled words so it appears that it isn't just a visual bug, but the entire subsystem is disabled.

I'll try and get back with more, but I have a few midweek deadlines to get to.

Thank you!

Na
NathanRogers
Posts: 1
Joined: Sat Jun 14, 2014 3:13 am
Platform: Windows

Sat Jun 14, 2014 3:23 am Post

I have also noticed this issue and only since upgrading. It almost always happens on start-up. As cgray77 said, it seems like the whole spell-check system is turned off even though it is checked in the options. Reapplying the option turns it back on again.

Windows XP
Scrivener 1.7.1.0
English (United Kingdom)

User avatar
TromboneAl
Posts: 1012
Joined: Sun Jan 19, 2014 2:17 pm
Platform: Mac

Sun Jun 22, 2014 8:14 pm Post

I noticed this today. I exited and restarted S and it was OK.
Al Macy
Scrivener Version 3.1.4
iMac 21.5 Version 10.15.1

eb
ebrewer27
Posts: 4
Joined: Mon Jun 30, 2014 7:49 pm
Platform: Windows

Mon Jun 30, 2014 7:52 pm Post

I'm also having this issue. Seems to be random. Running Scrivener 1.7.1.0 on Windows 7 Pro 64-bit.

Ju
Jura
Posts: 56
Joined: Wed Mar 07, 2012 4:12 pm
Platform: Windows

Tue Jul 01, 2014 8:53 am Post

I have the same issue.

MimeticMouton wrote:What dictionary language are you using?

English (United Kingdom).

MimeticMouton wrote:Does the check spelling while typing disable in both editor splits or just one, or only in specific documents?

When the window is split, the spelling check is disabled in both documents. It does not happen in specific documents; as far as I can tell the whole Scrivener project is affected.

MimeticMouton wrote:If you can find any particular trigger, that would help greatly in tracking this down.

There is, as far as I'm aware of, no trigger, at least not manually from my side. In today's occurrence of this bug, I was working on a document (split vertically with the same document in both windows) and spell check was working. Then I took a break, returned and continued working on the same document (without switching to another document or other Scrivener actions). I then noticed that the spell check was off.

Perhaps it is related to the automatic save, that occurs after x seconds of inactivity?

MimeticMouton wrote:Has this only been occurring since upgrading to 1.7.1 or did you see it previously in 1.6.1 as well?

This behaviour started with version 1.7.1.0. I'm absolutely sure of that, since I use Scrivener for a few hours every day (and make spell errors every day :) ): if this bug occurred pre-1.7.1, I'd have noticed it before.

MimeticMouton wrote:What version of Windows are you using?

Windows 7 SP1 (64bit).

********************
Edit:
Today (7-7-14) the error occurred after creating a new document (single view).

Ju
Jura
Posts: 56
Joined: Wed Mar 07, 2012 4:12 pm
Platform: Windows

Tue Jul 08, 2014 9:01 am Post

I got the following error today on Scrivener 1.7.1.0 (if this thread is still being monitored):

errorScrivener.png
errorScrivener.png (26.03 KiB) Viewed 1395 times


I'm mentioned it here because in this thread that error has been linked to spell checking issues.

Edit: After installing Scrivener 1.7.2, I still do not have that .dll file in my Scrivener folder. Where can I locate a safe version of that .dll?

User avatar
MimeticMouton
Posts: 8716
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Fri Jul 18, 2014 8:31 am Post

Scrivener doesn't use the QtSvg4 library indicated, so it isn't included in the installation. It's also not used by Aspell. I've attached a copy, but as I'm not sure what on your system is trying to access it (some plug-in that's being called?) I don't know if it will resolve the issue. I gather from your other post that Scrivener is running in spite of the message?
Attachments
QtSvg4.zip
(112.34 KiB) Downloaded 33 times
Jennifer Hughes
(MM for short)

User avatar
MimeticMouton
Posts: 8716
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Jul 19, 2014 10:58 pm Post

Thanks for everyone's reports on this. We've found that opening the Compile dialog or Project Statistics will disable the spell check in the project. Opening Options and clicking OK will reset the spell check as you type and it seems to then persist through the remainder of the session, until the project is reopened.
Jennifer Hughes
(MM for short)

Ju
Jura
Posts: 56
Joined: Wed Mar 07, 2012 4:12 pm
Platform: Windows

Sat Jul 26, 2014 5:19 am Post

MimeticMouton wrote:Scrivener doesn't use the QtSvg4 library indicated, so it isn't included in the installation. It's also not used by Aspell. I've attached a copy, but as I'm not sure what on your system is trying to access it (some plug-in that's being called?) I don't know if it will resolve the issue. I gather from your other post that Scrivener is running in spite of the message?

I don't have a Scrivener plugin, but the error message has not been triggered again in the last two weeks. Yes, in spite of the message Scrivener is running. :)

Ju
Jura
Posts: 56
Joined: Wed Mar 07, 2012 4:12 pm
Platform: Windows

Thu Aug 28, 2014 1:37 pm Post

MimeticMouton wrote:Thanks for everyone's reports on this. We've found that opening the Compile dialog or Project Statistics will disable the spell check in the project. Opening Options and clicking OK will reset the spell check as you type and it seems to then persist through the remainder of the session, until the project is reopened.

Thanks for fixing this issue in 1.7.3. :)