Editor settings don't apply to Corkboard?

Be
BethCutter
Posts: 91
Joined: Sun Oct 24, 2010 4:52 am
Platform: Windows

Mon Nov 05, 2012 3:34 pm Post

Don't know if this is a bug, or just how things are 'sposed to work:

I have my editor paragraph format set to no indent, and 8 pts space after.

But if I edit synopsis text while in Corkboard, it uses indents and no space.

This is just a little disconcerting when your eye has become used to the other way.

User avatar
temporalranger
Posts: 149
Joined: Thu Aug 09, 2012 12:34 am
Platform: Mac + Windows
Contact:

Mon Nov 05, 2012 11:07 pm Post

I don't think they're supposed to apply to synopsis text, since synopsis text is plain text rather than rich text? If you look at the editor bar, all the options are greyed out. Odd that you're getting indents, though... I'm not getting those.

User avatar
AmberV
Posts: 24411
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Nov 05, 2012 11:13 pm Post

That is correct, the default main text attributes settings only impact the text in the main editor. They do not impact the synopsis, document notes or project notes (although the latter two are indeed rich text, they don't use the same defaults as many people prefer different fonts for notes).

That said, you shouldn't be getting any kind of indent in the synopsis fields, for either Outliner or Corkboard. You're getting a result where the first line of the index card is inset a bit from the left edge of the card, and the second line and beyond is flush?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Be
BethCutter
Posts: 91
Joined: Sun Oct 24, 2010 4:52 am
Platform: Windows

Mon Nov 12, 2012 7:40 pm Post

AmberV wrote:
That said, you shouldn't be getting any kind of indent in the synopsis fields, for either Outliner or Corkboard. You're getting a result where the first line of the index card is inset a bit from the left edge of the card, and the second line and beyond is flush?



Yes. But not consistently. It's only happened with a few index cards since I made that post. I think in two cases it might have resulted from when I did a c&p to move text from the main editor to the synopsis field. Other times.... I don't know what causes it.

It's not a big problem though. If I click on the synopsis while in corkboard mode I can 'backspace' the indent way. Just one backspace -- maybe a sign that it's a tab character? -- though the indent looks like several spaces worth.

User avatar
AmberV
Posts: 24411
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Nov 12, 2012 8:55 pm Post

Ah, yes you are right, that is a tab character then, rather than a formatted indent, if it can be deleted with the backspace key. Yes that would copy over, since a tab is a character just like a letter is (technically speaking) rather than a formatting instruction, like line height or font settings would be. They can be several spaces long. How a tab character is drawn is largely up to the text editing view. For example you can make Scrivener draw them as spaced out arrows instead of blank spaces, if you turn on invisible characters. This is normal, and it's okay to just delete them when you see them.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles