Capitalization after Mr.

User avatar
RSMcGowan
Posts: 69
Joined: Mon Oct 25, 2010 9:48 pm
Platform: Windows
Contact:

Sat May 05, 2012 2:12 am Post

I tried searching as best I could for something similar, but I didn't really see it. So I'm posting this and if it's inaccurate, ignore me! This is something that hadn't come up until just now. I was trying to write "Mr. and Mrs." but the auto capitalization after periods automatically corrects it to "Mr. And Mrs." I know there's a setting to turn the capitalization off, but it would seem overkill just to stop it from capitalizing in this instance. So maybe someone can look into fixing the autocorrect for this.
Testing Specs: Windows 7 Home Premium 64-bit, HP Pavilion G7 Notebook PC, Intel i3 processor
****
Don't blink. | 2010 & 2011 NaNoWriMo Winner!

User avatar
garpu
Posts: 2004
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Sat May 05, 2012 3:57 am Post

Haven't seen you around in awhile!

ARe you using the US dictionary? If memory serves, Mr without punctuation is a UK-usage thing. But you might have to turn off auto-capitalization.
Slackware-current 64-bit, XFCE

User avatar
RSMcGowan
Posts: 69
Joined: Mon Oct 25, 2010 9:48 pm
Platform: Windows
Contact:

Sat May 05, 2012 9:18 pm Post

Yep, US dictionary. So I'm not quite sure why it's doing this. I really don't want to turn off autocorrect. Ah well.
Testing Specs: Windows 7 Home Premium 64-bit, HP Pavilion G7 Notebook PC, Intel i3 processor
****
Don't blink. | 2010 & 2011 NaNoWriMo Winner!

Ja
JanStrnad
Posts: 6
Joined: Sun May 06, 2012 7:26 pm
Platform: Windows

Sun May 06, 2012 11:01 pm Post

I have this same problem. I have a character named Sam Jr. and I have to go back to get rid of the automatic upper case. For instance, that previous sentence would read "I have a character named Sam Jr. And I have to go back...."

User avatar
MimeticMouton
Posts: 8709
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sun May 06, 2012 11:29 pm Post

The auto-capitalization is a bit over aggressive. It's something we'd like to look at and tweak if possible, so we do have it on the list. In the meanwhile, if you don't want to turn off the auto-capitalization completely, you might want to try using the abbreviations without the periods, then using a find/replace later to add them back in. Make sure you backup the project before you run a project replace, in case you accidentally replace something--you'll need to set the find/replace carefully so you don't replaces instances of the abbreviation that happen to appear inside another word, so e.g. search for the term with spaces around it or such.
Jennifer Hughes
(MM for short)

ro
ros
Posts: 2
Joined: Wed Nov 02, 2011 4:11 pm
Platform: Windows

Sat May 12, 2012 4:11 pm Post

Here’s what I did when I ran into this: Tools> Options> Auto-Correction> Edit Substitutions> click on + sign. In the “replace” box type: Mr. And Mrs. In the “with” box type: Mr. and Mrs. When you type in your document, it will capitalize And initially, but when you click the space bar, it comes up “Mr. and Mrs.”