Insert picture in Binder is jumping and not resizable

J.
J.R.
Posts: 4
Joined: Tue Dec 13, 2011 10:49 pm
Platform: Windows

Tue Dec 13, 2011 11:01 pm Post

Inserting a picture into a page in the Binder is leading to unexpected jumps in the layout. Even the Text before the picture is spaced in huge steps. Resizing by right mouse click entering some values does not work. Is this a bug or am I doing it wrong?
Win 64 - Scrivener 1.0.3 - JPG

User avatar
MimeticMouton
Posts: 9005
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Dec 21, 2011 2:02 am Post

This appears to be a bit buggy, but I'm still working on figuring out exactly what's going on here as I'm able to make it work sometimes and not others. This mostly seems to be happening when I have an image that is too large to appear entirely in the editor, so if that's the same as what you're seeing, try adjusting the editor zoom temporarily (by the double-arrow button in the left of the editor footer) to something small enough that the entire image is visible in the editor. Then right-click on the image and try resizing it.

The awkward spacing sounds like it's from having something higher than 1.0 inter-line spacing set for your text. When the image is inserted, it picks up this same line-height multiple but the spacing then gets applied to the image height, meaning that you get a much larger space over the image than you get over text set at the same multiple. To fix this, select the image by double-clicking it and then adjust the line spacing to 1.0 or 1.1. (Note that there seems to be a separate bug--though potentially related to the problems above--whereby clicking and dragging when the cursor is next to an image is producing a copy of the image, so the best way to make the selection of the image is to just double-click it.)
Jennifer Hughes
(MM for short)