9th APRIL - LEE'S UPDATE - BETA 022 RELEASED

sc
scribbles
Posts: 61
Joined: Tue Oct 26, 2010 2:44 am
Platform: Windows

Wed Apr 13, 2011 2:32 am Post

LAP wrote:We're continuing with other fixes, but thought you might appreciate an interim update.


Well, I do! :D Thanks, this is really great news--especially about the general saving! (So, is the sticky binder the same as the sticky inspector? Oh, but I see Clive's got a full screencast showing it.)

User avatar
garpu
Posts: 2041
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Wed Apr 13, 2011 3:09 am Post

Woot. Is it time you're taking donations in the form of coffee in IV bags? :)
Slackware-current 64-bit, XFCE

21
21firewire
Posts: 39
Joined: Mon Nov 22, 2010 3:20 am
Platform: Mac + Windows

Wed Apr 13, 2011 4:21 am Post

I seem to have lost the link to the Known Bugs for this latest beta version. Can anyone tell me where it is?

User avatar
MimeticMouton
Posts: 8762
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Apr 13, 2011 4:57 am Post

21firewire - I don't believe there is one at the moment. This thread contains the known known bugs, but also there are some recent posts in the Bug Hunt forum worth clicking through.

PDF Compile Error
Behold! A lengthy screencast (about 5 min) showing several attempts to create a PDF. This is all on a clean install of 022 on Win7 Pro 64bit (running in a VM). No extra PDF software is installed on the machine, nor is MS Word (although I didn't get that message during this trial). This starts with a newly created project, displaying the crash that happens if you compile blank documents (not likely to happen purposely, but possible by accident I suppose--anyway, it seems to consistently crash if you try that), then compiling with a synopsis, then compiling with text a few times. Despite appearances, three valid PDFs did get created during this process ("test3", "testagain", and "finaltest"), even when Scrivener went unresponsive. To be fair, presumably "test2" would have been created also, but it was taking so long to convert it would've used up the entire video, so I aborted. (None of the others were aborted, although occasionally that button is blue. It's a little hard to tell what I'm clicking or when I hit enter in the screencast; I apologize.)

Any time that you don't see the mouse it's because the mouse is gone. I tried to bounce it around on the edge of the screen to show that it's available on the desktop but vanishes when over the Scrivener window.

I paused the recording between closing and reopening to save time, hence the sudden cuts.

Hope this helps a little; sorry it's so long. Also doesn't show the other couple errors I mentioned earlier (requires MS Word or can't find printer drivers). Interestingly, this is on the same machine that earlier needed the printer drivers--now it seems to know about VeryPDF.

Please ignore the typos. :oops:

On another project, brought over from the Mac and about 58MB, trying to compile just doesn't do anything. I select the format, hit compile, wait for some time while nothing happens and then eventually Scrivener just closes the compile dialogue without having done anything. I've made it as far as the "Save As" for the PDF option but it just gives up after a long wait. Scrivener doesn't quit in that case, though, it's just the compile.

Turns out I was wrong about this. It actually did create a PDF, it just gave me zero indication that it had done so. I discovered it later. So that worked; it would just have been nice for some notification. There was no progress bar (no "conversion" step like in the video) or "completed!" message or anything, and since I'd had so much other trouble I just assumed it hadn't worked. Apologies for the misrepresentation.

On the other hand, opening the project again and attempting to compile to PDF just does the spinning mouse of death and a crash as in the videos. Inconsistency. :( The only thing I'm really pretty confident about is that compiling with no text results in a crash. Which is kind of a sarcastic "whoopdeedoo"...Oh well.
Jennifer Hughes
(MM for short)

jm
jmsthornton
Posts: 66
Joined: Thu Feb 17, 2011 12:03 am
Platform: Windows
Location: Melbourne, Australia

Wed Apr 13, 2011 5:28 am Post

jmsthornton wrote:I am absolutely dying for some form of tagging or commenting on individual paragraphs or sentences which does not show up in the main text (like annotations) and which can be separately searched to be added.
MM replied: This really is what the annotations are for, and you can use Find by Formatting to go jump through them in your project, even using "Contains Text" to narrow it down--so if for instance you use a "REDO" tag for your rewrite paragraphs, maybe adding extra text like "REDO: this paragraph really needs more sea monsters", you can then use the FbF tool to search for inline annotations containing "REDO" and then step through your project that way. Once they're added, you'll be able to do something similar with the inspector comments, which will keep that REDO comment out of the text itself.


Thanks so much MimeticMouton. I had to search through the User Manual to work it out, but found it at 18.3.3. Very useful substitute for inline tags. Is there a way to have a "Tips and Tricks for Windows" thread on the forum that does not get confused with the one for the Mac version of Scrivener? Your reply here would be too detailed for the User Manual but perfect for a Tips and Tricks forum message. Plus I am really interested to find out how other people use Scrivener so I can incorporate their good ideas without having to reinvent them.