Highlight color stays

li
linnea
Posts: 7
Joined: Mon Oct 25, 2010 3:32 pm
Platform: Windows

Tue Mar 29, 2011 11:32 pm Post

When I want to remove a highlighted color, the color goes off, but immediately after that the color however comes back. I can't get it to stay away.

Ki
Kimber
Posts: 17
Joined: Fri Nov 05, 2010 3:14 am
Platform: Windows
Location: Halifax, NC, USA

Wed Mar 30, 2011 3:50 am Post

Yep, me too. I posted about it the 26th. Still can't figure out how to fix it, other than re-type the highlighted section. It didn't happen until the 20 update for me.

li
linnea
Posts: 7
Joined: Mon Oct 25, 2010 3:32 pm
Platform: Windows

Wed Mar 30, 2011 12:39 pm Post

Yes, I think it came at the same time, when the menu text "No color" was changed to text "Remove Color".

User avatar
rowanfae
Posts: 40
Joined: Mon Oct 25, 2010 3:20 am
Platform: Windows
Location: Wasatch Mountains

Thu Mar 31, 2011 8:03 am Post

Viral highlighting: The first paragraph of Random Document One was highlighted light blue--on purpose. I went editing through that document, taking out the highlights, and then moved on to Random Document Two. The first paragraph of RD2 was highlighted light blue. It wasn't supposed to be. (There was nothing wrong with the first paragraph of RD2.) So I go back to RD1, and find the highlighting is back. I spend several minutes going back and forth between the two documents, telling it to remove the color, then saving the project on top of the auto-save. I get an idea: I highlight the whole first paragraph of RD1 and the first line of the second paragraph in yellow, then I remove color and save. (You know, in case it had to do with the color.) Now the whole first paragraph of RD1 and RD2 is light blue, and the whole second paragraph of both Random Documents is yellow ... sigh ...
I haven't yet checked to see if this has affected other documents, but I suppose I should. Mostly I'm terrified. (No, in fact, it hasn't spread. Yet.)

I'll be sure to mention if the highlighting continues to be aggressively viral. In the meantime, I'll probably retype the sections so I can continue my editing in peace ...
Using:
Scrivener Beta 0.2.4

System:
Windows 7 Starter on a Gateway netbook
Intel Atom Processor N270 1.60Ghz
32 bit OS with 1.00 GB RAM

User avatar
rowanfae
Posts: 40
Joined: Mon Oct 25, 2010 3:20 am
Platform: Windows
Location: Wasatch Mountains

Thu Mar 31, 2011 8:17 am Post

I retyped four whole paragraphs (some of which were not short), starting with Random Document 2, and when I finished with Random Document 1, I looked at RD2 again, and The First Paragraph Was Highlighted Blue. The paragraph that hadn't been highlighted to begin with. The one that I retyped completely. The yellow was gone, and RD1 (when I went back to check on it) was highlight-free.
I'm not retyping it again. I'm moving on. But if the viral highlighting moves to Random Document 3, I will gnash my teeth a lot, and probably swear at Scrivener an immoderate amount.
Using:
Scrivener Beta 0.2.4

System:
Windows 7 Starter on a Gateway netbook
Intel Atom Processor N270 1.60Ghz
32 bit OS with 1.00 GB RAM

User avatar
rowanfae
Posts: 40
Joined: Mon Oct 25, 2010 3:20 am
Platform: Windows
Location: Wasatch Mountains

Thu Mar 31, 2011 8:54 am Post

The blue highlighting returned to Random Document 1. The yellow highlighting seems to be gone, though.
Using:
Scrivener Beta 0.2.4

System:
Windows 7 Starter on a Gateway netbook
Intel Atom Processor N270 1.60Ghz
32 bit OS with 1.00 GB RAM

li
linnea
Posts: 7
Joined: Mon Oct 25, 2010 3:32 pm
Platform: Windows

Thu Mar 31, 2011 12:09 pm Post

I got at least sometimes the color off, when I selected the colored text and chose in the highlight menu the item "Arbitrary" and there some empty (white) Custom color. So I get the selected text white and the pen icon in the menu, too, gets white.

So I don't try to remove the color, but I color the text white. I don't know if it works always.

User avatar
paulobrabo
Posts: 41
Joined: Fri Oct 29, 2010 5:10 pm
Platform: Windows
Contact:

Thu Mar 31, 2011 2:36 pm Post

I can confirm an identical viral behaviour with Font Color instead of highlight. Beta .21
Windows 7 Home Premium

Ci
Cimeries
Posts: 11
Joined: Mon Oct 25, 2010 10:59 pm
Platform: Windows

Wed Apr 06, 2011 3:40 pm Post

I can confirm this. I have had highlighting appearing over text that was never highlighted in the first place and things that have had highlighting removed getting their highlighting back, which is especially irritating when it's something that wasn't supposed to be highlighted in the first place! This has been quite a pain while I've been collecting my readings for an essay I'm about to do in Scrivener. Though I can't complain - it is a free beta, and it makes essay writing at least 1000000000000000x easier.

User avatar
MimeticMouton
Posts: 8919
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Apr 13, 2011 12:08 am Post

So interesting point on this that I just discovered. After you remove the highlighting in Scrivener and it appears gone, if you open the actual .rtf in another editor that will read the highlighting, you'll see it's still highlighted. Removing the highlighting in that external program and saving (when the Scrivener project is closed) seems to get rid of it for real.

Note though that if you do this, it's really not recommended to edit the files directly in the .scriv folder, so back up your work first. I haven't had any problems just removing the highlighting and saving, but I'm also just working in test projects and I don't have any other fancy formatting or this or that which may get accidentally messed up from the external save. It's probably safe, since the real issue is more about what the .scrivx file and checksums are going to recognize, but just a fair warning for you. Anyway, if it works for you, sure beats retyping. ;)

Also note that WordPad doesn't seem to show the highlight, at least in my case, but if you select all and clear highlighting and save, it works anyway.

(This is working in beta 022 on Win7 Pro 64bit, just for the record. Still an issue with 022, basically. Also seems related to this underline bug, as I referenced there.)
Jennifer Hughes
(MM for short)