Page 1 of 1

disabling/enabling typewriter mode in full-screen

Posted: Tue Dec 13, 2011 6:02 pm
by simeva
After searching the forum I found how to do this: Ctrl-Meta-T (I never heard the key with the Window logo being called 'Meta' before - is that just me or is this a hangover from the Mac version?)

Anyway - I'm bound to forget this, and so my request is that you include a toggle command on the right-click mouse menu, or on the menu bar at the bottom of the page.

Re: disabling/enabling typewriter mode in full-screen

Posted: Thu Aug 09, 2012 8:37 pm
by doceye
I concur.

Re: disabling/enabling typewriter mode in full-screen

Posted: Thu Aug 09, 2012 9:13 pm
by robertdguthrie
"Meta" is from Sun Microsystems, though I have heard people use that word for the Windows key. http://en.wikipedia.org/wiki/Modifier_key "The (Sun) Meta key, Windows key, (Apple) Cmd key, and the analogous "Amiga key" on Amiga computers, are usually handled equivalently." No one I've seen ever refers to a Meta key on the Mac.

Re: disabling/enabling typewriter mode in full-screen

Posted: Mon Aug 27, 2012 7:24 am
by brian747
And, after decades in the software industry salt mines, including many years working for Microsoft partners, I can assure you that no one ever refers to a Meta key on a Windoze keyboard, either. It's always known as "the Windows key", 100% of the time.

If I try very hard I can recall occasional mention of a Meta key, notably during my time as a sysadmin on SunOS and Solaris — and perhaps also (although my memory of this is extremely fuzzy) with GNU Emacs? But not in a Windows context. Ever.

Of course, it may be that everyone else is out of step? :wink:

Cheers,

Brian

[Later edit: My apologies to the OP for the continued OT]

Re: disabling/enabling typewriter mode in full-screen

Posted: Mon Aug 27, 2012 3:02 pm
by pigfender
Yeah, calling it a "meta" key is just confusing. It's the "windows" key. I've never heard it called a "meta" key before, and when I saw it on the shortcut sheet I googled it, but gave up after reading the first two pages of results that didn't tell me the answer.

I am intrigued by the idea of a "super" key and a "hyper" key though.

Re: disabling/enabling typewriter mode in full-screen

Posted: Mon Aug 27, 2012 3:31 pm
by robertdguthrie
I'm going to guess that the cross-over is from Linux, which is a semi-supported beta platform, which treats the windows key on the keyboard as a "meta" key; I can only assume that using a Mac keyboard, the CMD key would be the meta key. I suppose I get the Windows key = Meta key from my past experience with Linux then, if it's not ever referred to in a purely Microsoft context.

Re: disabling/enabling typewriter mode in full-screen

Posted: Mon Aug 27, 2012 4:45 pm
by brian747
I am intrigued by the idea of a "super" key and a "hyper" key though.

<grin> I seem to remember also that on DEC VMS machines there used to be a text editor called EDT which featured a "Gold key". 8)

But this is becoming a little esoteric.....

B.

Re: disabling/enabling typewriter mode in full-screen

Posted: Fri Aug 31, 2012 2:09 pm
by Twolane
@simeva - Thanks for the Ctrl-Meta-T secret on how to disable/enable typewriter mode in full-screen. Yesterday, I was about ready to toss the laptop off the balcony in frustration - although I would have had to retrieve it eventually. Today, I'm doing the happy dance.

Now all I have to do is remember that the Meta key in Windows is the "little flag key thingy". Again, thanks.

Re: disabling/enabling typewriter mode in full-screen

Posted: Mon Nov 05, 2012 6:12 pm
by redgypsee
That seemed to fix my problem-thank you so much. Things were scrolling all over the place-could not cut & paste or control what was going on-virtually unusable-don't remember having this trouble last Nanowrimo. Here's hoping the setting sticks. :D

Re: disabling/enabling typewriter mode in full-screen

Posted: Tue Nov 06, 2012 11:19 pm
by MimeticMouton
The typewriter scrolling settings will stick per-editor in a given project; to change the defaults to off for *new* projects you create, go to Tools > Options... and deselect both typewriter scrolling options in the Editor tab.