Centering custom separators in Scrivener 3

va
valerie1980
Posts: 10
Joined: Thu Mar 25, 2021 6:45 pm
Platform: Windows

Thu Mar 25, 2021 6:53 pm Post

So, it's been a long and arduous time trying to figure out the new compile features, but I think I'm nearly there.

EXCEPT... I can't get my custom separators to center.

I just want three little stars between each scene. * * * CENTERED!!!

It always centered on its own before. Maddeningly, there's this click box at the bottom that says something about ignoring the indent when it's centered, as if it supposed to be centered automatically, and YET. I've tried clicking this and unclicking this to no avail. I have tried creating a new file from scratch, thinking it was picking up some junk code from my old Scrivener files. I have googled and googled and nothing.

HALP.

I am a Scrivener enthusiast, but I feel adrift and lost in a sea of uncertainty and confusion in this new version.

va
valerie1980
Posts: 10
Joined: Thu Mar 25, 2021 6:45 pm
Platform: Windows

Thu Mar 25, 2021 11:45 pm Post

Continuing to play,

Obsessed with making this work.

So... it works in a compile setting for .docx

Just centers nicely on its own with my doing nothing.

But not in an epub, not in a mobi.

This is a bug, right? Will they fix it? I tried to get in and modify the CSS but I'm really flying blind on that. I know a very eensy bit about html and CSS. You can't seem to modify the default spreadsheet which does have the following:

.separator + p { text-indent: 0em; }
.separator + div > p:first-child { text-indent: 0em; }

So I put this in the custom CSS sheet:

.separator + p { text-indent: 0em; text-align: center; }
.separator + div > p:first-child { text-indent: 0em; text-align: center; }

But this didn't work. Furthermore, the custom CSS sheet destroyed all the rest of the formatting, so it wasn't even worth it.

I guess I'm giving up for the night.

:(

va
valerie1980
Posts: 10
Joined: Thu Mar 25, 2021 6:45 pm
Platform: Windows

Fri Mar 26, 2021 3:53 pm Post

All right, I found a workaround, but it has been ARDUOUS.

So, while I was playing, I discovered that when you pull in an old Scrivener document, you get a possible format pulled in which is like called, importedformatv1 or someshizz. Anyway, if you assign your section layouts (you don't get all the fancy choices, however, you get, like, whatever you had set up in your old Scrivener file) you can compile, and THE SEPARATORS WILL BE CENTERED.

I dunno why. I'm guessing the setting is right in the old Scrivener and just wrong right now and needs fixed.

Anyway, so then what I did was basically manually set all the pretty presets that I had in the other settings, which took FOREVER, and I could never figure out how to make the first line of each text section not indented, which looked really slick on the other version, but WHATEVER.

Anyway, I now know more about the compile function in Scrinever 3 than I ever wanted, so that's a plus. And I have my first beautiful epub which I am planning to upload to Amazon today. I also was easily able to compile to MS word and transfer that into my paperback template, no problemo. So... I dunno... I'm up and running now and I'll see if this compile bug ever gets fixed, but I'm happy for now.

va
valerie1980
Posts: 10
Joined: Thu Mar 25, 2021 6:45 pm
Platform: Windows

Fri Mar 26, 2021 4:11 pm Post

And after all that, I ended up going back to the presets, because they are sooo slick. In my wanderings and learnings, I figured out how to add a couple empty lines as a prefix, which separates the scenes nicely without a separator, and looks FAB!

So, anyway, I love the way this looks! Gorge, just gorge!! :) :) :)

Image

li
lizaldenwriter
Posts: 2
Joined: Tue Mar 30, 2021 10:53 pm
Platform: Windows

Tue Mar 30, 2021 10:54 pm Post

Glad you found a workaround that works for you. I'm not ready to give up on centering my custom separator yet!

li
lizaldenwriter
Posts: 2
Joined: Tue Mar 30, 2021 10:53 pm
Platform: Windows

Wed Mar 31, 2021 1:14 am Post

Hey! I figured out a workaround.

I created a new section type: Following Scene.
Every scene after the first one in the chapter got changed to section type: following scene.
Then in compile, I assigned the section type following scene a layout of Section with subheading
I edited the Section layout:
-unclicked the title check box
-added the section break symbols in the prefix (based off of your idea for the extra lines)

Voila!

br
brookter
Posts: 2301
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Wed Mar 31, 2021 9:49 am Post

It doesn't work for me on Windows v3, but the same project *does* work on the Mac. (i.e. just add *** to custom separators between the section layouts used for scenes or text sections: they are centred without any problem — no need for unpleasant shenanigans involving CSS...)

So it looks like a bug in the Windows version — your best bet is to email support with a report of the steps you took so it will be lodged formally as a bug for investigation.

HTH.

jw
jwhitten
Posts: 152
Joined: Sat Oct 12, 2019 6:42 am
Platform: Windows

Thu Apr 22, 2021 3:39 am Post

I just tried your idea on Windows 3 and setting the separator in the Prefix does add the custom text in the right place, but also changes the entire Section Text as well to be the same as the Prefix text, along with the alignment.

So if I do it, the whole section text becomes centered, along with the custom separator. Which is definitely not what I wanted.

Thanks for the idea though.

ch
chrisdr2
Posts: 84
Joined: Wed Oct 16, 2019 9:09 am
Platform: Windows

Thu Apr 22, 2021 4:56 am Post

I had the exact same problem using the beta. My workaround was to create a text file in the binder with a single centered line: ###, then added it as a Custom separator (Separator between sections): <$include:separator_txt>.

This was the resulting separator css:

Code: Select all

<p style="margin-left: 0rem; text-indent: 1.50rem; line-height: 1.0em; text-align: center;">###</p>


The same trick works for separator images, if you replace ### with something like this: <$img:sep_img;w=156;h=20>

sc
scrive
Posts: 77
Joined: Mon Jul 06, 2020 8:05 am
Platform: Mac

Thu Apr 22, 2021 10:54 am Post

With Scrivener+LaTeX, I use the \froufrou package to generate a styled separator.
froufrou.png
froufrou.png (7.02 KiB) Viewed 115 times

Currently, I place the call to \froufrou in the last Section of each Chapter so that it appears at the end of each Chapter (at the end of the last Section within the Chapter) as a way to close out the Chapter.

This requires that I move the call to the \froufrou package to the end of any new Section that I may add to the end of a Chapter.

I was wondering if it might be possible to arrange the Scrivener (and/or LaTeX) code to call \froufrou somewhere or somehow within the Chapter itself, e.g. as some sort of Custom Metadata for the Chapter, instead of in the last Section within the Chapter, to save on a bit of maintenance.

Thanks,
scrive
:?: :idea:
froufrou.png
froufrou.png (7.02 KiB) Viewed 115 times