Newbie Struggling with Compile (wrong font)

User avatar
KangaPivot
Posts: 3
Joined: Wed Dec 23, 2020 11:44 pm
Platform: Windows

Sun Feb 07, 2021 12:12 am Post

I'm working on a six-book hard sf series, and so far have done all the writing in MS Word. I've created several hundred keywords within a Project that I plan to use as a Template for all six (why I set up the keywords first). I left the Courier font for the corkboard. A few months ago, when I got Scriv, I set it up so that all of my text will be in Cambria. Before importing several hundred Word files, I've created a sample ms with just a few sentences in lieu of full scenes just to test the Compile function. It compiles correctly (scenes, subsections, etc.) and I can open it in Word. However, it keeps exporting it in Cambria! I would like it to export into the regular standard acceptable format for fiction mss, But neither the Novel/Fiction ms format (Scriv template I'm using) nor the Times New Roman 12 option will export it in Times New Roman (although that one does change the chapter titles to TNR). I am also able to change the header and footer fonts. Just not the body of the text.. I've watched the videos again, and read the manual again, and tried various Options etc.. (When I go into the setting where I changed everything to Cambria, the Font selector is grayed back and so I can't change it to TNR which I suppose is the last-ditch resort option for Compile.) I've also searched the help forums but can't find this specific problem.
I have also tried going for walks, scrolling through the news feeds on my phone, and complaining to a friend. None of that has fixed the Compiler either, so here I am Asking for Help.

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Tue Feb 09, 2021 6:23 pm Post

KangaPivot wrote:I'm working on a six-book hard sf series, and so far have done all the writing in MS Word. I've created several hundred keywords within a Project that I plan to use as a Template for all six (why I set up the keywords first). I left the Courier font for the corkboard. A few months ago, when I got Scriv, I set it up so that all of my text will be in Cambria. Before importing several hundred Word files, I've created a sample ms with just a few sentences in lieu of full scenes just to test the Compile function. It compiles correctly (scenes, subsections, etc.) and I can open it in Word. However, it keeps exporting it in Cambria! I would like it to export into the regular standard acceptable format for fiction mss, But neither the Novel/Fiction ms format (Scriv template I'm using) nor the Times New Roman 12 option will export it in Times New Roman (although that one does change the chapter titles to TNR). I am also able to change the header and footer fonts. Just not the body of the text.. I've watched the videos again, and read the manual again, and tried various Options etc.. (When I go into the setting where I changed everything to Cambria, the Font selector is grayed back and so I can't change it to TNR which I suppose is the last-ditch resort option for Compile.) I've also searched the help forums but can't find this specific problem.
I have also tried going for walks, scrolling through the news feeds on my phone, and complaining to a friend. None of that has fixed the Compiler either, so here I am Asking for Help.


We can fix it in a Zoom session, if you like.

Find me at https://www.facebook.com/DrMajorBob or drmajorbob@yahoo.com.
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

fp
fpb
Posts: 1
Joined: Fri Apr 02, 2021 1:36 pm
Platform: Windows

Fri Apr 02, 2021 1:39 pm Post

I am having the identical problem. Perhaps you archived your Zoom session?

Frank Boscoe
Portland, ME

User avatar
drmajorbob
Posts: 932
Joined: Sun Jul 01, 2012 1:38 am
Platform: Mac

Fri Apr 02, 2021 10:43 pm Post

fpb wrote:I am having the identical problem. Perhaps you archived your Zoom session?

Frank Boscoe
Portland, ME

Can I archive a Zoom session that was never initiated?

You'd have to ask for one and then we'd have to schedule one.
Teeth, without gums, fall loosely in the mouth.

(I'm not a Literature & Latte employee. Just another user.)

User avatar
MimeticMouton
Posts: 9049
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Apr 03, 2021 5:14 am Post

Have you tried already the font override in the main compile window? Go to File > Compile, select the file format at the top and then the compile format you want to use on the left, and in the centre of the window, above the display of the section layouts used for formatting the manuscript documents, click into the Font box that probably says "Determined by Section Layout" and choose the specific font you want all the text to use.

If that isn't working to produce the correct font (and assuming of course your output format and the program you're opening it in supports the custom font), the issue may be that you've used character styles throughout the manuscript that are either retaining their original font or being overridden with a specific font as part of the compile format. In that case, you'll want to double-click the compile format you've selected, choose to Duplicate & Edit if it is a built-in format, then click on Styles and set up character styles here to match those used in your project so that you can set them to the font you want. (Alternatively, you could update the styles within the project to use the font you want, if they are not already being overridden by the format.) Section 24.4 in the user manual (available from the Help menu) discusses the Styles settings in compile.
Jennifer Hughes
(MM for short)

User avatar
KangaPivot
Posts: 3
Joined: Wed Dec 23, 2020 11:44 pm
Platform: Windows

Wed Apr 14, 2021 6:11 am Post

fpb wrote:I am having the identical problem. Perhaps you archived your Zoom session?

Frank Boscoe
Portland, ME

First, try the steps outlined by MM below. Or, you can discover what drmajorbob so kindly and patiently showed me in our Zoom call (not recorded, so not archived).that I set up with him. Namely, that the button that looked like it should be an option for Text (deep in the bowels of formatting options as described in my initial post) was grayed out. Turns out that it was active, and the gray seemed to have been more of an aesthetic choice on Scriv's part! So first try meticulously following the directions in the manual, then clicking on that button even thought it's grayed out. (Sorry to be so vague, by now I've forgotten it all, except for my solemn vow to never again go in and monkey around with default settings.)

User avatar
KangaPivot
Posts: 3
Joined: Wed Dec 23, 2020 11:44 pm
Platform: Windows

Wed Apr 14, 2021 6:14 am Post

MimeticMouton wrote:Have you tried already the font override in the main compile window? Go to File > Compile, select the file format at the top and then the compile format you want to use on the left, and in the centre of the window, above the display of the section layouts used for formatting the manuscript documents, click into the Font box that probably says "Determined by Section Layout" and choose the specific font you want all the text to use.

If that isn't working to produce the correct font (and assuming of course your output format and the program you're opening it in supports the custom font), the issue may be that you've used character styles throughout the manuscript that are either retaining their original font or being overridden with a specific font as part of the compile format. In that case, you'll want to double-click the compile format you've selected, choose to Duplicate & Edit if it is a built-in format, then click on Styles and set up character styles here to match those used in your project so that you can set them to the font you want. (Alternatively, you could update the styles within the project to use the font you want, if they are not already being overridden by the format.) Section 24.4 in the user manual (available from the Help menu) discusses the Styles settings in compile.

Thanks, MM. I got it sorted out in mid-February, thanks to drmajorbob.